Thread Rating:
  • 1 Vote(s) - 5 Average
No menus, fonts, anything showing up...
#16
they don't exsist and never will they are not needed because PM3 gets all its strings from the main xbmc file not its own like other skins can
Reply
#17
Should it be looking for them then?
Subtitles - Serious Business
Reply
#18
Its a default thing for every skin it checks for the file making a special exception just for 1 skin in the code is inefficiant and not worth the effort besides its not a required file and most non new skins wont have it
Reply
#19
Sorry... can you rephrase that Jezz?
Reply
#20
@schwachs

Does the problem go away if you revert to 0.5.0b1?
Subtitles - Serious Business
Reply
#21
iordonez Wrote:Sorry... can you rephrase that Jezz?

I honestly don't know how to

skin\[SKIN NAME]\language\english\strings.xml

is checked for by XBMC every time it loads a skin (any skin) this file is not needed. It is a recent addition to the skin layout to help skins not part of main xbmc have a language file that can be translated and changed when XBMC changes langauge. Obviously we can't add every skins custom words to the main xbmc strings file.

The file is not needed Making a acception for Project Mayhem III (because it uses all its language stuff is in XBMC main strings.xml) to not spew out the ERROR message is In my opinion pointless. And not worth adding extra code to XBMC

if anything maybe it could be changed to "Warning" other than error
Reply
#22
bmfrosty Wrote:@schwachs

In the log I see:

23:17:48 T:2685812640 M:1078800384 INFO: load language file:/Applications/XBMC.app/Contents/Resources/XBMC/language/English/strings.xml

Does that file exist, and is it readable by user, group, and world?

If you don't know how to check this, open up a terminal and do this:

ls -l /Applications/XBMC.app/Contents/Resources/XBMC/language/English/strings.xml



-rw-r--r-- 1 joshua admin 86041 May 5 23:15 /Applications/XBMC.app/Contents/Resources/XBMC/language/English/strings.xml
Reply
#23
bmfrosty -

yes, it does actually!

on a side note, the "Downloads" link from http://www.osxbmc.com/2008/05/07/release...etta-beta/ isn't working...

http://dn-0.com/xbmc-trac/wiki/WikiStart comes up w/ a server error.

which made finding b1 a little more 'fun' but i was able to google it pretty easily.


bmfrosty Wrote:@schwachs

Does the problem go away if you revert to 0.5.0b1?
Reply
#24
Hi,

Same problem as the above and this is my first install of XBMC. The Console reports the following (if this makes it easier to debug):

5/19/08 12:31:09 AM /Applications/XBMC.app/Contents/MacOS/XBMC[526] CPSGetCurrentProcess(): This call is deprecated and should not be called anymore.
5/19/08 12:31:09 AM /Applications/XBMC.app/Contents/MacOS/XBMC[526] CPSSetForegroundOperationState(): This call is deprecated and should not be called anymore.
5/19/08 12:31:10 AM [0x0-0x66066].org.xbmc.XBMC[526] The XBMC_HOME environment variable is not set.
5/19/08 12:31:10 AM [0x0-0x66066].org.xbmc.XBMC[526] The XBMC_HOME environment variable is not set.
5/19/08 12:31:10 AM [0x0-0x66066].org.xbmc.XBMC[526] The XBMC_HOME environment variable is not set.
5/19/08 12:31:10 AM [0x0-0x66066].org.xbmc.XBMC[526] ++ WARN: could not retrieve file info for `image.nrg': No such file or directory
5/19/08 12:31:10 AM [0x0-0x66066].org.xbmc.XBMC[526] ++ WARN: can't open nrg image file image.nrg for reading


Hope getting a fix as I'm exited to test the application Sad

//megus
Reply
#25
schwachs Wrote:bmfrosty -

yes, it does actually!

on a side note, the "Downloads" link from http://www.osxbmc.com/2008/05/07/release...etta-beta/ isn't working...

http://dn-0.com/xbmc-trac/wiki/WikiStart comes up w/ a server error.

which made finding b1 a little more 'fun' but i was able to google it pretty easily.

It sounds like you found a bonafide bug - one that may only crop up in the os-x version. You would probably be well served by posting a bug report. Possibly include the logs for the version that works, and the version that does not.
Subtitles - Serious Business
Reply
#26
schwachs Wrote:http://dn-0.com/xbmc-trac/wiki/WikiStart comes up w/ a server error.

dn-0.com will be working again this afternoon... the second the owner goes out of town it always goes down (not kidding)
Reply
#27
Also since there are two of you that see this, what system specs are you using, what resolution, Leopard Version, etc. see if we can narrow this down a bit and figure out what you have in common.
Reply
#28
Hardware Overview:
Model Name: MacBook
Model Identifier: MacBook1,1
Processor Name: Intel Core Duo
Processor Speed: 2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 2 MB
Memory: 2 GB
Bus Speed: 667 MHz
Boot ROM Version: MB11.0061.B03
SMC Version: 1.4f12

System Software Overview:
System Version: Mac OS X 10.5.2 (9C7010)
Kernel Version: Darwin 9.2.2

//megus
Reply
#29
and which screen resolution are you using in the system?
Reply
#30
Well,
the resolution on the MacBook is 1280x800 of course, but XBMC runs in a window and since I don't have any text in the interface I can't figure out how to move to full screen...

//megus
Reply



Logout Mark Read Team Forum Stats Members Help
No menus, fonts, anything showing up...51