Android -  How to: Create additional Kodi Channels for Android TV Home launcher (Oreo)
#16
(2018-06-13, 11:17)Tinwarble Wrote:
(2018-06-13, 11:01)graviphoton Wrote: Yes I have used my beloved Eminence 2.0 skin which is not yet supported in Kodi 18 and was automatically disabled after first run.
I understand, I had to stop using Aeon Nox 4 because it was no longer supported and AE 5 wasn't really what I was looking for since it changed. But that's what happens, if you want the latest and greatest you may not be able to use the skin you like.  There's always a chance that a skin author will not update or make drastic changes with the skin, but you shouldn't sacrifice looks for features.

You might want to look through the WIP skins https://forum.kodi.tv/forumdisplay.php?fid=160  there are some new skins which are Leia compatible and you may end up liking more.  
Oh, thanks for pointing to this URL, some of these (unfinished) skins look really promising. And there is even skin Aura from Eminence's author with similiar style which definitely I will try.
Update 2018-06-15: Aura it is. Generally displayed information is very condensed but yet readable. Lists are very similiar. Eminence is better (for me) but I like this skin. :-)
 
(2018-06-13, 11:17)Tinwarble Wrote:
(2018-06-13, 11:01)graviphoton Wrote: vThe biggest issue I have is generating false movies items with the same title when updating library. These entries start TV shows episodes which are not in movies folder/source (very strange). Cleaning library removes these bogus entries but after updating library they are back. I spent almost hour finding what is wrong but I didn't come to any conclusion yet. It needs further investigation.
If it's a matter of the file name, why not just use a different name and then changing the sort order name if it's just a matter of the sort/display name? You can also just use the Link to TV Show in the context menu. Then you're movie will show up in the TV Show folder.   
It is more complicated, some of my episodes are in TV Shows with correct name and at the same time under newly added movies with nonsensical names as "1" (at least it plays the same episode). If it is not some stupid configuration error I will describe it more thoroughly in appropriate thread.
Update 2018-06-15: Problem solved. It was another stupid error on my side. Putting Kodi backup to library's searching path is not good idea...
Reply
#17
How long should it take for the playlist to appear as an available channel on the Oreo launcher?

I've added a few smart playlists, restarted Kodi a couple of times and rebooted by Nexus Player and still only getting the suggestion channel (which is rubbish!) shows up...
Reply
#18
On Nvidia Shiield Android TV channel appears almost immediatelly but showing all items (or displaying picture of new items in list) is sometimes very very slow... it can last for several restarts.
Reply
#19
Okay, they appeared after about an hour. Took overnight for thumbnails to show and even though the smart playlist has updated (latest TV shows) the home screen hasn't noticed.

I get the feeling that Google just don't know what they're doing with the home screen under Oreo - YouTube still won't show us our own subscriptions but is intent on showing us things we're not interested in. Which is ridiculous as Google probably knows me better than my family so should be spot on with recommending me things to watch!
Reply
#20
All I’m getting, after following the guide, is channel empty.

The list shows up in Kodi and shows the movies and at the launcher it shows the playlists/channel but says channel is empty and thus not selectable.

I have tried deleting and redoing them. Three of them have been left more than 24 hours and still nothing
Reply
#21
Hi,

Thank you for the tutorial, it works really good for me.

The only thing I can't solve is how to update the recently added TVshows and movies channels without start kodi. The NAS add content automathically to my library and it's connected with SMB to the Shield. Kodi updates library on every start and add new content to the channel (needs a really long time to update the channel by the way). Is there a way to update the library when the NAS add content so I could watch it in the channel when start the Shield?

Thank you again because now it's easier to access all media.

PD: Sorry if the question is not exactly related to this post
Reply
#22
(2018-07-01, 11:30)Jbev01 Wrote: All I’m getting, after following the guide, is channel empty.

The list shows up in Kodi and shows the movies and at the launcher it shows the playlists/channel but says channel is empty and thus not selectable.

I have tried deleting and redoing them. Three of them have been left more than 24 hours and still nothing
 I believe the recent Nvidia update broke this feature. I read something on the Nvidia forums about it being a known issue but cant find the pot ATM.
Reply
#23
Thanks for the post I follow the instruction and got no problem yet, though it take me a while to complete and understand it.
Reply
#24
(2018-07-16, 19:58)Hardax Wrote:  I believe the recent Nvidia update broke this feature. I read something on the Nvidia forums about it being a known issue but cant find the pot ATM. 
  
No, the Shield update did not break this feature regardless of what has been said in the Nvidia forums. It's still working fine for me as well as for others and if anything it would have been a Android TV Home launcher update (there have been several) that would have caused the issue. However, the issue may be on our end.

Forum Rules (wiki) | Banned add-ons (wiki) | Wiki (wiki) | Quick start guide (wiki)
Reply
#25
I guess it's pointing to the fact that the channels must be pre-populated before they can be added to the home screen now, as I told you.
Once the channel has been added from the shield beta (they only added this "feature" at the last minute) you won't notice, but you couldn't add new ones, as Kodi only populated the channels *once they were added*, based on how it worked then.

It's the same on the mi box, so it's clearly a last minute change from google, nvidia is not to blame (besides shipping a final version different from the beta).
Pretty stupid to force using resources to populate channels that might never be used, imao, but hey...

Although I indicated what had to be done, this hasn't been fixed in master, yet, apparently.
Reply
#26
@Koying Is this it?

https://github.com/xbmc/xbmc/pull/14170
Reply
#27
(2018-07-19, 02:28)Tinwarble Wrote:
(2018-07-16, 19:58)Hardax Wrote:  I believe the recent Nvidia update broke this feature. I read something on the Nvidia forums about it being a known issue but cant find the pot ATM. 
  
No, the Shield update did not break this feature regardless of what has been said in the Nvidia forums. It's still working fine for me as well as for others and if anything it would have been a Android TV Home launcher update (there have been several) that would have caused the issue. However, the issue may be on our end. 
 I'm having the same issue. It was working for me with Kodi Alpha 1 64-bit, but decided to remove, and do a fresh install of Alpha 2 and add my video libraries... and now I get this:

Image
[H]i-[d]eft [M]edia [K]een [V]ideosaurus
My Family Room Theater
Reply
#28
Yes, see @Koyings comments above.  I've been working on getting the fix implemented, per Koyings suggestions, but as I'm not a dev I've had some difficulties getting things right.  Hopefully I've done the necessary things in the code to fix the issue, the fix should be in a future Kodi nightly (will notify when it does).

Until then though, you can try uninstalling updates for Android TV Home (the launcher) and see if that fixes things.

Forum Rules (wiki) | Banned add-ons (wiki) | Wiki (wiki) | Quick start guide (wiki)
Reply
#29
Reverted to Kodi 18 Alpha 1 to check, and same issue, except oddly only 'Suggestions' can be enabled and works, but my own playlists are unselectable. Will wait for a fix.

Edit: Happening now with Alpha 2 as well. I see other apps with the same issue (Google Play Music).
Reply
#30
(2018-07-21, 01:43)Tinwarble Wrote: Until then though, you can try uninstalling updates for Android TV Home (the launcher) and see if that fixes things.

This works, just tried and can now populate the channel

Thanks v. Much
Reply
 
Thread Rating:
  • 2 Vote(s) - 3.5 Average



Logout Mark Read Team Forum Stats Members Help
How to: Create additional Kodi Channels for Android TV Home launcher (Oreo)3.52