Solved -  NFS Sub folders inaccessible
#1
Followed the wiki for qNap, slightly different screenshots but got there.

From Kodi I can browse, see the IP of my qNap and see a whole bunch of folders below but then can't get into the folders.
I'm sure it's just a permissions thing but where, any ideas?

/etc/exports
"/share/CACHEDEV1_DATA/Kodi" 192.168.1.159(ro,async,no_subtree_check,insecure,no_root_squash)
"/share/NFSv=4" *(no_subtree_check,no_root_squash,insecure,fsid=0)
"/share/NFSv=4/Kodi" 192.168.1.159(ro,nohide,async,no_subtree_check,insecure,no_root_squash)
"/share/CACHEDEV1_DATA/Public" *(rw,async,no_subtree_check,insecure,no_root_squash)
"/share/NFSv=4/Public" *(rw,nohide,async,no_subtree_check,insecure,no_root_squash)

/etc/config/nfssetting
[Global]
Version = 4.3.4

[Access]
/share/CACHEDEV1_DATA/Public = TRUE
/share/CACHEDEV1_DATA/Kodi = TRUE

[AllowIP]
/share/CACHEDEV1_DATA/Public = *
/share/CACHEDEV1_DATA/Kodi = 192.168.1.159

[Permission]
/share/CACHEDEV1_DATA/Public = rw,insecure
/share/CACHEDEV1_DATA/Kodi = ro,insecure

[SquashOption]
/share/CACHEDEV1_DATA/Public = no_root_squash
/share/CACHEDEV1_DATA/Kodi = no_root_squash

[AnonUID]
/share/CACHEDEV1_DATA/Public = 65534
/share/CACHEDEV1_DATA/Kodi = 65534

[AnonGID]
/share/CACHEDEV1_DATA/Public = 65534
/share/CACHEDEV1_DATA/Kodi = 65534
Reply
#2
Sorted was down to using NFS v4 only
Reply
#3
Thread marked solved.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#4
I am having a similar trouble sharing NFS shares from my QNAP to Kodi. Currently I have both "NFS v2/v3 Service" and "NFS v4 Service" enabled in QNAP control panel. Did you disable NFS v4 to make it work? I am a little hesitant changing things up as I am rather new to this..
Reply
#5
Yeah I turned NFSv4 off totally. I only use NFS for Kodi so it wasn't an issue for other services.
Reply
#6
You both are able to use NFSv4 if you choose to use system mounts instead of Kodi mounting the shares.

Depending on the underlying OS, which we currently don't know yet, it 'should' support NFSv4. Ubuntu does, btw.
Reply
#7
I use fstab to mount the file system before Kodi, it didn't work with NFS v4 on a Raspberry Pi or Vero4k, on NFS v3 worked straight away.
Reply
#8
On my libreelec boxes I have moved over to using system mounted nfs volumes and use path substitution in advancedsettings.xml so the database still points to nfs shares. (need that on my android boxes)

Seems to me that the nfs in kodi works sometimes and sometimes it just freezes the client for up to 5 minutes.
If my post helped you then there is a nice "Thank user" button on the bottom of the post.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
NFS Sub folders inaccessible00