Need help troubleshooting movie set art.
#1
I can't get my movie sets to show custom poster in kodi 17.6. I have done the following:
  • In Settings > Modules > Kodi Interface: Kodi MovieSet Artwork Folder: smb://192.168.1.100/moviesetart
  • In \\192.168.1.100\moviesetart, I have files in format <movieset name>-poster.jpg.
  • I sync the movies in moviesets.
  • Does it matter that my movie sets don't have a tmdb collection id? I don't care about scraping movie set info but just want it to use the poster I add manually.
How do I troubleshoot this?
  • The kodi non-debug log doesn't show anything about trying to access the share specified above.
  • The .nfo file associated with each movie only has the following item about sets:
      <set>
        <name><movieset name></name>
      </set>
    So is it normal to not see anything about the movieset poster in the .nfo file?
  • So is the "Kodi MovieSet Artwork Folder" info stored only in the kodi database and not in any nfo file? If I'm using mysql, can I look at the database to confirm this setting is in place?
On kodi wiki, it mentions that I can just put a movieset-poster.jpg in the folder of each movie. Does that really work?
https://kodi.wiki/view/Movie_artwork#Movieset_Fanart
Reply
#2
(2018-06-17, 01:22)badbob001 Wrote: I sync the movies in moviesets.
You have to sync the movieset, not the movie.
(2018-06-17, 01:22)badbob001 Wrote: Does it matter that my movie sets don't have a tmdb collection id? I don't care about scraping movie set info but just want it to use the poster I add manually.
No, it's not important and only needed in Ember to scrape the movieset images and informations from TMDb.
(2018-06-17, 01:22)badbob001 Wrote: So is it normal to not see anything about the movieset poster in the .nfo file?
Yes. Kodi can't handle movieset images, so it's not needed to save the path in the movie NFO. To show the movieset images in Kodi you need the Kodi Interface or an addon like MSAA or AB in Kodi. But the KI in Ember is the easiest way.
(2018-06-17, 01:22)badbob001 Wrote: So is the "Kodi MovieSet Artwork Folder" info stored only in the kodi database and not in any nfo file? If I'm using mysql, can I look at the database to confirm this setting is in place?
No. The KI and the Kodi addons save the path to the image in the Kodi database like all other images for movies and tv shows.
(2018-06-17, 01:22)badbob001 Wrote: On kodi wiki, it mentions that I can just put a movieset-poster.jpg in the folder of each movie. Does that really work?
Only with the Kodi addons that are listet on the wiki page.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
#3
I still can't figure out how to get movieset posters to work through EMM, so I set the movieset poster from within kodi itself:
  • Go to Movies Sets.
  • Open context menu on a movieset > Manage... > Choose art > Poster > Choose poster that is stored on network share.
This works and the change is reflected in my other kodi nodes as well (all running 17.6), no special addons needed. No doubt kodi 18 will fubar this. Smile

In EMM, when editing a movieset, what is the purpose of the Poster tab? It's unclear where those posters go and what is changed in kodi. Perhaps it's only to support certain addons.
Reply
#4
Please read this tutorial: Link
Write again if you've still problems.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
#5
Followed the tutorial more closely with a new movieset but still no luck. Below is what I have and the process tired, which results in the movieset having a generic poster (shows video camera icon). Well, at least it's not using the cover of one of the movieset movies.

Following EMM settings in place. Note that _MovietSetArt folder under the Movies folder so network access to the folder is not an issue. Can the underscore in "_MovietSetArt" be an issue?
Image

Not sure if the following is needed since the tutorial seems to mix settings needed for MSAA. Note that the path is different format from the one used in the Kodi Interface, per tutorial screenshots.
Image

Process when adding 
  1. <new movieset name>-poster.jpg is copied to folder. Max dimensions of image is 1000.
  2. New movie set created in EMM.
    Details tab: Collection ID is left empty.
    Movies tab: movies added.
    Poster tab: not touched.
  3. Real-time sync is enabled so movieset should be automatically synced to kodi. But for giggles, also right-click movieset name > Kodi Interface > Sync.
When syncing, the debug log shows the following. Are all the database deletes normal?
Quote:11:05:38.970 T:17268   DEBUG: CWebServer[8080]: request received for /jsonrpc
11:05:39.539 T:28608   DEBUG: Previous line repeats 5 times.
11:05:39.539 T:28608   DEBUG: CVideoDatabase::RunQuery took 538 ms for 119 items query: select * from movie_view  JOIN sets ON movie_view.idSet = sets.idSet ORDER BY sets.idSet
11:05:39.681 T:28608   DEBUG: CWebServer[8080]: request received for /jsonrpc
11:05:40.032 T:28368   DEBUG: Previous line repeats 1 times.
11:05:40.032 T:28368   DEBUG: CVideoDatabase::RunQuery took 324 ms for 19 items query: select * from movie_view  JOIN sets ON movie_view.idSet = sets.idSet WHERE sets.idSet=18 ORDER BY sets.idSet
11:05:40.413 T:28368   DEBUG: CVideoDatabase::RunQuery took 347 ms for 19 items query: select * from movie_view  WHERE movie_view.idSet = 18
11:05:40.449 T:28368   DEBUG: CWebServer[8080]: request received for /jsonrpc
11:05:40.769 T:28364   DEBUG: Previous line repeats 1 times.
11:05:40.769 T:28364   DEBUG: CVideoDatabase::RunQuery took 294 ms for 19 items query: select * from movie_view  JOIN sets ON movie_view.idSet = sets.idSet WHERE sets.idSet=18 ORDER BY sets.idSet
11:05:40.779 T:28364   DEBUG: Mysql Start transaction
11:05:40.779 T:28364   DEBUG: Mysql execute: UPDATE sets SET strSet='Pixar', strOverview='' WHERE idSet=18
11:05:40.847 T:28364   DEBUG: Mysql commit transaction
11:05:40.937 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='banner'
11:05:40.943 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='characterart'
11:05:40.945 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='clearart'
11:05:40.947 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='clearlogo'
11:05:40.950 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='discart'
11:05:40.953 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='extrafanart'
11:05:40.955 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='extrathumbs'
11:05:40.957 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='fanart'
11:05:40.960 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='landscape'
11:05:40.962 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='poster'
11:05:40.964 T:28364   DEBUG: Mysql execute: DELETE FROM art WHERE media_id=18 AND media_type='set' AND type='thumb'

Checked results on an android instance in case it's a display issue on window instance, but same results.
Reply
#6
Interesting observation: For a movie within the movieset with a generic icon, I fix a typo in the movie's title and then the movieset now has the poster of that movie. I sync the movieset itself and now the movieset icon is back to the generic icon. So does updating a movie break the custom movieset poster? Not a big issue but just have to remember to sync movies again afterwards.
Reply
#7
  • you've to check that the "Kodi MovieSet Artwork Folder" has the right upper and lowercase (Kodi on Linux/LibreELEC is case sensitive)
  • an image can only be synced if Ember has recognized the image (green flag in the list, see screenshot)
    If you manually add an image to the movieset folder than you've to rescan that movieset with F5. Otherwise Ember removes/cleanup the folder after edit or scraping!
The edit dialog shows up if you create a custom movieset. Why you don't use the "Poster" tab to manually add an image? You also can drag&drop to load an image from webbrowser or Explorer.

Summary:
If Ember does not know that there is an image then he can't send Kodi a path to that image.

Image
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
#8
Thank you! I got it! The missing piece was to not manually place the movieset posters in the shared folder but to add them through the movieset poster tab.

What confused me was this part of the tutorial:
Quote:You can choose between the standards for the Kodi Interface and the Kodi Addon "MSAA". The two standards use matching and different file names. Also, DiscArts are not supported by MSAA. An overview of the used file names can be found here: Link
The link to the file names info made me think that I actually have to worry about that detail when it doesn't really matter.
Reply
#9
Ember recognize only file names that are enabled in the "File Naming" settings. There also is an option to set custom file names that are complete deviant from all known standards.
The KI can sync ANY path/file name of images to Kodi. The only condition is that you've added the file names to Ember and he recognized it (green flag). The KI simple replace the Ember source (or folder) path with that path you've mapped in the KI Host settings. So long Kodi has the access rights for this path it can show the image in Kodi... even it's "smb://movies/Avatar/my-really-bad-named-poster.jpg".

Ember only saves one path to an image in the own database and the preferred on is "Kodi defaults => Kodi Interface => Kodi Addons => Expert File Naming". So usually the default Kodi or Kodi Interface file name will be synced to Kodi.
German Ember Media Manager Support

Daily Builds - Link
Latest official Ember-MM version - Ember Media Manager 1.4.x
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Need help troubleshooting movie set art.00