•   
  • 1
  • 13
  • 14
  • 15
  • 16
  • 17(current)
Internet Archive Game Launcher
Thanks Zach!  Exactly what I needed!
Reply
Sorry Zach, I can't seem to get retroarch launching correctly. 

I created a list with a single game in it, updated the download path and set it to external launcher.  When I try to load the game it loads the Kodi RestroPlayer list.  Upon looking at the log there are 2 errors:
13:11:36.263 T:5324   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.program.iagl/game/_MAME_Ext_Launcher/Missile+Command+%28rev+3%29
13:11:36.273 T:18268   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.program.iagl/game/_MAME_Ext_Launcher/Missile+Command+%28rev+3%29) failed

Both the location of retroarch.exe & system paths are both configured in the IAGL settings.  Here is a copy of the list .XML.
https://pastebin.com/7bNk4Bhz

I'm not sure why its not finding my external RA launcher.  Tried using the rom_override_cmd but with the same results.
Reply
First wanted to say thanks for all the hard work that goes into making this addon and then maintaining it. i am having a problem with amiga games. it always says download failed. all the other systems i tried worked fine,wondering if this is just a problem with archive.org or something setup wrong on my end  thanks
Reply
(2019-02-08, 23:30)SimonC Wrote: Sorry Zach, I can't seem to get retroarch launching correctly. 

I'm not sure why its not finding my external RA launcher.  Tried using the rom_override_cmd but with the same results.

Those error messages are a red herring, and not necessarily a problem (Kodi just doesn't like the info window that IAGL uses and says it doesn't see that as a valid directory). I'd need a full debug log to know what the problem might be. Here's some general troubleshooting tips.
Reply
(2019-02-13, 01:45)Phert Wrote: First wanted to say thanks for all the hard work that goes into making this addon and then maintaining it. i am having a problem with amiga games. it always says download failed. all the other systems i tried worked fine,wondering if this is just a problem with archive.org or something setup wrong on my end  thanks

Amiga game launching is currently borked with Retroplayer - the reason is that IAGL creates an M3U file listing all the game disks (adf files) to launch, but Kodi recognizes M3U as a playlist for video/audio. There's a github issue in Kodi for it, but no solution yet. It works when using external launch of Retroarch.

Eventually, I will update the Amiga game list for hdf support which was recently added, but that too is not really working well in either Kodi or Retroarch (it just crashes in OSX).
Reply
(2019-02-13, 04:12)zachmorris Wrote:
(2019-02-08, 23:30)SimonC Wrote: Sorry Zach, I can't seem to get retroarch launching correctly. 

I'm not sure why its not finding my external RA launcher.  Tried using the rom_override_cmd but with the same results.

Those error messages are a red herring, and not necessarily a problem (Kodi just doesn't like the info window that IAGL uses and says it doesn't see that as a valid directory). I'd need a full debug log to know what the problem might be. Here's some general troubleshooting tips. 
 Thanks Zach, unfortunately the rest of the Kodi log doesn't show anything else.  I did get Retroarch working but that was establishing it as the launcher for an emulator, in this case it was 3DO.  

What I was attempting to do in my previous message, which I should have noted.  I use RetroPlayer for pretty much everything.  I do have some MAME roms which don't work however.  What I did was go into my MAME IAGL list, find the problem game and add it to a new list which will be used to launch it with RA.  In this new list I then update the download path, set it to external launcher.  Because the game was in a previous list seems to be the issue.  The pastebin I posted is an example of a game in a new list which was added from an existing list.  Was there anything in that list I should modify in order for it to correctly launch RA?
Reply
Thanks for the quick reply, will use retroarch. And thanks again for this great addon
Reply
Hi @zachmorris I am having problems checking my translation in the real environment on Kodi. All new strings that I have entered are ignored. The log shows me this error, what can be done? Can you guide me?
For example thist line...
ERROR: POParser: missing msgstr line in entry. Failed entry: 
                                            msgctxt "#30058"
                                            msgid "Choose from List"
                                            msgid "Seleccionar de un listado"
IAGL it does not show the changes. Why?
Sony BRAVIA KD-55XF9005 | The Official Kodi Wiki is your friend
Reply
ImageHey Zach, Scumm VM games have incorrect file sizes. Just letting you know.Image
Reply
Hello there. I have an issue when I try running a game. 
First of all, thanks for the addon. 
So, on my Windows 7 PC running Kodi 18 everything works fine. When I first time installed the addon, it automatically downloaded the emulators and everything works just fine, on the other hand, on my Ubuntu 18.04 PC, also running Kodi 18 I can't get any emulators. I read somewhere that some emulators are available in the original Kodi repo, but there are no. 

It makes me wonder... why did I get a bunch of emulators already pre-installed on my Windows machine, but not my Ubuntu machine. 
Note: I followed the same guide.

Thanks in advance.
Reply
  •   
  • 1
  • 13
  • 14
  • 15
  • 16
  • 17(current)
 
Thread Rating:
  • 4 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Internet Archive Game Launcher54