Not aligned colour-layers when playing video with Nouveau drivers
#1
I am unable to use official Nvidia drivers on my Linux client; otherwise KODI works perfectly.

Using the open-source drivers "Nouveau", instead, KODI shows any video (streaming/file/etc) with not aligned colours: see screenshot.

Image

I already tried any possible video calibration..
Nobody experience this issue ?

See also my logs: https://pastebin.com/a3ecpWH9
Reply
#2
Why can't you use the proprietary NVidia drivers?

Using Kodi with Nouveau drivers is not supported.
Reply
#3
Quote:14:18:27.214 T:139900709720192  NOTICE: GL_RENDERER = Gallium 0.4 on NV50
14:18:27.214 T:139900709720192  NOTICE: GL_VERSION = 3.0 Mesa 13.0.6

Is this a printing error? Mesa 13.0 is getting 2 years old ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#4
I can't install Nvidia drivers since they are very unstable with my card (340-legacy version), actually not usable at all, in my double-monitor configuration... I really tried every single setting, but no luck..
Nouveau is quite stable and works fine for me.
Reply
#5
(2018-06-24, 16:38)fritsch Wrote:
Quote:14:18:27.214 T:139900709720192  NOTICE: GL_RENDERER = Gallium 0.4 on NV50
14:18:27.214 T:139900709720192  NOTICE: GL_VERSION = 3.0 Mesa 13.0.6

Is this a printing error? Mesa 13.0 is getting 2 years old ... 
 You might know that Debian has very old (but stable) versions of software... If you think may fix the issue, I could easily update Mesa to 17.3, using "backports" as Debian call them...
https://packages.debian.org/source/stret...ports/mesa
Reply
#6
Worth a try. It might add NPOT texture support.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Not aligned colour-layers when playing video with Nouveau drivers00