Vbox PVR add-on breaks Kodi on shield TV after updating to latest version of Android?
#1
Is anyone else having problems with the vbox PVR add-on sincere upgrading their shield tv to the latest Nvidia os? After updating Kodi just keeps crashing as soon as I tried to run it, so I uninstalled and reinstalled and it was fine until I enabled the vbox add-on in Kodi, after which it just crashed and would-be run again. I want sure if it was just an issue with that version of Kodi but I've now uninstalled and reinstalled with Leia alpha 1 and 2 and even tried the Krypton one from the play store but they all do the same; crash as soon ai enable the vbox add-on and will no longer run past the Kodi loading screen.

Any ideas? I got the vbox solely for user in Kodi so it kind of makes it defunct if it won't work for me!
Reply
#2
Hi 
Vbox team are working to resolve this  

Since Vbox device is  fully support with M3u/UPNP 
We suggest you to run a 3rd add-on  such as PVR IPTV simple client
In order to do so You need first to  disable Vbox add-on 
Then configure the PVR IPTV simple client
As follow : 
1.    location >local path (include local network)
2.    M3U playlist path >UPNP devices >detect your Vbox device>vbox simple IPTV

Sometime the KODI needed to be restarted after the configuration is  being done  
And thanks for bringing up this to our attention
Reply
#3
Hi... just wanted to add I had the same experience i.e. updated Nvidia shield tv to latest android and now kodi won’t start with the vbox addon enabled.

Kodi starts fine without it but enabling the add on seems to prevent kodi from loading at all (17.6 as well as the alphas).

However, simple iptv addon as described above works well. The only things I would add are:
- the ‘upnp’ option doesn’t appear in the new alpha versions...(17.6 works as described)
- you also need to find the xml file for the guide in the iptv simple client setup (I think it’s called vboxxmltv.xml...it’s the last entry on the file list)
Reply
#4
I've tried using simple iptv but I can't get it to load the EPG. I can get it to pick up the channels but when I try to point it at the EPG xml file it then displays no channels at all. 

Hopefully the VBox addon with be fixed quickly!
Reply
#5
Yep I had the same problem as well...i.e. I added the xml file and everything disappeared ...I think the add-on needs to be reset after you do this.

That is, I added the EPG and everything disappeared but then when I went back into the iptv simple client add-on setup, hit disable and then hit enable, all the channels came back plus the EPG. It's almost like you need to turn it off and on to refresh it.

I've put the shield to sleep and then turned it back on and the channels+EPG are still there. However, if I manually exit Kodi then the all channels are gone, and I need to do the disable/enable thing in the add-on again to get them back. It's not perfect but it works - at least until the vbox team fix their add-on. Also, I don't think iptv simple client allows for recordings or pausing TV Sad

As an alternative, I noticed there is a vbox app in the google play store called "Vbox Live Channels" which is quite easy to set up and lets you stream from the vbox to the "Live Channels" app on the shield (along with EPG, recording, pausing live TV etc.). I don't think Vbox Live channels existed when I got my shield last year. The Live Channels app interface is a bit weird looking for my taste and not as flexible as Kodi, but it might be a better solution until the vbox Kodi app is fixed.
Reply
#6
Exactaly the same issue I’m having. Was going to report in it last week but been on holiday so didn’t have time.

Excellent you are on the issue :-) I’m currentlay using the android app which is working ok

Cheers
Reply
#7
Any news on this? I really need this working
Reply
#8
The vbox team posted an update last week that this was fixed in the Alpha release

(see http://community.vboxcomm.com/viewtopic....3413bc53a9)

However, I tried this and it still appears broken on my Shield i.e. same crashing as before. Not sure if I just didn't install it right, or I didn't install the right version. I suspect we will need to wait for the vbox addon for Kodi 17 to be fixed, which still appears to be work in progress.
Reply
#9
It works for me using this build except trying to play back recordings - they crash Kodi.
Reply
#10
Is there any way of downloading the latest version of the addon and manually updating Kodi 17.6? I dont want to use Kodi 18 as it doesnt work very well for me whereas 17.6 does.
Reply
#11
I don't think they have released a fix for version 17.6 as I tried the latest last night.

I am running 18 nightly and it working  about 80% ok

recordings are fine and live tv is OK but sometimes you have to when first into kodi is select a tv channel a few times before its starts to play properly.

some times its starts to play then freezes , and then after a time starts to flash the 100% buffer symbol every few seconds..... not too sure on that one
Reply
#12
I don't think they have released a fix for version 17.6 as I tried the latest last night.

I am running 18 nightly and it working  about 80% ok

recordings are fine and live tv is OK but sometimes you have to when first into kodi is select a tv channel a few times before its starts to play properly.

some times its starts to play then freezes , and then after a time starts to flash the 100% buffer symbol every few seconds..... not too sure on that one
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Vbox PVR add-on breaks Kodi on shield TV after updating to latest version of Android?00