v17 -  How to change default music player
#1
I’m looking to change default music player to PAPlayer as it’s cutrently set to VideoPlayer. Right now I can only use PAPlayer if I bring up context menu then click play using and select PAPlayer.

Device: Fire TV gen 3
Version: Krypton 17.6
Reply
#2
Seems a strange question as PAPlayer is the default music player so you must have changed once to use VideoPlayerHuh Check if you have an advancedsettings.xml containing an audio section and defaultplayer setting, if you do then delete it. Refer to https://kodi.wiki/view/Advancedsettings.xml
Reply
#3
Here’s what I mean by it showing VideoPlayer as default player:

Image

And here’s what my advanced settings look like - there’s barely anything there.

Image
Reply
#4
To receive meaningful assistance you will need to provide a full debug log.

The instructions are here... debug log (wiki)

If you are using the Basic Method, then ensure the following is applied...
1.Enable debugging in Settings>System Settings>Logging,
2.Restart Kodi
3.Replicate the problem.

If you are using the Advanced Method ensure you have correctly created and applied the advancedsettings.xml file.

In both instances, you should see the word DEBUG throughout the log.

Note: Full logs only. No partial or redacted logs
Do NOT post your logs directly into the forum. Always use a paste site like pastebin.com. Post the link to your pasted log in the forum
Reply
#5
Please replicate playing something with debug logging enabled using above instructions. You've either

a) Not got an official Kodi build but something that has been modified.
b) You have an addon installed that has changed something
c) Kodi is not using the advancedsettings.xml you think it is.

There is no way a clean install of a Official Kodi build will be using VideoPlayer for music.
Reply
#6
Actually I see I could be wasting my time looking at your post history. Are you still trying to use stiff from those dodgy repos that got your last thread binned? if so then sorry if you get stiff from such disreputable sources you're on your own or you find support elsewhere.
Reply
#7
No I reset Kodi and this is from the Apple iTunes Podcast addon shown here:

https://kodi.wiki/view/Add-on:Apple_iTunes_Podcasts
Reply
#8
Well that's your answer then, that addon reports itself as a video addon which why VideoPlayer is default.
Reply
#9
Ok then is there anyway to change the default player to PAPlayer? I’ve looked all through settings and can’t see anything about setting default player.
Reply
#10
The only way via the core would be change the default player for video, but then wouldn’t get sny video playback. This behaviour is down to the way the addon identifies itself there you need to probably modify the addon, find if there’s a support thread for it and ask there.
Reply
#11
May I ask how it is you can tell it’s a video addon? I downloaded it in the music addons section. Just curious.
Reply
#12
Check with the Add-on developer, this is not a Kodi issue, its just how the Add-on was written.
[Image: addon-TheMealDB-blue.svg] [Image: skin-EstuaryATF-green.svg]
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
How to change default music player00