Solved "Could not connect to repository"
#1
Fresh install of Windows 10. Fresh install of Kodi 18 (latest developer build).

Trying to install addons from the official Kodi repository results in the error "could not connect to repository"

A Kodi 17 install works fine.

Please help - this has been driving me nuts for over a week now!

Logs:

https://pastebin.com/UzPSuXYh
Reply
#2
Can you connect to https://mirror.math.princeton.edu/pub/ in your browser?
Please try again opening the repo a few times, not only once and share the Debug log (wiki) again.

Edit: If it still doesn't work also share a log with libcURL component logging enabled.
Reply
#3
Yes I can connect to that URL via a browser.

New logs here with multiple attempts to connect:

https://pastebin.com/HMLAa311

Will try the more advanced logging in a few minutes.

This wouldn't have anything to do with the fact that Ive installed Kodi as portable would it?
Reply
#4
(2018-08-03, 14:58)Rechi Wrote: Can you connect to https://mirror.math.princeton.edu/pub/ in your browser?
Please try again opening the repo a few times, not only once and share the Debug log (wiki) again.

Edit: If it still doesn't work also share a log with libcURL component logging enabled.
Here are logs with libcURL logging enabled:

https://pastebin.com/TgzKfxuB
Reply
#5
Just tried the same development build install on my Mac and I am able to access the official repo without issue so its not my network/internet access. Something with either the specific windows build (but you would think there would be others complaining about it?) or something within Windows 10 itself?
Reply
#6
Just installed a video add-on, using Kodi 64/bit (18.0-BETA1 Git:20180731-e3dd2e42d5) on a win/64/7 no issues.
Reply
#7
Thought I would be clever and install the latest dev build on virtual Windows 10 setup I have on my Mac laptop. As expected, it works fine. I installed it as a portable so I could bring it over to this Windows PC that is not working.

I can now access the official repository but when ever I try to install anything it fails. I attempted to install a couple of UI sounds and the logs are here:

https://pastebin.com/v1bhmsRe

This is obviously a Windows issue of some kind but there has to be some sort of resolution? There is talk in this thread about some sort of proxy server being used? (333005 (thread)) I have no proxy's setup in either Kodi or Windows but the OP in that thread didn't either. Like I said, this is a brand new Windows 10 install with nothing but network and video drivers loaded.
Reply
#8
Also tried changing DNS servers back and forth between Googles and Cloudflare. No help.
Reply
#9
Tried installing the 32 bit version of the Kodi 18 developer nightly and it works.

Something is up with the 64 bit installer package when installing on Windows 10?
Reply
#10
Perhaps..

there was some gobblygook I couldn't make out in the log.

A direct download from this address of the .zip file works, the work-round would be to install it local. Patience perhaps this will resolve in the next nightly using default skin.

16:37:56.191 T:7000   ERROR: CCurlFile::FillBuffer - Failed: SSL connect error(35)
16:37:56.191 T:7000   ERROR: CCurlFile::Open failed with code 0 for https://mirrors.kodi.tv/addons/leia/reso...-1.0.0.zip:
16:37:56.191 T:7000   ERROR: Could not fetch addon location and hash from https://mirrors.kodi.tv/addons/leia/reso...-1.0.0.zip
16:37:56.191 T:7000   ERROR: CAddonInstallJob[resource.uisounds.titan.modern]: failed to resolve addon install source path
Reply
#11
(2018-08-04, 03:58)PatK Wrote: Perhaps..

there was some gobblygook I couldn't make out in the log.

A direct download from this address of the .zip file works, the work-round would be to install it local. Patience perhaps this will resolve in the next nightly using default skin.

16:37:56.191 T:7000   ERROR: CCurlFile::FillBuffer - Failed: SSL connect error(35)
16:37:56.191 T:7000   ERROR: CCurlFile::Open failed with code 0 for https://mirrors.kodi.tv/addons/leia/reso...-1.0.0.zip:
16:37:56.191 T:7000   ERROR: Could not fetch addon location and hash from https://mirrors.kodi.tv/addons/leia/reso...-1.0.0.zip
16:37:56.191 T:7000   ERROR: CAddonInstallJob[resource.uisounds.titan.modern]: failed to resolve addon install source path
I’m just surprised we are not seeing others complaining about it? Surely I’m not the only one trying to install the 64 bit version onto Windows 10? Direct download will be tough as anything I try to install that requires dependencies won’t download either so setting up any add on is going to be quite a chore.

32 bit will work for me for now but I’d feel better knowing that the team knows about this and is actively working on it.

Thanks for looking at things.
Reply
#12
(2018-08-04, 04:23)Hardax Wrote: I’m just surprised we are not seeing others complaining about it?

There are, but different platform and only local to their own setups... 2753586 (post)
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#13
(2018-08-04, 04:23)Hardax Wrote: I’m just surprised we are not seeing others complaining about it?

Then let me complain about it. Had the same issue on Windows 10 Pro with the Alpha versions of Kodi 18.
Strange thing is though that it works fine on another machine with Windows 10 Home.
For now I "solved" the problem by using the 32-bit version.
Reply
#14
(2018-08-06, 08:56)Dillik Wrote:
(2018-08-04, 04:23)Hardax Wrote: I’m just surprised we are not seeing others complaining about it?

Then let me complain about it. Had the same issue on Windows 10 Pro with the Alpha versions of Kodi 18.
Strange thing is though that it works fine on another machine with Windows 10 Home.
For now I "solved" the problem by using the 32-bit version.  
Exact same problem and exact same solution for me. Its still bothering me that it will work just fine on Windows 10 system (on the same network) but not on another.
Reply
#15
Any new info on this? Ive waited for a few nightlies to be released hoping that this is resolved but still nothing on my end. 

64 bit install = Cannot connect to the official repository
32 bit install = works fine
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
"Could not connect to repository"00