Solved "Could not connect to repository"
#31
Same here - Beta 2 latest nightly as of 16 Sep 2018 Beta 2 64 bit.  More than just repositories broken.  Also can not update any libraries.  I managed to install Netflix by putting in 3 or 4 of the dependencies manually, and wasa able to play a movie (so it can connect to the outside world for some stuff). Have uninstalled and gone with the 32 bit nightly.
Reply
#32
(2018-09-16, 06:54)josepetete Wrote: I have the same problem in my htpc intel. is a j3455 quad core.
i have a desktop computer and netbook with amd processor. kodi leia x64 in both. they work right.
Could it have something to do with the processor?.
 That's entirely possible. I'm using an Intel Apollo Lake processor in my mini-PC.
Reply
#33
To all the previous 'metoo' posters... At least send in a debugging-enabled debug log (wiki) and all other possible circumstantial info. There is nothing to do if there is no evidence.
(I'm not a developer myself, just trying to help out.)
Got a Kodi problem? Provide a full Debug log (wiki) | Usefull pages: First time user (wiki) | Troubleshooting (wiki) | Free content (wiki) | Forum rules (wiki) | VPN policy (wiki)
Reply
#34
(2018-09-16, 06:54)josepetete Wrote: I have the same problem in my htpc intel. is a j3455 quad core.
i have a desktop computer and netbook with amd processor. kodi leia x64 in both. they work right.
Could it have something to do with the processor?.

I’m using a NUC with the newish Pention silver j5005 Gemini Lake processor. I bet dollars to donuts this is the issue!

My logs have already been posted
Reply
#35
People posting the same problem in another thread appear to also be using similiar processors.

https://forum.kodi.tv/showthread.php?tid=335419
Reply
#36
I have the same issue with Kodi 18 x64 bit version (Beta 2 & Nightly). I cannot connect to the internet on the Kodi. It cannot connect to any repository. Heck, loading more skin also doesn't work.

It wasn't the firewall. 32 bit Kodi 18 version works.
Windows 10 fresh install version on a Intel NUC6CAYH.

For now, I am switching to 32 bit verison.
Reply
#37
It would be nice to see one of the devs acknowledge this as a bug.
Reply
#38
Updated all my Kodi Leia versions to-day, scrapes and repository access were flawless. Suggest everyone do the same, and if there's a problem with repsoitory access give me feedback in this thread with your log.
Reply
#39
(2018-09-18, 03:23)PatK Wrote: Updated all my Kodi Leia versions to-day, scrapes and repository access were flawless. Suggest everyone do the same, and if there's a problem with repsoitory access give me feedback in this thread with your log.
I think the bug only presents itself in the 64-bit builds of Leia, and then only on certain Intel processors. For example, I have an Intel mobile processor in a mini-PC similar to many of the people reporting the bug on Intel NUCs. The bug isn't really that Kodi has no internet access, but rather digests aren't being matching expectations when they are calculated on downloads. My process is:

Intel® Celeron® CPU J3355 @ 2.00GHz, 2 cores available

https://paste.ubuntu.com/p/VwWGSJV7V8/
Reply
#40
I think the problem is solved with the update of curl 7.61.1 had the same problem with libreelec alpha except for the last build of milhouse where the update solved the problem
Reply
#41
(2018-09-18, 07:57)josepetete Wrote: I think the problem is solved with the update of curl 7.61.1 had the same problem with libreelec alpha except for the last build of milhouse where the update solved the problem
 It would be good for folks experiencing this problem to update and see if it makes a difference.  When I saw that PR I thought maybe it was a fix, but from the description I don't see that it is.  But could be a side-effect.  Certainly worth giving it a shot.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix see: Aeon MQ5 Mod Martix release thread
Leia see: Aeon MQ5 Mod Leia release thread
Aeon MQ 5 skin and addon repo
Reply
#42
(2018-09-18, 19:42)scott967 Wrote:
(2018-09-18, 07:57)josepetete Wrote: I think the problem is solved with the update of curl 7.61.1 had the same problem with libreelec alpha except for the last build of milhouse where the update solved the problem
 It would be good for folks experiencing this problem to update and see if it makes a difference.  When I saw that PR I thought maybe it was a fix, but from the description I don't see that it is.  But could be a side-effect.  Certainly worth giving it a shot.

scott s.
.  
Will the next nightly have the updated curl library? If so, I'll test it tomorrow.

Edit: I tried this build from today:

http://mirrors.kodi.tv/nightlies/windows...er-x64.exe

Here is my latest log and I still have the bug.

https://paste.ubuntu.com/p/4vbjbBZ4pz/

Relevant snippet:

20:40:33.237 T:6268   ERROR: CCurlFile::FillBuffer - Failed: SSL connect error(35)
20:40:33.237 T:6268   ERROR: CRepository: http://mirrors.kodi.tv/addons/leia/addons.xml.gz index has wrong digest 649b934c649b934c7852b8557852b85527ae41e4649b934ca495991b7852b855, expected: 915f09cd6841766459c48bfa79bf3f601d436983ef3e0cd547991413aca50006
20:40:46.977 T:6268   ERROR: XFILE::CDirectory::GetDirectory - Error getting
20:40:50.660 T:6268   ERROR: Previous line repeats 6 times.
20:40:50.660 T:6268  NOTICE: VideoInfoScanner: Starting scan ..
20:40:52.607 T:6268   ERROR: CCurlFile::FillBuffer - Failed: SSL connect error(35)
20:40:52.607 T:6268   ERROR: CCurlFile::Open failed with code 0 for https://api.tmdb.org/3/search/movie?api_...anguage=en:
20:40:52.607 T:6268   ERROR: ADDON::CScraper::Run: Unable to parse web site
Reply
#43
in the last builds the version of curl is 7.59 let's wait for the next days.
https://github.com/xbmc/xbmc/pull/14435
Reply
#44
(2018-09-19, 10:15)josepetete Wrote: in the last builds the version of curl is 7.59 let's wait for the next days.
https://github.com/xbmc/xbmc/pull/14435
 That shows the pull was merged into master 4 days ago. So shouldn't nightly builds already include it now?
Reply
#45
This didn't change curl version for windows.
Reply



Logout Mark Read Team Forum Stats Members Help
"Could not connect to repository"0
This forum uses Lukasz Tkacz MyBB addons.