Trouble-shooting Kodi Estuary Search Not Working
#1
Is there anyway to isolate the problem with the search. On my Sony TV and Tablet, trying to type if anything of a search brings up no results followed by a complete freeze of Kodi. Only a hard reboot of the TV will bring it back up. I've done uninstalls, reboot, re-install and I still have the same  problem. I am assuming when the search works right, one can search for a movie or tv show by phrase or word.

Any help pointing me in the right direction would be appreciated. Even if I am told that feature does not work. Thank you.
Reply
#2
Debug log needed.
Reply
#3
The log gets uploaded to the Internet automatically? What information is captured outside of the immediate issue?
Reply
#4
No it doesn't. You need to upload it as required.

  1. Enable Debugging mode. Go to Settings>System Settings>Logging and it should be the first option
  2. Restart Kodi
  3. Replicate the problem.
  4. Upload the log to https://paste.ubuntu.com/ manually or use the Kodi Logfile Uploader. With either method post the link back here.
Note: Full logs only. No partial or redacted logs
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#5
Kodi crashed after the search came back with "no results" from the home screen. But here is the URL. https://paste.kodi.tv/notakatuso

I appreciate your help!
Reply
#6
Thanks, but that log is the one where you restarted Kodi to use the Log Uploader, so it no longer has the Search crash.

If you restart then you need to upload kodi.old.log and it needs to be enabled in the Kodi Uploader Settings.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#7
Ok, let's see how this goes. https://paste.kodi.tv/asiroyuwar.
Reply
#8
Thanks.

That seems to be crashing well before you would have any chance of performing a search. It crashes .5 of a second after the skin is loaded, so I can't see how it is a Search issue.

Just as a wild first guess, could you disable service.nextup.notification. Do you still experience the crash? If it still crashes then others may need to assist.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#9
Bummer. Disabled that service under the advance tab, restarted, tried a search "Flubber" {a movie} and it locked up requiring a reboot.

One place I saw where it said 2.1 Dependency. Add this to your addon.xml to make it install your skin. Not sure that applies here, but it was under Add-on:Global Search on the Kodi Wiki.
Reply
#10
(2018-08-14, 02:13)themusj Wrote: tried a search "Flubber" {a movie} and it locked up requiring a reboot.
Do you have that log? The previous log does not show you getting that far into Kodi.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#11
Thank you. I appreciate all the effort and patience. I wanted to be clear on that. Smile

I can get to the Search on the Home Screen. It brings up a screen where I can type on-screen keyboard. I type "Flubber" and then select Done and that's when I get No Results and from there I am completely frozen. A hard reset. I have done just the above and bring Kodi back up. The log is running. I go to the Kodi Logfile Uploader, it asks if I want to upload old log file, I select yes. Here it is.
https://paste.kodi.tv/cowafutava.
Reply
#12
Same issue as the previous log. Looks like it isn't saving the final part of the log where you are performing the Search.

I'll move your thread out of the skin forum and into the Android forum for now, and see if anybody else might know.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#13
Also, you're not using Estuary you're using an Estuary mod. Switch back to the default version and try again.
Reply
#14
Well here is a wrinkle. At work during lunch I installed Kodi 18 and the search worked. Then installed the Estuary mod for Kodi 18 and it worked.

I tried to install the zip and apk on my Sony TV to see if it worked as well and after an hour I have no success installing it. I have the file on a USB stick, permissions fixed, and Xplorer won't highlight the install word to move forward.

I know the latter is really for another thread, but thought I would share the search works in the new version.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Trouble-shooting Kodi Estuary Search Not Working00