Solved -  Xbox Kodi Unable to Open NFS Folder
#1
I am running Kodi Alpha 3 on my XBox One and on my Surface.  Everything works fine on my Surface, but my XBox One in particular has this issue.

My media is stored a QNAP network attached storage on my local network. 
  • I try to add media by adding a file source. 
  • Add Videos -> Add Video Source -> Browse -> Network File System (NFS)
  • It automatically shows the IP of my NAS. 
  • I select the NAS IP name and it navigates to show me the root list of shared folders (Multimedia, Downloads, Public, etc).  
  • At this point I cannot descend any further into any of the folder names except for Public.  The other ones if I click on them just make an audible UI noise, but nothing happens.
  • I have checked the settings on the Multimedia folder, but they appear to be readonly for guest/everyone access.

On my Windows 10 Surface, the same procedure lets me descend into the Multimedia share and select a folder to index or view a file from.  It is like my XBoxOne is restricted or unable to go any further, but no error message is displayed.
Reply
#2
I sorted this out myself.  

So my Kodi app on my Surface was working, because from my Surface in Windows Explorer I had logged into the NAS folders using a login/password.  The XBox One Kodi I had not done that (and not sure if you can).  I had to log into my QNAP and comb through the settings.  I had set up access as read only in one spot, but I needed to change a pick list to say "NFS host access" and then set "Access right" enabled.  Once I applied that setting, then I could descend into the folder from Kodi on the XBox One.   Was not able to upload my screenshot here, but here are step by step instructions for my NAS admin page.

1. Connect to your QNAP NAS admin page.
2. Open Control Panel
3. Select Privilege -> Shared Folders. 
4. You will now see a list of folders.
5. In the Actions column, hover over the icon that gives the tooltip that says "Edit Shared Folder Permission" and click it.
6. A window will appear that says "Edit Shared Folder Permission". 
7. I did have "Guest Access Right" pick list set to "Read Only" here.
8. Change the "Select permission type" pick list to be "NFS host access".
9. Enable the checkbox for "Access right".
10. Click Apply.

You should be good to go now.  If you found you needed more steps, please post back here.  But this worked for me. 

I'm running the QNAP TS-231.  Firmware version: 4.3.4.0675 Build 20180810
Reply
#3
Wink 
I am running Kodi Beta on my XBox One with a QNAP TS-328 FW 4.3.4 and your advice worked a treat, many thanks
Reply
#4
Thread marked solved.
Useful pages: Debug log (wiki) || First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
Hey all,
I also have a Qnap and was having this issue. I have 2 hard drives but the steps provided only seems to work with one of my drives. The drive it doesn't work with is the first drive I installed (primary). As my BluRay collection got bigger so did my needs for hard drive space so I got another drive and put my BluRay movie rips on the primary drive and moved my BluRay TV rips to the secondary drive so it would be a bit more organised in my eyes.
As I said, the secondary drive works just fine using these instructions (THANK YOU) but the primary drive just won't. Is this where apps are stored and maybe there could be a security issue? I can change the settings but if I log out of the NAS  and back in, they have reverted to their original settings.
I know a bit about computers but networking and Nas drives are a little beyond my understanding, but I'm willing to learn
Thanks
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Xbox Kodi Unable to Open NFS Folder51