OS X Kodi not importing my xmltv data to the EPG
#1
I have the following setup:

VBoxCommunications satellite box with unicable input to give me four channels.

Kodi 17.6 Krypton running on Apple MacBook Pro.

I use mc2xml to collect my guide data from Schedules Direct JSON service (for the UK) and save it as my xmltv file.  I use an xmltv.chl file to restrict the channels and the final size of the xmltv file (currently a manageable 9.4 Meg).  I use the -U flag to download in UTF-8 instead of the default "ISO-8859-1" as I believe Kodi needs that.

I have previously had all this working but let it lapse (on Kodi 17.3) but have now started to get back into it as I have solved using launchd to automatically get the listings once a day for importing to Kodi.  With Kodi 17.6 I appear to be having problems.

I cannot import the xmltv data into the VBox as it does not appear to like the Mac network and file structure so that is left unused and is why I want to import it into Kodi.

I am trying to import the data into my Kodi setup but it refuses to do so.  I have checked the file content and it all seems OK.  

The file location is on the same machine as Kodi so it is not a network issue and Kodi browses and locates it fine.

I have cleared out all previous data and reinitiated Kodi but that also does not help (deleting ~/Library/Application Support/Kodi and ~/.kodi).

I have rebooted the VBox, my router and my MacBook and it still will not load the EPG data from the file.

I am stumped.  I read somewhere that it should generate a mapping file but it does not appear to do so.

Can anyone help me please?

Geoff
Reply
#2
Hmmm.  No takers?  I still need help please.

I have noticed that when Kodi starts up, first it tells me when the next backup is scheduled for and then it gets the PVR details, a 50% notice flashes up then disappears and as the channels all come through I assume this is OK.  It then starts to read the EPG data (so presumably reading the xml file) but only gets to 1% then stops but no message in log to say why.

I have gone through the Kodi log and there are some errors but not sure if they affect the EPG import or not.  I list them below in case it helps.

The first two are:

13:20:23.305 T:140735534248832 WARNING: CSettingString: unknown options filler "timezonecountries" of "locale.timezonecountry"
13:20:23.306 T:140735534248832 WARNING: CSettingString: unknown options filler "timezones" of "locale.timezone"

However, when I go to the Interface settings|Regional both the Timezone Country and the Timezone are greyed out and cannot be used so perhaps this is the standard setting?

Then towards the end of startup I get the following:

13:20:25.222 T:140735534248832 WARNING: JSONRPC: Could not parse type "Setting.Details.SettingList"
13:20:25.376 T:140735534248832  NOTICE: initialize done
13:20:25.376 T:140735534248832  NOTICE: Running the application...
13:20:25.377 T:140735534248832  NOTICE: starting zeroconf publishing
13:20:25.377 T:140735534248832  NOTICE: CWebServer[8080]: Started
13:20:25.377 T:140735534248832  NOTICE: starting upnp client
13:20:25.378 T:123145465352192  NOTICE: ES: Starting UDP Event server on port 9777
13:20:25.379 T:123145465352192  NOTICE: UDP: Listening on port 9777 (ipv6 : false)
13:20:26.056 T:123145459474432  NOTICE: script.xbmcbackup-1.1.2: scheduler enabled, finding next run time
13:20:26.057 T:123145459474432  NOTICE: script.xbmcbackup-1.1.2: scheduler will run again on 09-01-2018 00:00
13:20:34.607 T:123145450274816 WARNING: CPVRRecording::CPVRRecording - unable to determine channel type. Defaulting to TV.
13:20:34.641 T:123145469108224  NOTICE: Start - EPG thread started
13:21:30.767 T:123145455104000 WARNING: DARWINOSX: underflow (0 vs 4096 bytes)
13:23:42.354 T:123145449738240 WARNING: CSkinInfo: failed to load skin settings
13:23:42.386 T:140735534248832 WARNING: Skin has invalid include: contentpanelslide
13:23:42.388 T:140735534248832   ERROR: Control 101 in window 13000 has been asked to focus, but it can't
13:24:33.908 T:140735534248832   ERROR: GetDirectory - Error getting /Users/gjj/Library/Application Support/Kodi/media/Fonts/
13:24:33.909 T:140735534248832   ERROR: GetDirectory - Error getting special://home/media/Fonts/
13:24:33.919 T:140735534248832   ERROR: GetDirectory - Error getting /Users/gjj/Library/Application Support/Kodi/media/Fonts/
13:24:33.919 T:140735534248832   ERROR: GetDirectory - Error getting special://home/media/Fonts/
13:24:34.413 T:140735534248832   ERROR: GetDirectory - Error getting /Users/gjj/Library/Application Support/Kodi/media/Fonts/
13:24:34.413 T:140735534248832   ERROR: GetDirectory - Error getting special://home/media/Fonts/
13:24:34.423 T:140735534248832   ERROR: GetDirectory - Error getting /Users/gjj/Library/Application Support/Kodi/media/Fonts/
13:24:34.424 T:140735534248832   ERROR: GetDirectory - Error getting special://home/media/Fonts/
13:24:45.255 T:123145454567424  NOTICE: virtual bool CAESinkDARWINOSX::Initialize(AEAudioFormat &, std:Confusedtring &): Opening default device Built-in Output
13:27:19.534 T:123145453494272 WARNING: DARWINOSX: underflow (0 vs 4096 bytes)
13:30:03.868 T:123145454567424  NOTICE: virtual bool CAESinkDARWINOSX::Initialize(AEAudioFormat &, std:Confusedtring &): Opening default device Built-in Output
13:31:05.003 T:123145453494272 WARNING: DARWINOSX: underflow (0 vs 4096 bytes)

The JSONRPC interests me only because it is a JSON service that gets my EPG data but I suspect it is irrelevant?
CPVRRecording?  What is it and is it important?
DARWINOSX: underflow occurs several times.  Is this important?
CSkinInfo (and following line on skin include):  I have not amended any skin settings
EPG:  The EPG  collection starts.  Is it the underflow that stops it or the issue with the skin?
ERROR: GetDirectory fails as there is nothing in the folder /Users/gjj/Library/Application Support/Kodi/media.  Should there be?

Any help gratefully received.

Geoff
Reply
#3
Bump?
Reply
#4
Hi

Is anyone out there not able to offer me some advice?  I am becoming increasingly frustrated by the lack of response here and also from VBox Communications.

I have tried everything I know to get this to work and today, after updating my xmltv file, I have gone right back to last year with Kodi quitting as soon as it tries to read the guide data.

I have disabled the external data to just use the now and next data from VBox but it is still trying to read the external data (or I think it is) and crashing.

Help please?

Geoff
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi not importing my xmltv data to the EPG00