20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

JSON-RPC VideoLibrary.GetEpisodes often returns '0' for episode runtime
#1
For most episodes in my library, the call to VideoLibrary.GetEpisodes with requesting several properties returns 0 for the runtime property. This is also the case when I try to get the duration from the streamdetails objects. I found a ticket similar to my problem, but the solutions listed do not work for me.

Does anyone know the solution to this problem? Many thanks in advance. 

I am running Kodi version 17.6.
Reply
#2
Hi,
More details would be usefull. What scrapper do you use? Are the files some kind of streaming files (in that case you, you might not follow the forum rules). What says kodi's gui to runtime?
Edit: when its already in the json-rpc respond wrong this is anyway the wrong subforum. The post should be here i guess https://forum.kodi.tv/forumdisplay.php?fid=174
Check out my plugin yarc, it's a web-remote optimised for all screen sizes (especially touch and small screen).
Reply
#3
Yes true, I reported my own post for being in the wrong place, since I don't seem to be able to delete it. Apparently it is placed here now. The post is also placed here

Answering your question, I just use the JSON-RPC interface to get Episode information, e.i this call, and request almost all properties, including streamdetails and run-time, but Kodi returns 0 for episodes that haven't been played yet.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
JSON-RPC VideoLibrary.GetEpisodes often returns '0' for episode runtime00