19 Nov 2019 - TVDB are still in the process of fixing a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are still working to rectify the problems.

  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 10
  •   
Release Weatherbit.io
#46
Ronnie, Thanks for your response.  Well, I have no idea what that means, but I have re-tested and the same thing happens.  The only variable at play is the addition of of the API key for maps. Have no such key and all is good.  So a kodi module may indeed be at fault but the root cause of the failure is the map API key entry.  I guess I will enjoy my last few free days with Wunderground and then look out the window for my weather forecast after that.
Reply
#47
as long as you disable 'download weather maps' in the weatherbit.io settings, you should be fine.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#48
Ronnie,
Admittedly, I had already tried that and discovered that Kodi did not crash.  However, the objective is to make use of the maps as a replacement for Wunderground.  In particular radar and cloud cover.  Or perhaps I am missing the obvious?  I can only see the forecasts.
Reply
#49
you could give kodi v18 a try, perhaps you'll have better luck there...
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#50
Thank you for the great addon. I have it running in my basement system and it works great. I installed on the system in my family room, and unfortunately, on the weather page it says 32 degrees with a line through it, doesn't matter what town I put, I installed the zip file from this thread but had the same struggle, and I cut/pasted my api from the dashboard. jeyapoqoki (paste)
Reply
#51
Ronnie,
I did as you suggested and installed Kodi v18 beta 5.  And now a) there is no crash, b) the maps are now visible, but c) all maps are completely blank, ie a black screen with title and gradient bars only.  Your thoughts?
Reply
#52
(2018-11-06, 15:45)Riviera455 Wrote: Ronnie,
I did as you suggested and installed Kodi v18 beta 5.  And now a) there is no crash, b) the maps are now visible, but c) all maps are completely blank, ie a black screen with title and gradient bars only.  Your thoughts?
 please provide a debug log (see info on how to create this log in first post of this thread)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#53
(2018-11-06, 03:06)clones Wrote: Thank you for the great addon. I have it running in my basement system and it works great. I installed on the system in my family room, and unfortunately, on the weather page it says 32 degrees with a line through it, doesn't matter what town I put, I installed the zip file from this thread but had the same struggle, and I cut/pasted my api from the dashboard. jeyapoqoki (paste)
 could you create another debug log (following the steps in the first post) and this time:
- go to the addon settings and search for a location
- after selecting the location, press ok to save the settings
- navigate to the weather window
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#54
(2018-11-06, 23:26)ronie Wrote:
(2018-11-06, 03:06)clones Wrote: Thank you for the great addon. I have it running in my basement system and it works great. I installed on the system in my family room, and unfortunately, on the weather page it says 32 degrees with a line through it, doesn't matter what town I put, I installed the zip file from this thread but had the same struggle, and I cut/pasted my api from the dashboard. jeyapoqoki (paste)
 could you create another debug log (following the steps in the first post) and this time:
- go to the addon settings and search for a location
- after selecting the location, press ok to save the settings
- navigate to the weather window  
Okay, taberalove (paste)
Reply
#55
i wonder if the addon is saving the location you've selected.

could you test the following:
- go to the weather addon settings and search for 'London'
- select the first location for the list of results, and click ok to save the settings.

next, open this file in a text editor:
C:\Users\Ohnesorge\AppData\Roaming\Kodi\userdata\addon_data\weather.weatherbit.io\settings.xml

and check if these two lines are present:
    <setting id="Location1">London (GB)</setting>
    <setting id="Location1deg" default="true">[&apos;51.5073&apos;, &apos;-0.1277&apos;]</setting>
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#56
Ronnie,
Sorry for delay; life got in the way.
Hope I did this correctly.
bopetaqaja.kodi (paste)
Reply
#57
it confirms my suspicion raised here: 2788258 (post)
i'm afraid you're out of luck until a kodi dev manages to fix pil on android.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#58
Ronnie,
Well thanks for helping this old boy.  Hopefully you will make these "kodi dev" folks aware of my, and presumably other's plight.
Reply
#59
There seems to be a problem with the addon not getting some data in a format it's expecting which is causing a crash with a TypeError.  If I remark out the three lines related to the UV index everything works fine.  I didn't check any further to see if weatherbit.io is just sending crap data or not, but I thought I'd post in case anyone else is seeing the issue.
Providing a debug log: Log_file/Easy (wiki)
Leia Estuary mod: 333143 (thread)
Artist Slideshow: Add-on:Artist_Slideshow (wiki)
SpeedFan Information Display: Add-on:SpeedFan_Information_Display (wiki)
Reply
#60
Hi Ronie - am considering alternative weather providers since WU is questionable long term and figured I would give this new add on a spin.. I get the following error when I startup or refresh weather data.

Code:
17:59:02.117 T:4840   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: a float is required
                                            Traceback (most recent call last):
                                              File "C:\Users\Mario\AppData\Roaming\Kodi\addons\weather.weatherbit.io\default.py", line 474, in <module>
                                                forecast(locationname, locationdeg)
                                              File "C:\Users\Mario\AppData\Roaming\Kodi\addons\weather.weatherbit.io\default.py", line 250, in forecast
                                                daily_props(daily_weather)
                                              File "C:\Users\Mario\AppData\Roaming\Kodi\addons\weather.weatherbit.io\default.py", line 369, in daily_props
                                                set_property('Daily.%i.UVIndex'           % (count+1), str(int(round(item['uv']))) + '%')
                                            TypeError: a float is required
                                            -->End of Python script error report<--


<settings version="2">
    <setting id="API">****REMOVED****</setting>
    <setting id="Debug">true</setting>
    <setting id="LatLon">true</setting>
    <setting id="Location1">Woodburn (US)</setting>
    <setting id="Location1deg" default="true">[&apos;45.1512&apos;, &apos;-122.857&apos;]</setting>
    <setting id="Location2" default="true"></setting>
    <setting id="Location3" default="true"></setting>
    <setting id="Location4" default="true"></setting>
    <setting id="Location5" default="true"></setting>
    <setting id="MAPAPI">***REMOVED***</setting>
    <setting id="WMaps">true</setting>
    <setting id="Zoom">4</setting>
</settings>

I also have a feature request and I really hope it is something that can be added at some point, but I thank you for the consideration at the very least.

I love the weather alert feature of WU and I think that is now the only add on that actually supports populating those properties for skin use.

Could you possibly add that feature?

weather.gov api info:

https://forecast-v3.weather.gov/documentation

also

https://alerts.weather.gov/

Thanks for help with the error and considering adding alerts support

Thanks,

Mario
Reply
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 10
  •   
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Weatherbit.io00