v18 Nvidia Shield/Android Tablet and Kodi/MP Backend
#1
Hi All,

I've been having issues with NextPVR lately and I'm trying to see if Media Portal is more stable. 
I've installed TV Server v1.20 and the TVServerKodi plugin and configured it and it works perfectly on 3 different Windows 10 1803 boxes. (The Media Portal Server is also 1803).

Where I am coming unstuck is on Android Devices, a Lenovo Tab4 10" Tablet running 7.1.1 and an Nvidia Shield running 8.0 (Both running the latest nightlies).

I've setup the Media Portal plugins to use IP Address (same as the WinPCS) and the plugin loads and I get a full EPG/Channel Listing, however, when I click play nothing happens.

The relevant .ts file appears in the TimeShift Share on the Media Portal Server, and, If I play a TV Channel on another PC, I can browse to that share on the Android Devices and play the .ts file with no issues.

Is anybody else experiencing this issue?

Cheers All!
Reply
#2
After looking at the Kodi.log output, I'm seeing the following

21:48:02.996 T:546871215184    INFO: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() smb://ADMIN:[email protected]/TIMESHIFT/live4-0.ts.tsbuffer.
21:48:04.001 T:546871215184   DEBUG: CSMBFile::Open - opened smb://USERNAMETongue[email protected]/TIMESHIFT/live4-0.ts.tsbuffer, fd=-1
21:48:04.002 T:546871215184    INFO: SMBFile->Open: Unable to open file : 'smb://USERNAMETongue[email protected]/TIMESHIFT/live4-0.ts.tsbuffer'
                                            unix_err:'16' error : 'Invalid argument'

Since Android has no DNS Resolution in this regard, how can I work around this?

Can I modify the Media Portal Kodi Server plugin to use IP Address instead of Name (TVSVR).  I have the IP address in the Media Portal Client, so it must be getting that from the Server itself.
Reply
#3
You don't need to tell the server which computer to use.

The fact that the client log shows the names of the computer, not the IP address, suggests that you don't have the IP address in the Kodi PVR settings. Without full logs and possibly screenshots of the config section, it's hard to help you.
Reply
#4
(2018-09-12, 22:54)mcelliott Wrote: You don't need to tell the server which computer to use.

The fact that the client log shows the names of the computer, not the IP address, suggests that you don't have the IP address in the Kodi PVR settings. Without full logs and possibly screenshots of the config section, it's hard to help you.
 Hi mcelliott,

Please see the full paste log below:
https://paste.ubuntu.com/p/jmxbHpsS6Y/

This will clearly show I'm definitely using IP Address for the Kodi PVR Plugin and don't have the hostname (TVSVR) pipped anywhere in Kodi.

The only Place I see TVSVR is in the TVServerKodi Plugin Settings in MediaPortal Configuration, which shows \\TVSVR\Timeshift and \\TVSVR\RecordedTV, nowhere in Kodi do I have this set, as I don't have a hosts file or local DNS resolution to resolve it, thus I
use its IP address 192.168.2.253.

I'm running Media Portal TV Server 1.20, are there any benefits to running 2.x?

Also, i'm running the Server Plugin Version: TVServerKodi-1.15.0.137, should I be running a different version perhaps?

Cheers again for looking at this!
Reply
#5
In that case I would try changing the setting in the TV server plugin to also use the IP address.

I see the following line in your logs.

21:47:29.378 T:546871215184   DEBUG: CSMBFile::Open - opened smb://USERNAMETongue[email protected]/TIMESHIFT/live4-0.ts.tsbuffer, fd=-1

I don't know if the logging substitutes your password, but you have entered your password for the shares, right?

Try adding the shares in 'videos' and play a recording from there. If that doesn't play, that's your problem.
Reply
#6
(2018-09-13, 09:50)mcelliott Wrote: In that case I would try changing the setting in the TV server plugin to also use the IP address.

I see the following line in your logs.

21:47:29.378 T:546871215184   DEBUG: CSMBFile::Open - opened smb://USERNAMETongue[email protected]/TIMESHIFT/live4-0.ts.tsbuffer, fd=-1

I don't know if the logging substitutes your password, but you have entered your password for the shares, right?

Try adding the shares in 'videos' and play a recording from there. If that doesn't play, that's your problem.
 How do I change this in the TVServer Plugin, there is no way to do this?
ie, is there config file somewhere I can edit, or is it in the Database, which I will need help with in that instance...

To confirm, I'm talking about the Server-Side plugin that integrates with the MediaPortal TV Server
https://users.scintilla.utwente.nl/marce...rxbmc.html

The lines above are as is in the log file:
smb://USERNAMETongue[email protected]/TIMESHIFT/live4-0.ts.tsbuffer, fd=-1

The lines I modified are the following, so unsure why it tries my credentials once, then goes back to "USERNAMETongueASSWORD":
AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() smb://[MYUSERNAME]:[MYPASSWORD]]@TVSVR/TIMESHIFT/live4-0.ts.tsbuffer.

So I replaced my real username and password with [MYUSERNAME] and [MYPASSWORD] (including square brackets) and left all the rest untouched.

When I add "192.168.2.253\Timeshift" to the Video Share, I can access and play .ts files, but my Android Tablet and Shield cannot resolve "TVSVR" to an IP address (no local dns or wins).

I can only assume that the Kodi client plugin connects to MediaPortal successfully (gets the channel list,etc) and is somehow given a referral containing the "HOSTNAME" for RecordedTV and Timeshift (since i haven't entered this anywhere in Kodi).

The easiest fix seems to be modifying the Server-Side to use IP instead of HOSTNAME if thats possible.

Appreciate the assistance/advice!
Reply
#7
Go to the TV server configuration, and the sections for timeshifting and recording. You can define the folders there. You must have done this.

In mine, I have

\\MYSERVERNAME\Media\Recordings

etc, but I'm sure I could put the IP address in there instead if necessary.

There is also the Kodi plugin setting which has the same folders. You probably want to switch from name to IP address there as well.

There are screenshots in the Wiki to help you.

https://kodi.wiki/view/MediaPortal_TV-Server
Reply
#8
(2018-09-13, 18:01)mcelliott Wrote: Go to the TV server configuration, and the sections for timeshifting and recording. You can define the folders there. You must have done this.

In mine, I have

\\MYSERVERNAME\Media\Recordings

etc, but I'm sure I could put the IP address in there instead if necessary.

There is also the Kodi plugin setting which has the same folders. You probably want to switch from name to IP address there as well.

There are screenshots in the Wiki to help you.

https://kodi.wiki/view/MediaPortal_TV-Server
 The create share will create those shares in that screenshot of the configuration.  There is no way to change this to an IP Address via the GUI.  Which Is why I was asking if there was a config file I could modify or a database modification command I could run.

Cheers.
Reply
#9
But what happens if you reference it with the IP address in the recordings and timeshifting section of configuration?

Does it then use the IP address in the Kodi plugin?
Reply
#10
(2018-09-14, 15:28)mcelliott Wrote: But what happens if you reference it with the IP address in the recordings and timeshifting section of configuration?

Does it then use the IP address in the Kodi plugin?
 Can't do that either... the only option is "Browse" which will let you browse local folders.
Reply
#11
I have been experiencing the problems with DNS resolution on Windows 10, and putting the IP address for the TV server into the Kodi plugin on the client side sorts it.

When I check my logs, it does have the computer name for the location of the files on the network, so the lack of DNS is the problem.

For me, I think my router handles DNS. Is this not the way it works?

I'm out of ideas!
Reply
#12
(2018-09-15, 11:54)mcelliott Wrote: I have been experiencing the problems with DNS resolution on Windows 10, and putting the IP address for the TV server into the Kodi plugin on the client side sorts it.

When I check my logs, it does have the computer name for the location of the files on the network, so the lack of DNS is the problem.

For me, I think my router handles DNS. Is this not the way it works?

I'm out of ideas!
I ended up enabling DNSMasq on my Ubiquiti USG Router.  This has enabled resolution and the issue is now resolved.  Would be easier if you could configure the KodiTVServer plugin for MediaPortal to not use hostname however...
Is there any way to feed this back to somebody who maintains the plugin to allow this hopefully in future?

Clearly using the IP Address in the Kodi Client plugin is fine, but the Server Plugin must return the HOSTNAME for Recordings/Timeshift Shares.

Cheers again for the assistance.
Reply
#13
(2018-09-15, 11:54)mcelliott Wrote: I have been experiencing the problems with DNS resolution on Windows 10, and putting the IP address for the TV server into the Kodi plugin on the client side sorts it.

When I check my logs, it does have the computer name for the location of the files on the network, so the lack of DNS is the problem.

For me, I think my router handles DNS. Is this not the way it works?

I'm out of ideas!
 Not DNS resolution as such but NETBios name resolution.  That went away with Win10 1803.  No longer any means to resolve names locally other than a DNS server ( or maintaining your hosts file with NETBios names and IP's). 

See this -> https://support.microsoft.com/en-us/help...in-windows as to why MS turned it off.  In particular, scroll down to 'Explorer Network Browsing' and follow the steps there to turn it back on and hostname resolution should work locally again.
Learning Linux the hard way !!
Reply



Logout Mark Read Team Forum Stats Members Help
Nvidia Shield/Android Tablet and Kodi/MP Backend0
This forum uses Lukasz Tkacz MyBB addons.