v18 -  kodi-gbm requires kodi-x11?
#1
I switched my HTPC (Ubuntu 18.04 x64, Intel i3-3225) over from X11 to GBM nightlies. It works great, but I noticed that kodi-x11 is installed as a dependency. Is this dependency necessary?

$ apt-cache depends kodi-gbm
kodi-gbm
  Depends: kodi-x11
  Depends: kodi
  Depends: libasound2
  Depends: libass9
  Depends: libavahi-client3
  Depends: libavahi-common3
  ...
Reply
#2
why do you switch to gbm? you should have good reasons because quality of video is not as good as on X11
Reply
#3
Mostly curiosity, but I also wanted to see if there would be a noticeable difference in resource consumption without X11. About 90% of the videos I tried played without issue, but there was some stuttering and artifacts in a few videos. Not much difference resource-wise.
Reply
#4
(2018-09-14, 17:06)MrTarantula Wrote: I switched my HTPC (Ubuntu 18.04 x64, Intel i3-3225) over from X11 to GBM nightlies. It works great, but I noticed that kodi-x11 is installed as a dependency. Is this dependency necessary?

$ apt-cache depends kodi-gbm
kodi-gbm
  Depends: kodi-x11
  Depends: kodi
  Depends: libasound2
  Depends: libass9
  Depends: libavahi-client3
  Depends: libavahi-common3
  ...
 Not sure if we'd actually need to rely on kodi-x11, but I guess it's the case because GBM with OpenGL actually needs X11 as libGL.so depends on X11.
I've been working a bit to sort this out, but it's non-trivial (although it might happen in the future).
Reply
#5
(2018-09-30, 10:18)a1rwulf Wrote: Not sure if we'd actually need to rely on kodi-x11, but I guess it's the case because GBM with OpenGL actually needs X11 as libGL.so depends on X11.
I've been working a bit to sort this out, but it's non-trivial (although it might happen in the future).

That's not the reason, reason is that kodi-x11 has packaged some files which kodi-gbm and kodi-wayland need too. I've looked at the packaging and those files are usr/bin/kodi, usr/bin/kodi-standalone and usr/lib/*/kodi/system.
Reply
#6
Ok, thx rechi for clarifying.
Reply
#7
yep, to get rid of it, I'll have to split off libs in their own package
Reply
#8
I wouldn't consider it a priority, though
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
kodi-gbm requires kodi-x11?00