Cannot create new connection to kodi on Libreelec

When I try to create new connection to Libreelec box (8.2.5, with kodi 17.6) from kore (v 2.4.4), and click "Test" button, I get "Can't connect to Kodi/XBMC. Please check configuration" message and the host is not added.
I tested same configuration (ip, port, username and password) with yatse on same device and it works, so I think it's not a network or kodi configuration problem. Indeed, I can ping kodi host from android device, telnet to port 80 and 9090 works (can establish connection).

I did a tcpdump on my router while trying to add the host and this is what I found:
POST /jsonrpc HTTP/1.1
Content-Type: application/json; charset=utf-8
Content-Length: 49
Connection: Keep-Alive
Accept-Encoding: gzip
User-Agent: okhttp/2.3.0


HTTP/1.1 401 Unauthorized
Content-Length: 0
Connection: close
WWW-Authenticate: Basic realm=XBMC
Date: Tue, 25 Sep 2018 23:07:19 GMT

It seems kore forgot to send basic authentication to kodi (I'm sure i filled the fields on the kore gui). I tried to do a similar request in python but with basic auth and I got:

>>> import requests as r
>>>'', auth=('username,'password'), json={"jsonrpc":"2.0","method":"JSONRPC.Ping","id":25})
>>> rr.content
>>> rr.status_code

Any idea? It's strange I'm the only with this problem
Thanks for the detailed report. You might want to report it on github where the discussion can be more productive

Anyway, it's odd what you're experiencing. I just checked and basic auth worked for me. I also checked the code and it's there, so i don't know what might be going on.
Thank you for your reply. Submitted on github at
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Cannot create new connection to kodi on Libreelec00