•   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 27
  •   
Vu+ PVR addon is getting updates again
@phunkyfish  I just send samples to you.
Reply
Perfect, thanks. Did you get a chance to test on windows using vanilla kodi?
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
@garret I'm afraid you might have CoreElec bug. I've tested your sample on both Vanilla Kodi on Mac and Librelec on Intel and it plays perfect, 32 minutes long and can I skip forward/back etc no problem.

My guess is there have a problem somewhere converting from 64 to 32 bit (or vice versa) between the addon and main kodi system.

Can you try Vanilla Kodi on Mac/Windows and/or LibreElec on a raspberry PI to confirm it's a CoreElec only issue?
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
The same .ts duration problem can be seen with the Kodi Android version (on Nvidia Shields).
Sony VPL-HW55ES + Stewart Firehawk 182cm, nVidia Shield, LibreElec + 5 * Intel NUC, Vu+ Uno4k & T90+8lnb, 28Tb Thecus N7510 NAS, Denon AVR-X1100W, AMX+ 3*Ipad, 3*KefQ1, 4*KefQ2DS, Elac S12EQ
Reply
Ok, good to. I would still like to see the a test done on Windows/Mac. It may be an ARM CPU issue.

@Raitsa can you post full debug log of the issue occurring please?

@garret you should probably upgrade your Enigma2 device. It's running very, very old versions of everything. 

Code:

23 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - DeviceInfo
13:34:23.623 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2EnigmaVersion: 2015-07-13-(no branch)
13:34:23.624 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2ImageVersion: 4.
13:34:23.624 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2DistroVersion: openpli
13:34:23.633 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2WebIfVersion: OWIF 0.4.6
13:34:23.634 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2DeviceName: Premium Ultra
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
I am little bit confused at the moment. 

Tested with three different devices:
 
  • Raspberry Pi3, LibreElec 8.2.5, Kodi 17.6 stable, VU+/Enigma2 client 2.4.12.1
  • Amlogic S905W, CoreElec 8.95.7, Kodi 18.0 RC4, Enigma2 client 3.15.4.2
  • Intel i7-4770S, Windows 8.1, Kodi 18.0 RC4, Enigma2 Client 3.16.1

With Amlogic duration is wrong and cannot skip forward or backwards. In a matter of fact, skip control buttons are invisible.

With Raspberry duration is wrong but I can skip forward or backwards.

With Intel no problems at all.

In a matter of fact, I cannot find any problematic recording that does not work with Intel. Instead, I have constant problems with Amlogic. Lot of recordings does not work, even though they work well with Raspberry.
Reply
@garret 

Can you try the latest raspberry PI nightly build for Leia? 298461 (thread)

The old LibreElec will not work as there is no implementation of GetStreamTimes. If the above works then we know this mainly effects AMLogic in your case which makes sense (and maybe just coreelec).

We'll have to see @Raitsa 's debug log before seeing what's at play there.
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
When GetStreamTimes is called the addon returns the duration of the file in seconds, multiplied by 1,000,000 to give micro seconds. If this is a 32/64bit issue it would happen in files around 36 mins long as these would overflow a 32bit signed int at this point.

However, the sample file you sent me is 32 minutes long and still had issues for you. Which doesn't make a whole lot of sense.

I've added the following statements to the debug logging in 3.16.2. Let's see if they report something other than what we expect.

Code:

2019-01-08 15:35:17.270 kodi.bin[97813:2739241] Debug Print: AddOnLog: Enigma2 Client: pvr.vuplus - CurrentDuration RecordingReader - Full: 1920
2019-01-08 15:35:17.270 kodi.bin[97813:2739241] Debug Print: AddOnLog: Enigma2 Client: pvr.vuplus - GetStreamTimes Playback StartTime: 0, ptsStart: 0, ptsBegin: 0, ptsEnd: 1920000000

First statement is in seconds, the second Microseconds using the 32min sample.
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
Thank you for this

I'm running libreelec 8.95.02 generic and running pvr.vuplus 3.15.4.
Can i download 3.16.1 somewhere?
I like this add-on very much.
Reply
You're welcome @B3NJAMIN Wink

You can install a nightly build from here which will have the latest addon version: 298462 (thread)
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
(2019-01-08, 16:19)phunkyfish Wrote: @garret 

Can you try the latest raspberry PI nightly build for Leia? 298461 (thread)
 Tested.

Doesn't show duration at all (in player), no skip-controls. Almost all recordings are broken (like Amlogic).
Reply
Good news is I have a raspberry somewhere. Let me dig it out and get it set up.

So this issue may be solely ARM related.
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
So I just installed latest LibreELEC (Leia) v8.95.2 BETA on my raspberry PI 3.

Using the samples you supplied I have no reduced functionality. I can view the duration in the player controls (there are no skip controls, but I don't think there are supposed to be). If I click left or right I can skip through the video correctly.

I think this may be your Enigma2 device @garret as i said it's running a 3 year old image. 

Code:

13:34:23.623 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2EnigmaVersion: 2015-07-13-(no branch)
13:34:23.624 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2ImageVersion: 4.
13:34:23.624 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2DistroVersion: openpli
13:34:23.633 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2WebIfVersion: OWIF 0.4.6
13:34:23.634 T:3973231472 NOTICE: AddOnLog: Enigma2 Client: pvr.vuplus - LoadDeviceInfo - E2DeviceName: Premium Ultra

Can you upgrade to something more current? I guess it's possible that how the file is accessed causes a problem due to the old version of Enigma2 software and OpenWebIf, it would appear this only effects ARM processors. It's certainly worth a try even if it is a bit of a stretch.

Upgrading will give you other benefits like support for Autotimers etc.

@Raitsa can you supply a debug log? I would like to see what image you are using (I.e. the log info above).
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
@garret also tested using the lastest Raspberry PI nightly and everything is working. Let me see can I find an Amlogic device that I can install CoreElec on.
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
Found a Wetek Hub, still using LibreElec as they support that device but also functioning correctly. If I can figure out how install coreelec I will try it too.
Maintainer of Enigma2 PVR addon: Github repo, documentation
If you're asked to provide a full debug log, follow this link
Reply
  •   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 27
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Vu+ PVR addon is getting updates again52