•   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 14
  •   
Vu+ PVR addon is getting updates again
(2019-01-11, 02:33)phunkyfish Wrote: @garret

The the weekly Linux 5.0rc1 build includes the PR:

https://forum.kodi.tv/showthread.php?tid...pid2807616
Good Morning!

Great news. It seem's to be working now. I'll do more testing and get back to this soon. Thank you phunkyfish!
Reply
Excellent, also tested here and looks good.

Did you say you had a second bug?
Reply
I can confirm that everything works now. I have tested over 20 broken recordings, without any problems. Great work phunkyfish.

May I ask that is there any possibility to get this fix also to VU+/Enigma2 client 2.4.12.? As I said to you, I am forced to use Kodi Krypton at the moment. No need for any new features, just this "GetStreamTimes" -modification to get duration working.
 
(2019-01-11, 11:21)phunkyfish Wrote: Did you say you had a second bug?
I think that you just earn free weekend to yourself. I will prepaire some documentation for next week.
Reply
There is no GetStreamTimes API function in Krypton. Works completely different there.
Reply
(2019-01-11, 18:35)ksooo Wrote: There is no GetStreamTimes API function in Krypton. Works completely different there.
Interesting.

Do you know what might cause this same problem in Krypton? I would be nice to get if fixed.
Reply
@garret as GetSteamTimes is kodi 18 only there isn’t anything that can be done I’m afraid. I wouldn’t even have a build environment for it as I only started maintaining the addon in Leia. It shouldn’t be too much longer hopefully for Kodi 18 to be released.

How come you can’t use the kodi 18 release candidate? Just curious.

Send on the other bug anytime, this is my hobby so I have fun fixing them Wink If you manage to create a GitHub account and create an issue there it’s much easier from a tracking perspective and it’s easier for other devs to follow what’s going on. So if it ends up being an issue in kodi it’s easy to link etc.
Reply
(2019-01-11, 19:32)phunkyfish Wrote: @garret as GetSteamTimes is kodi 18 only there isn’t anything that can be done I’m afraid. I wouldn’t even have a build environment for it as I only started maintaining the addon in Leia. It shouldn’t be too much longer hopefully for Kodi 18 to be released.
I see. I hope that ksooo or fritsch (who fixed "Timer recording margins" Backport in 2.4.12) can solve this. I bet that we don't see stable Leia before next autumn ;-)
(2019-01-11, 19:32)phunkyfish Wrote: How come you can’t use the kodi 18 release candidate? Just curious.
Nothing special, just hevily modified favourite skin (Amber) which doesn't work in Leia.
(2019-01-11, 19:32)phunkyfish Wrote: Send on the other bug anytime, this is my hobby so I have fun fixing them Wink If you manage to create a GitHub account and create an issue there it’s much easier from a tracking perspective and it’s easier for other devs to follow what’s going on. So if it ends up being an issue in kodi it’s easy to link etc.
Ok... Here it is:

If I have understand this right, when Kodi is showing despcription to recording it parses this information from Enigma's *.meta file.

When I add recording to STB from Kodi's EPG, I cannot see description in Kodi because it doesn't exist in meta-file. Kodi will lost it somehow. In STB I can see description, because it uses information from *.eit -file.

If I add recording from OpenWebif, description is present. This have been tested with different Kodi OS, Enigma-images, Webif versions and skins with same result. Also with newest Milhouse build.

Here you can see difference between recordings which are made in STB and Kodi:
Image

As soon I have placed new recording, description is lost. This can be verified from timers.xml in STB. It's only containing recording time.

Ps. I dont know does this help, but In Finland terrestial broadcasters usually doesn't use "extended event description" -information at all. Just "event description". Thats why "Plot" is usually empty and needed information can be found at "PlotOutline".
Reply
Is this to record something that is on now in the EPG or a timer for later?

If plot is empty, plot outline is used by default so no issues there.

If you can detail the exact steps you perform in kodi to reproduce that would be useful. Screenshots also helpful!

On the kodi release they are at RC5 now. It can’t be too much longer. On your skin I would contact the skin developer about upgrading it for Leia.
Reply
It doesn't matter how you make this timer. If its made from Kodi, description is lost. And in descrption field is recording time.

Example.

I made two timers, first from Webif, second from Kodi EPG. Same program.

Image

Image

See the difference?
Reply
I only use Timer rules which don’t have this issue. I should be able to reproduce this easily though.

If you do an instant recording (using the record button while viewing a channel) do you have the same issue?
Reply
https://github.com/kodi-pvr/pvr.vuplus/issues/174
Reply
Sorry! I'll forget to make account in github. I promise that next time I will do it. Anyway here is test you asked..

When watching channel-list, description is present:
Image

Description is also present in EPG:
Image

And in info-window:
Image

Now when I am recording it from Kodi:
Image

...description is lost in recording:
Image

It doesn't matter how do you make recording. If they are made in Kodi, description is lost. This is annoying. It it prevents me from using Kodi for adding timers if for example season and episode information is lost every series what you are following.
Reply
Do you have autotimers on your Enigma2 device? I know it's a default plugin on newer images but not sure about yours.

If so you could try installing openwebif 1.3.5, if it all works you would have description for your recordings from autotimers and you wouldn't need to remember to setup/change recording times.

It would tide you over while I figure out what's happening. Just remember to back up your device before giving it a go.
Reply
(2019-01-13, 12:32)phunkyfish Wrote: Do you have autotimers on your Enigma2 device? I know it's a default plugin on newer images but not sure about yours.

If so you could try installing openwebif 1.3.5, if it all works you would have description for your recordings from autotimers and you wouldn't need to remember to setup/change recording times.

It would tide you over while I figure out what's happening. Just remember to back up your device before giving it a go.
Yes, I have autotimers and I also also use them. But they cannot be only way to place new timers. Not for me. Maybe I am weird person (I know I am).

​​As I said earlier, this issue is tested with different Kodi- and Webif-versions (with different users) and it does not matter. Same Same result.

Before I have to upgrade my STB, is it possible to you try first add timer from Kodi EPG? Or simply push record button ilke I did and then check do you have description?
Reply
I meant as a workaround in the meantime Wink With your current version of OpenWebIf you won’t be able to use autotimers from kodi.

You would only need to install a single package, not the upgrade the entire image.

I’ll have a look at the regular timer description issue tomorrow.

You’ll find the latest OpenWebIf package here if you’d like to try it: https://github.com/E2OpenPlugins/e2openp...es?files=1
Reply
  •   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 14
  •   
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Vu+ PVR addon is getting updates again51