Vu+ PVR addon is getting updates again
(2019-02-01, 13:56)suppenkasper Wrote:
(2019-01-30, 23:57)phunkyfish Wrote:
(2019-01-30, 19:52)suppenkasper Wrote: Hi, unfortunately my streaming from my D-Cube Receiver is not working anymore after this shitty update. I tried to reinstall and also delteted all files in .kodi/ home-dir. Nothing helped. With version 3.16 it reads at least the Bouquets, but only via http. Via HTTPS there is always an error and it doesn't work unfortunately.

Everything worked well before the update! Would you please help me to get my streaming back?


Here is my kodi-crash-log: https://paste.kodi.tv/movukoqafo.kodi
Cli-Command: https://paste.kodi.tv/kupahoyudu.kodi
 Phrases like "this shitty update" are not appreciated at all. If you would like help it pays to be nice.

You are running an RC1 of 18.1 Leia when 18.0 is stable (is there a reason you need the RC?). Your addon version is two revisions old (3.16.2 is the latest), first step would be to upgrade to the latest version. You made no mention of what version you upgraded from (either kodi or the addon) so can't really help further without knowing.      
 Hi, I am sorry, but why do you change so much? It was one of the few tools which actually worked in kodi. I used version 2.14. There is no reason, why I use kodi 18.1 RC. That's easily in my repository. I used the stable repo from team-xbmc on my Ubuntu machine. Everything worked well (since years). Now it unfortunately updated kodi and also plugins. There is no chance to get back to 17.6 and old plugin. There are no repositories anymore.

So I would love to bring this issue with 3.16 to fly. Unfortunately I can't update to 3.16.2 because I have to use the repo: team-xbmc-nighlty. Even when it says on the repo site they provide already 3.16.2 there is no chance to update from (3.16.0-1~xenial). 

But independent from here, is the issue knwon and will it be fixed or is it just me that have this issue with Formuler F1 Receiver on OpenATV 6.2?     
Don't worry, we'll figure out the issue. If you're running OpenATV you should be ok. The changes were made to the addon on Kodi 18, I never used it on Kodi 17 so it could be to do with the upgrade.

Did you do a fresh install or did you upgrade from 17.6?

Also, if you could switch on debug mode and post a debug log that would be helpful.

UPDATE: I see this on your CLI:

Code:

WARNING: Invalid RefPicListX entry!!! It is not included in DPB terminate called after throwing an instance of 'nlohmann::detail::type_error' what(): [json.exception.type_error.302] type must be number, but is string

3.16.1 fixed a library dependency on the packages: nlohmann-json-dev and nlohmann-json3-dev

Can you check if you have either of those installed and what versions you have?

The problem is I can't see what is causing the terminate error without a debug log.

UPDATE: I'll add a fix to catch the error thrown above. It certainly should not cause a crash
Maintainer of Enigma2 PVR addon: repo, docschangelog
How to create a full debug: here
Reply


Messages In This Thread
RE: Vu+ PVR addon is getting updates again - by phunkyfish - 2019-02-01, 15:23


Logout Mark Read Team Forum Stats Members Help
Vu+ PVR addon is getting updates again3
This forum uses Lukasz Tkacz MyBB addons.