External subtitles ouf of sync with blu-ray rips
#1
I have a question regarding external subtitles (in srt format) in combination with (full) blu-ray rips (in ISO or BDMV) format.

When I use external subtitles that I know that are in sync with these blu-rays, the subtitles always appear about 10-12 seconds early.

I play the blu-ray by selecting "Play" in the context menu and selecting the playlist that has the main movie in it.

I know the subtitles are in sync, because when I play the largest .m2ts file manually it works just fine. Also my other media player (Dune HD Solo Lite) has no issues with the same subtitles.

I have not configured a default subtitle offset. I also tried three different Kodi versions (17, 18 Beta and MrMC Lite), all on an Nvidia Shield.

Any clues as to why this is happening?
Reply
#2
Ok, so I did some more testing:
 
  • Started with a completely fresh install of Kodi 18 Beta 3 on the Nvidia Shield: still the same issue
  • Remuxed a movie using tsmuxer into a new ISO containing a single playlist with just the movie: still the same issue
  • Checked the original ISO with the Windows version of Kodi (64-bit installer version): still the same issue
  • Remuxed the movie into an mkv file using mkvtoolnix: issue solved and subs are in sync
  • Checked the original ISO with external subs using the Xbox One version of Kodi (currently beta 1): issue solved and subs are in sync

That last one is especially surprising I think... Can anyone else confirm this issue?
Reply
#3
Yep, I have the exact same issue with latest nightly. I guess we should open an issue on github?
Reply
#4
(2019-04-22, 07:37)ferdinand Wrote: I guess we should open an issue on github?
Please do. Include all the usual info as log files and other details that may be relevant.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
(2019-04-22, 07:50)Klojum Wrote:
(2019-04-22, 07:37)ferdinand Wrote: I guess we should open an issue on github?
Please do. Include all the usual info as log files and other details that may be relevant. 

Done. I hope I can help fix the bug with the info I've provided.
Reply
#6
(2019-04-25, 04:14)ferdinand Wrote:
(2019-04-22, 07:50)Klojum Wrote:
(2019-04-22, 07:37)ferdinand Wrote: I guess we should open an issue on github?
Please do. Include all the usual info as log files and other details that may be relevant.  

Done. I hope I can help fix the bug with the info I've provided. 
I have the same problem.The bug still not fixed on Kodi v18.2.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
External subtitles ouf of sync with blu-ray rips00