Can't watch any channel, nothing happens but Kodi tells me it is playing it
#1
Hi everyone,

I've been using NextPVR with Kodi for years, and had zero issues. Unbelievably reliable. We were away from home for 2 days last week, and when we returned live tv wouldn't play at all. I was on 17.6 so thought "I know, i'll just try updating to Leia and it will remedy any issue I had" (stupid thought, I know). Nope, still no worky.
Basically I go to the guide in Kodi, select the channel to watch and then in the top right of the screen next to the clock is shows a "playing" arrow next to the channel and show I selected. But nothing else happens. I am still shown the channel list or guide, with no tv video or audio.  So next I updated my firmware on my HDHR Prime, installed the latest NextPVR. Still the same issue.

Since then I have been running through all of the settings to make sure they are all as they should be, and I can't work it out. 

NextPVR standalone program works with live tv. If i select the HDHR PVR in Kodi it works fine. I can set up NextPVR in Emby, and it all works fantastically. I have since reinstalled all of the separate components but alas no improvement.

Anyone got any suggestions? I hadn't changed a single setting in Kodi/NextPVR backend, so I'm stumped as to why it has just stopped working. I can attach logs if necessary, but which one is the once to attach? I found a few logs with different titles when I took a look earlier.

Thanks in anticipation, and thanks for reading this far!

Here is my setup,
  • HDHR Prime - Spectrum cablecard
  • Kodi v18 beta 3 (but problem was originally in 17.6 too)
  • NextPVR backend
  • NextPVR selected in Kodi
  • I use Schedules Direct for EPG, just thought I'd throw in that info
Reply
#2
Not sure about the whole "was working now isn't part," but I found (especially with Kodi 18) that I had to disable the "Enable Timeshift with LiveTV option" in the NextPVR PVR addon settings to get Live TV to work.  Also, if you're using a Pi (at least the OSMC distro on a Pi), you might want to check which hardware decoder you're using.  I know when I tried OMXPlayer Live TV never worked.  Again, these are all settings I use because the alternatives never worked, so I'm not sure why you would be seeing a change now.  BTW, I'd say the kodi.log file with debugging on would be the best log to start with if you're going to post something.
Providing a debug log: https://kodi.wiki/view/Log_file/Easy
Leia Estuary mod: https://forum.kodi.tv/showthread.php?tid=333143
Artist Slideshow: Add-on:Artist_Slideshow (wiki)
SpeedFan Information Display: Add-on:SpeedFan_Information_Display (wiki)
Reply
#3
Hi I have a very similar problem, but what is specific in my case is that it only doesn't work on my Huawei MediaPad T3 10 tablet.  

Live tv playback is working on my other galaxy tablet, phone, and windows computers.  All running Leia Beta 3

Having selected a channel from the guide or channel list and switched to it.  It indicates in the top right that the channel is playing, however no TV picture is displayed.

Nacigating back, which would eventually take you to the playing media only ever takes to the main kodi menu.  Kodi at this point seems to be frozen.  It's not possible to select another tv channel to switch to.  It is also not possible to launch other media or exit kodi.  Eventually Android displays a message that kodi is not responding, or I have to kill it in the task manager.

Any ideas?

Josh
Reply
#4
I have had similar issues with the NextPVR addon in Kodi 18.  (Running on Amlogic S905X box on Librelelec)  As mentioned in pkscout's reply, disabling "Enable timeshift with LiveTV" in the NextPVR advanced configuration does allow live TV channels to start most of the time.   Interestingly, even with that option disabled, if I watch a live TV channel for a while, the pause button does appear anyway, and does appear to work, but I have trouble skipping backwards/forwards.  

Not sure if it's the NextPVR add on, or issues that remain unresolved in the current Kodi 18 beta, but I am finding the live TV and timeshifting not nearly as "stable" as they were in Kodi 17.  In addition to the timeshift issues, I also experience choppy playback, etc.
Reply
#5
Another developer (not sub) rewrote the timeshifting support for v18.  It had problems before but now it is almost not usable.  Brief pausing when timeshifting is off might work because it just suspends streaming but I am not sure how long the server will hold on before aborting a "dead" stream.  As you noted navigation is not supported and trying it is a waste of time.

Martin
Reply
#6
Nobody will have any clue what's wrong if no-one provides a debug log (wiki).
Learning Linux the hard way !!
Reply
#7
Can confirm. Disabling Time Shift brought back Live TV playback.
Using HDHR-3 and Amazon Stick 4K.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Can't watch any channel, nothing happens but Kodi tells me it is playing it00