Linux [SOLVED] Setting initial display port on bootup screen (not really Kodi-related)
#1
Photo 
This isn't really Kodi-related, so if the response is simply a link to a solution on some other forum then I'll happily take that... but I'm guessing it's an issue that may plague a few here (and frankly there's a higher level of support and knowledge on these boards than many others I attend so I'm confident I'll get a resolution).

My setup is Ubuntu16 running on a Gigabyte box connected to a 720P monitor via HDMI and when it initially boots the display is pretty messed up - text blocky and blurry, wrapping around to ghost across itself and when it begins to list services much of the info is off-screen:

Image

Once Kodi comes up, everything displays fine (most of the time) - but if there's a startup issue I can't read the console messages.  I end up having to plug in a small VGA console to read what's up:

Image

So, the question is: can I add something to my boot parameters to either appraise ubuntu of the HDMI resolution when detected, or to force a specific typeface so I can see the bootup messages correctly? Or are there tweaks in /etc/X11 I can do to prevent the detected HDMI device displaying off-screen?

Thanks for any help!
Reply
#2
sudo dpkg-reconfigure console-setup possibly ?
Learning Linux the hard way !!
Reply
#3
You are possibly very correct... but I'm guessing I need to do this from the HDMI TV and not from within a remote SSH session?

Just gave it a run (from the remote session) and... well, I'm not sure what the answers should be.  However, doesn't stop me from reading a few man pages, so that's a good place to start, thanks!
Reply
#4
(2018-10-21, 11:59)black_eagle Wrote: sudo dpkg-reconfigure console-setup possibly ?
 Sadly, this didn't work - or rather, it didn't fix my problem. 

I realise now it's not the font that's the issue, but the displayport sent by Ubuntu not matching the display of the TV.  dpkg-reconfigure console-setup only seemed to change the typefaces, sizes and encoding, not their actual position on the screen.

So.. is there any setting that affects a console offset?  The display works fine when using VGA, so I'm guessing it's some setting I need to specify if it detects the HDMI port being used.  "xrandr" simply gives "Can't open display" so not sure how I can use an SSH session to request more information about the HDMI settings (or even change them)
Reply
#5
Are you sure it's not the TV that's at fault here ?  Sounds to me like an overscan issue, in which case the proper fix is to turn it off on the TV.
Learning Linux the hard way !!
Reply
#6
(2018-10-27, 15:21)black_eagle Wrote: Are you sure it's not the TV that's at fault here ? 
Could very well be.  However, I'm not sure how to change settings from a TV perspective - I've had to adjust the settings in Kodi to get the picture properly positioned, but that's the graphical display (F7) - console and all other text displays are off-screen.

>Sounds to me like an overscan issue, in which case the proper fix is to turn it off on the TV.I'll take a look through the TV settings, see if this is something I can do for the HDMI input (now I know to look for "overscan".  Thanks for the pointers!
Reply
#7
If you had to use Kodi's calibration tools to make it fit the screen then it definitely sounds to me like an overscan issue.  Decent article here that explains why it's a bad thing and how to turn it off for various different manufacturers.  On my sammy it's 'screen fit' for instance.  The overall effect of turning it off is that everything moves 'inwards' from the edges by up to 5%.  You should really have it turned off anyway for proper 1:1 pixel mapping.
Learning Linux the hard way !!
Reply
#8
TV is a Sharp LC32SH130K... I found the datasheet as a PDF, but the menus look slightly different to what I have. However...

... it seems the setting only came up when the TV is flicked in HDMI - I changed it from "zoom" to "full" and the Kodi image shrunk slightly.  Recalibrated the pic in Kodi and it seems the overscan values dropped back to (0,0) each time. Doh!

Flicked it to normal terrestrial TV and the picture's still fine, so that "zoom" or "full" option is specific to the HDMI port and not generic across all inputs.

So.. you were right, @black_eagle - definitely a TV setting. I won't flick it over to the console to check just yet (last time I did then flicked it back to the GUI for some reason it wouldn't come out of the screen blanker) but it seems I may have cracked it, thanks to you help!

Edit: flicked it to the other screens (CTRL+ALT+F1->F6) and all looks great. Thread marked solved!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[SOLVED] Setting initial display port on bootup screen (not really Kodi-related)00
This forum uses Lukasz Tkacz MyBB addons.