Skin Helper Widgets Service Error
#16
(2019-12-14, 16:42)sualfred Wrote: We are aware of it. In the meantime downgrade to 0.10.0 -> https://mirrors.kodi.tv/addons/leia/scri...0.10.0.zip

How do I downgrade? Never done that before?
Reply
#17
Download that zip file, then use the Install via zip file method in settings>Addons
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#18
(2019-12-14, 16:42)sualfred Wrote: We are aware of it. In the meantime downgrade to 0.10.0 -> https://mirrors.kodi.tv/addons/leia/scri...0.10.0.zip

Thank you!

Is there a place we can monitor to see if/when this is fixed?
Reply
#19
Ive reverted to 0.10.x but now im being offer 0.15.x

that seems quite a version leap?
Reply
#20
Reserecting an old thread, since last night i am seeing all the skin helper services and widgets showing error. I have the marcelveldt repo so appears to be ll up to date. Any ideas
Reply
#21
(2019-12-15, 05:12)crazy-c Wrote: Reserecting an old thread, since last night i am seeing all the skin helper services and widgets showing error. I have the marcelveldt repo so appears to be ll up to date. Any ideas

Having the same problem, Estuary Mod V2 Skin, anyone found a solution?
Reply
#22
I am using Aeon MQ8 and also experiencing skin helper errors over several of the widgets. I noticed arrow updated itself on the 14th Dec. I will downgrade, however 0.10.0 is n longer available on only 0.15.4 and 0.15.5
Fixed, updated my repo's
Reply
#23
It's the add-on arrow that was updated a fix is in the works.
Reply
#24
(2019-12-15, 04:11)dm21912 Wrote: Ive reverted to 0.10.x but now im being offer 0.15.x

that seems quite a version leap?

I installed 0.15.5 from the Kodi repository and the error is gone. In fact the 0.10.0.zip mentioned before is not available anymore, so I guess that 0.15.5 is the recommend version now.

PS: If you can not see the new version in Kodi, don't forget to update your repositories. ;-)
Reply
#25
(2019-12-15, 05:29)muza Wrote:
(2019-12-15, 05:12)crazy-c Wrote: Reserecting an old thread, since last night i am seeing all the skin helper services and widgets showing error. I have the marcelveldt repo so appears to be ll up to date. Any ideas

Having the same problem, Estuary Mod V2 Skin, anyone found a solution? 
Go here @muza 350083 (thread)
Reply
#26
Installed 0.15.5 and error still shows up. Tried 0.15.4 and same problem. Can't find 0.10.0. Sad
Reply
#27
(2019-12-15, 06:22)Headhunter3k Wrote: PS: If you can not see the new version in Kodi, don't forget to update your repositories. ;-) 
what you mean? how can i update official kodi repository to display 0.15.5?
Reply
#28
@LeKodeur post your kodi log 
@Element_Hg in the addon browser in available updates or via the addon info dialog
Embuary | Skin | Helper | Info | Repo | GitHub
Reply
#29
(2019-12-14, 20:14)sualfred Wrote: The fix is currently pending.

In the meantime you can downgrade to 0.10.0

https://mirrors.kodi.tv/addons/leia/scri...0.10.0.zip

 This problem is also affecting script.embaury.info

Code:
2019-12-15 09:44:16.831 T:3423511424   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ImportError'>
                                            Error Contents: No module named backports.functools_lru_cache
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/script.embuary.info/default.py", line 7, in <module>
                                                from resources.lib.helper import *
                                              File "/storage/.kodi/addons/script.embuary.info/resources/lib/helper.py", line 15, in <module>
                                                import arrow
                                              File "/storage/.kodi/addons/script.module.arrow/lib/arrow/__init__.py", line 3, in <module>
                                                from .arrow import Arrow
                                              File "/storage/.kodi/addons/script.module.arrow/lib/arrow/arrow.py", line 19, in <module>
                                                from arrow import util, locales, parser, formatter
                                              File "/storage/.kodi/addons/script.module.arrow/lib/arrow/parser.py", line 12, in <module>
                                                from backports.functools_lru_cache import lru_cache  # pragma: no cover
                                            ImportError: No module named backports.functools_lru_cache
                                            -->End of Python script error report<--

Your provided link to arrow-0.10.0 results in a Not Found message Sad Where else is this available from?


EDIT:-

Ok, I see that arrow has been updated to 0.15.5, this is now working fine Big Grin
Reply
#30
In my case, the "arrow" component updated automatically after I triggered the repo update. Also another (depending?) component was updated automatically (something with "dateutil" - sorry, I cannot check right now as I am not at home).
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Skin Helper Widgets Service Error00
This forum uses Lukasz Tkacz MyBB addons.