v18 recorded TV delete issues
#16
Ok, thanks.  It is online now.  All you do is go to the 'Updates' tab in serverwmc and set the updates type to: Preview.  Then hit the 'check now' button to look for the newest preview update.  It should find preview version 1257.  Then just hit 'apply update'.   Let me know what you find.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#17
(2019-03-18, 18:04)krustyreturns Wrote: Ok, thanks.  It is online now.  All you do is go to the 'Updates' tab in serverwmc and set the updates type to: Preview.  Then hit the 'check now' button to look for the newest preview update.  It should find preview version 1257.  Then just hit 'apply update'.   Let me know what you find.
Good news - no more hangups!!!

Not perfect though - deleted a "folder" with 10 recordings - ended up deleting 7 of them, leaving three. Counter on the right side was set to 3, only showing the 3 left (so update took place), counter on the left stayed at 10 however. Another "delete folder" got rid of the last 3 and removed the folder from the lest side - so that updated once the last entry in the folder went away.

Other test with a 38-recording folder showed a similar behaviour. Smaller folders - 3-4 recordings - go away in one go.

I'm happy - no more hangups!!

thnx
Reply
#18
Good, thanks for letting us know.  As for not all the files deleting, possibly its due to another swmc setting.  Take a look at wmc's settings file (see debug tab).  Search for FastMassDeleteFilterEnabled and set it to false.  Save the file then restart swmc.

The background of this setting is that it stops swmc from deleting a lot of files if the requested deletions are rapid and too numerous.  I put this in because one of my kids once wanted to delete a series folder.  Since they were viewing the files inside the folder, they though the way to delete the folder while inside it, was to itself was to delete the '..' at the top of the list which kodi was happy to let them do.  It deleted every recording we had.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#19
I'm seeing an issue that might be related to this. I'm currently working on reproducing it with a log to go along. I can create a separate thread if necessary. Basically, what happens is, I will delete a recorded video, then go to play a different recorded video from a separate show, and it won't play (circle spins for a moment, then nothing). In the ServerWMC log, it will show up as a few "StreamStartError" lines. But if I close and re-open the Kodi client, the recorded video that I was trying to play will *then* play just fine.
Edit: Now I'm also seeing it after recording two different shows within the same Kodi client instance, then trying to play either one, and they both just give me circle spins for a sec. If I close and re-open the Kodi client, I can successfully play them.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
recorded TV delete issues00