v18 -  The addon no longer handles caching of images and channel icons
#16
(2018-12-02, 16:08)Christian_Haitian Wrote: Hello,

I updated to the latest release of this addon while on Kodi Krypton 17.6 and I no longer have my channel icons that were loaded from my mythtv backend (version 29.1). With the recent change per the announcement, does this mean that the only way to get the channel icons to load will be to update to Kodi Leia?
What is the version you have installed ? I guess it is the latest I published few days before. This version (4.18.1) includes the related change here, and the channel icons cache is no longer used. All channel icons are loaded from your backend on demand by kodi using mythtv api service. Since MythTV 0.27 all channel icons have to be dropped in the special folder ".mythtv/channels/" based in the home directory of the backend owner i.e "mythtv". If it is not the case you won't succeeded to get icons. A good practice should be to reconfigure your icons running mythtv-setup (with the backend owner i.e mythtv). If you know SQL you could manually configure the icons by updating the table "channel": the column "icon" should contain the icon filename (without path, only the filename).
Reply
#17
(2018-12-02, 23:28)janbar Wrote:
(2018-12-02, 16:08)Christian_Haitian Wrote: Hello,

I updated to the latest release of this addon while on Kodi Krypton 17.6 and I no longer have my channel icons that were loaded from my mythtv backend (version 29.1). With the recent change per the announcement, does this mean that the only way to get the channel icons to load will be to update to Kodi Leia?
What is the version you have installed ? I guess it is the latest I published few days before. This version (4.18.1) includes the related change here, and the channel icons cache is no longer used. All channel icons are loaded from your backend on demand by kodi using mythtv api service. Since MythTV 0.27 all channel icons have to be dropped in the special folder ".mythtv/channels/" based in the home directory of the backend owner i.e "mythtv". If it is not the case you won't succeeded to get icons. A good practice should be to reconfigure your icons running mythtv-setup (with the backend owner i.e mythtv). If you know SQL you could manually configure the icons by updating the table "channel": the column "icon" should contain the icon filename (without path, only the filename).

Hello,

The version I linstalled is indeed the most recent one you published (4.18.1). My channel icons are within .mythtv/channels/ folder which is within the home of the backend owner “i.e mythtv”. Last year I had used mythtv-setup to associate each of the icons to the appropriate channels using the guide available at https://www.mythtv.org/wiki/Channel_icon...l_Location. The icons display fine within the listings view from the backend’s webserver. I wonder if the issue is because my Kodi client is Krypton (v17) and not Leia (v18). Perhaps Krypton does not handle the loading of icons with version 4.18.1 of your addon?
Reply
#18
@Christian_Haitian , it works here and so it should work at your home.
You could test the api call manually to check the backend response:

http://backend_ip:6544/Guide/GetChannelIcon?Width=300&ChanId=your_number

Replacing backend_ip with the backend ip, and your_number with an existing channel id.
Reply
#19
Thank for the tip Janbar. Looks like I get a 404 Not Found error. I’ll need to investigate what’s wrong with my backend channels icons setup to resolve this. Perhaps it’s time I look at moving to xmltv for TV schedules which I understand automatically loads icons instead of the manual process I completed last year.
Reply
#20
Correction to my previous post.  I was using Channel Number instead of Channel ID.  This is why I was getting the 404 Error before.  When I use Channel ID, the icons show using the troubleshooting step.  So not sure why the new 4.18.1 plugin does not bring up the channel icons in Kodi 17.6.
Reply
#21
@janbar I did not have channel icons configured and after so much talk of it in this thread, I have created some and they appear to be working absolutely fine with Kodi 18 RC2 and pvr.mythtv 5.10.2.  My backend is mythtv 29.1.
Reply
#22
@Christian_Haitian, maybe you will resolve your issue by enabling the debug logging in Kodi. To do it:

- Go to Settings / System / Logging
- Enable the setting "Enable debug logging"
- Enable the setting "Enable component-specific logging
- Enter in "Specify component-specific logging" and select "Verbose logging for the libcURL library (HTTP(s), DAV)"
Finnally restart Kodi. Then you will able to investigate what happens by searching in the file kodi.log for "Curl". It will show details of calls to get icons from the backend.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
The addon no longer handles caching of images and channel icons00