Aeon Nox 5 Not Compatible with Kodi 18 RC1
#1
As Kodi 18 is at RC1 I thought I would try it on my 17.6 build which uses Aeo Nox 5 skin.
I am using Windows 10 laptop, downloaded Kodi 18 RC1, installed Kodi 18 RC1, it detected my already installed Kodi 17.6, went through it's installation addon conversion, only issue it reported was that Aeon Nox 5 was not compatible.
Following Kodi 18 RC1 addon conversion using Kodi I went to download more skins, only about 5 skins found, none for Aeon Nox 5.
Is there an Aeon Nox 5 skin version for Kodi 18?
Is there an Aeon Nox 5 skin for Kodi 18 planned?
Reply
#2
Looking over the commit history and going by my memory Aeon Nox 5 should work just fine with the latest Leia version.

Only things missing are DefaultMusicSources icon, doesn't hide the seekbar on Player.FrameAdvance, the new dependencies button that 95% of people don't need, some PVR stuff, and just some cleanup like removing ADSP xmls but none of that should cause any issues in most situations.

BigNoid just has not gotten around to bump the GUI version in the addon.xml file.

All you really need to do is change line 4 from this:
Code:
<import addon="xbmc.gui" version="5.13.0"/>
to this:
Code:
<import addon="xbmc.gui" version="5.14.0"/>

Restart Kodi then enable the skin in Kodi's add-on manager. It is under My add-ons > Look & Feel > Skins > Aeon Nox 5.
Reply
#3
(2018-11-30, 19:09)mikeSiLVO Wrote: Looking over the commit history and going by my memory Aeon Nox 5 should work just fine with the latest Leia version.

Only things missing are DefaultMusicSources icon, doesn't hide the seekbar on Player.FrameAdvance, the new dependencies button that 95% of people don't need, some PVR stuff, and just some cleanup like removing ADSP xmls but none of that should cause any issues in most situations.

BigNoid just has not gotten around to bump the GUI version in the addon.xml file.

All you really need to do is change line 4 from this:
Code:
<import addon="xbmc.gui" version="5.13.0"/>
to this:
Code:
<import addon="xbmc.gui" version="5.14.0"/>

Restart Kodi then enable the skin in Kodi's add-on manager. It is under My add-ons > Look & Feel > Skins > Aeon Nox 5. 
Thanks for reply, making the changes as you detailed allowed me to use Aeon Nox skin.

For information one difference was that following install of Kodi 18 RC1 and addon migration <import addon="xbmc.gui" version="5.13.0"/> in my case was <import addon="xbmc.gui" version="5.12.0"/>
Reply
#4
Looking this over again...

You and everyone else should ignore my previous recommendation. I did not know about ABI and backward capability until just a day or two ago.

If you see:
Code:
<import addon="xbmc.gui" version="5.12.0"/>
Then that has to be due to you updating from an older Kodi version and not checking for updates in the add-on manager after you recently updated to a new Kodi version.

Please install the latest skin version from the default Kodi repo immediately after updating Kodi.

If you still have a problem after following the instructions, please check for updates...

If you have checked for updates and the skin is still disabled, then and only then, you should check that line to see if BigNoid has not already updated Aeon Nox 5 yet.

Sorry for the previous misinformation.
Reply
#5
(2018-12-01, 01:59)mikeSiLVO Wrote: Looking this over again...

You and everyone else should ignore my previous recommendation. I did not know about ABI and backward capability until just a day or two ago.

If you see:
Code:
<import addon="xbmc.gui" version="5.12.0"/>
Then that has to be due to you updating from an older Kodi version and not checking for updates in the add-on manager after you recently updated to a new Kodi version.

Please install the latest skin version from the default Kodi repo immediately after updating Kodi.

If you still have a problem after following the instructions, please check for updates...

If you have checked for updates and the skin is still disabled, then and only then, you should check that line to see if BigNoid has not already updated Aeon Nox 5 yet.

Sorry for the previous misinformation.   
All on my Windows 10 Laptop.
I de-installed Kodi 18 RC1 and associated folders.
Re-installed Kodi 17.6 and my 17.6 build using Aen Nox 5.
Re-installed Kodi 18 RC1, which migrated addons and gave this error message:-
Image
When I go to install Aeon Nox 5 from Kodi repo it's not there, only these skins listed:-
Image
Checked for updates got this message:-
Image

I found after applying the change previously detailed that if I chose to configure addons I got this problem:-
Image

I am a bit lost how to proceed from here?
Reply
#6
It appears that until the updated skin is posted you will need to install manually.

You can use THIS file to install from zip in Kodi's add-on manager.
Reply
#7
(2018-12-01, 16:33)mikeSiLVO Wrote: It appears that until the updated skin is posted you will need to install manually.

You can use THIS file to install from zip in Kodi's add-on manager.
Many thanks for that link, installed and quick initial testing looking good :-)
Reply
#8
(2018-12-01, 18:23)Jeffers24 Wrote:
(2018-12-01, 16:33)mikeSiLVO Wrote: It appears that until the updated skin is posted you will need to install manually.

You can use THIS file to install from zip in Kodi's add-on manager.
Many thanks for that link, installed and quick initial testing looking good :-) 
Just installed KODI 18. rc5 and Silvo 6.16 and 6.13 is not compatible. The one you recommended does work perfect and thank you. The only issue is I have to configure skin>set up aeon nox menu and have to reconfigure my menu, submenu, background and addons and its really time consuming. My question is can this configuring be easier?  Is there going to be a Silvo for the this rc5 or just waiting for Leia  to be finished?  Thank you
Reply
#9
Currently I am using Aeon Nox Silvo (Mod) 6.0.7 on Krypton 17.6. I want to update to 18 leia. The Silvo Mod 6.0.7 is not compatible with Leia but I want to keep that skin  and the configuration I did to it. I lioke to keep my modded font, colors of the interface. Any suggestions?? Thanks
Reply
#10
Well Aeon Nox 5 Version 7.02  worked with Leia 18 RC5 and was able to modify the font..
Reply
#11
(2019-01-28, 04:19)rosario04 Wrote: Well Aeon Nox 5 Version 7.02  worked with Leia 18 RC5 and was able to modify the font..
 Where can I get Aeon Nox 5 Version 7.02?

Currently I am using a modded Version 6.1.0 kindly provided by Silvio a few posts back in this thread
Reply
#12
The download link in Post #6 is v7.0.2 which is an exact copy of the latest Git version of OG Aeon Nox 5 from @BigNoid. The only difference is the media folder contains a Textures.xbt file instead of the individual image files.

Not sure if you guys are mixing up SiLVO version with Original Aeon Nox 5 but it seems that way...
Reply
#13
(2019-01-28, 21:47)mikeSiLVO Wrote: The download link in Post #6 is v7.0.2 which is an exact copy of the latest Git version of OG Aeon Nox 5 from @BigNoid. The only difference is the media folder contains a Textures.xbt file instead of the individual image files.

Not sure if you guys are mixing up SiLVO version with Original Aeon Nox 5 but it seems that way...
 Yes, I was mixing up Aeon Nox on 17.6 v6.1.0 with your Leia v7.0.2 :-(

Do you know if an official Aeon Nox for Leia is in the pipeline, now that Leia has an official release?
Reply
#14
(2019-01-28, 21:47)mikeSiLVO Wrote: The download link in Post #6 is v7.0.2 which is an exact copy of the latest Git version of OG Aeon Nox 5 from @BigNoid. The only difference is the media folder contains a Textures.xbt file instead of the individual image files.

Not sure if you guys are mixing up SiLVO version with Original Aeon Nox 5 but it seems that way...

Is that why the version of Aeon Nox Redux you posted works with Leia 18+ versions because of the textures.xbt file?

Also

We spoke a while back about possibility of creating a tool to transfer settings from Aeon Nox Redux to the Silvo version.
Have you had a chance to do that or did you decide not to?

Also there were some things that were preventing me from sticking with the Silvo version like limited menu and submenu items.
Were there any plans to allow more for those who like more than 5 menu options with their custom builds?

It doesn't look like BigNoid will is very active anymore and either I need to learn Python and do it myself or search for an alternative. If the wheel don't need to be recreated, I ain't lookin' to do it.
~ Creator of none, hacker of some, jack of all traits, master of some...
~ YIRMASTER ~
Domaineer, Coldfusion Dev, Kodi customizer, Hedonist
Reply
#15
(2019-08-10, 19:25)YIRMASTER Wrote: Is that why the version of Aeon Nox Redux you posted works with Leia 18+ versions because of the textures.xbt file?

Also

We spoke a while back about possibility of creating a tool to transfer settings from Aeon Nox Redux to the Silvo version.
Have you had a chance to do that or did you decide not to?

Also there were some things that were preventing me from sticking with the Silvo version like limited menu and submenu items.
Were there any plans to allow more for those who like more than 5 menu options with their custom builds?

It doesn't look like BigNoid will is very active anymore and either I need to learn Python and do it myself or search for an alternative. If the wheel don't need to be recreated, I ain't lookin' to do it.

No it works cause of a 1 line change of updating the GUI requirement in the addon.xml.

I never said I would create a tool to import anything, you made that up somewhere along the way. What I did say was that I might drop Skin Shortcuts since it is unmaintained.

Even if I did that you would still need to recreate the menus. It is a different skin altogether so is not compatible with OG Aeon Nox 5 settings or Main Menu.

You don't need to learn python you just have to make the damn Menu again. It is really not that hard or time consuming. For testing I redo theMain Menu all the time on fresh installs and it's very fast to do so.

Also you can have an unlimited amount of Menu/Submenu items so not sure why think you can only have 5 Huh
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Aeon Nox 5 Not Compatible with Kodi 18 RC100