v18 -  nVidia Shield - DVD ISO playback problem with Leia

I'm using Kodi on my nVidia Shield TV (2015).
Video files are streamed from my NAS thru NFS.

With some DVD ISOs (Star Trek DS9 and Star Trek Voyager DVDs for example), using beta versions of Leia (up until nightly of November 28th), the picture isn't completely smooth. There's a small "jump" ("stuttering" ?) approximately 2-3 times/sec. It's there constantly from beginning to the end of the file. 

Since December 2nd nigthly (kodi-20181202-812855d8-master-arm64-v8a.apk), it's worse and practically unreadable : the image is freezing almost completely (but audio is ok), stepping forward every 5-10 seconds. Not really playing, just showing an image for 5-10 seconds will the sound is playing fine, then going forward to another one, etc.

Blu-ray ISOs and other video files are fine.

The stuttering problem wasn't there on Kodi v.17 and on Kodi V.18 alpha.
It appeared on beta versions of v.18 (beta 3 I think, but I'm not sure about that...)

The "unreadable" problem wasn't there before December 2nd nightly and is still there on the official RC.

Any thoughts ?
Here's some more details and examples.

My setup:
nVidia Shield TV -> Pioneer AV receiver -> LG OLED UHD TV

I've recorded three examples of the same video (Star Trek DS9) with three versions of Kodi (I know, the colors are off and the image is not centered... But that's not the point).

You'll see that the problems I've mentioned are present only with the episode, not with the DVD menu animations.
That tells me that those problems are probably due to some deinterlacing detection mistakes.

For each example :
  • I uninstalled Kodi from my nVidia Shield;
  • Install another version of KODI by downloading the files from https://mirrors.kodi.tv/releases/android/arm64-v8a/
    and put them in the "Download" folder of the Shield;
  • Changed six things in the Settings menu (everything else is by default) :
    • System/Display : Delay after change of refresh rate -> 2.5 seconds
    • System/Display : Set GUI resolution limit -> Unlimited
    • System/Audio : Number of channels -> 7.1
    • System/Audio : Allow passthrough -> On (and all the other passthrough options under that to "On")
    • Player/Videos : Adjust display refresh rate -> On start / stop
    • Player/Videos : Processing : Allow hardware acceleration - MediaCodec (Surface) -> Off
(Yes, I tried to populate the whitelist, but it didn't change anything)

Here's the video with v18 RC2 (unreadable) :

Here it is with v18 RC1 (readable but small stuttering. That problem is mostly apparent on long movements, see the opening sequence at 0:20) :

And with v18 Beta 1 (readable, no stuttering and deinterlace mode not automatic) :
Oh! I forgot: it's not me that makes the video infos appearing and disappearing in the RC2 example. It's doing that all by itself...
I checked again today with v18RC2and the problem of video not playing is there for any DVD ISO, not just TV shows.

Here's the log:

I opened a issue on GitHub:
Same problem here but it was ok on the rc2 nightly from 26 or 27 november, i don't really remember the day precisly.
Today i installed the latest nightly and i got the same issue.
(2018-12-07, 08:19)AlleV8 Wrote: Same problem here but it was ok on the rc2 nightly from 26 or 27 november, i don't really remember the day precisly.
Today i installed the latest nightly and i got the same issue.
Yes, you're right. The problem seems to be starting after November 27th.
Last night, I tried directly with a small .VOB file that I've extracted from a DVD and put in a local folder of the nVidia Shield.
The problem is the same. I really think it's a deinterlacing problem.

Link to that file : https://drive.google.com/open?id=1Asw7xY...tU-VTFirIA
I've made more testing this morning and I can confirm that the issue was introduced in the November 28th nightly (kodi-20181128-5880ccf2-master-arm64-v8a.apk).

The video file is playing fine on November 27th nightly (kodi-20181127-93086fd8-master-arm64-v8a.apk).
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
nVidia Shield - DVD ISO playback problem with Leia00