Where and how install inputstream.adaptive addon in KODI
#1
Hi,
a message say "missing inputstream.adaptive in your KODI install".
Where can find an install tutorial for this videoplayer inputsream addon?

I'm new with KODI. 
WIN10 on PC ACER PREDATOR HELIOS 300

TY for help by advance
Reply
#2
It can be installed from the Kodi repository. Go to...

Add-ons > Box Icon top left of the screen > Install from repository > VideoPlayer InputStream > InputStream Adaptive
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#3
Which version of Kodi are you running?

For up to date versions, you should find it in the official repo (the built-in one).

First from the main menu go Addons > My Add-ons > Videoplayer InputStream and if it's there select InputStream Adaptive and check it's enabled.

If it's not installed, go to Addons > Install from repository > Kodi Add-on repository (you may not need this step if you have no other repo's installed) > VideoPlayer InputStream and install it from there.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#4
(2018-12-13, 11:08)Karellen Wrote: It can be installed from the Kodi repository. Go to...

Add-ons > Box Icon top left of the screen > Install from repository > VideoPlayer InputStream > InputStream Adaptive
 also get this error

I trying updating/reinstalling the addon but get an error messag

"the dependency on kodi.binary.global.main...."

how to fix this?

What is the purpose of this addon
and what addons or function needs this?
Reply
#5
(2019-02-14, 09:11)madmax2 Wrote:
(2018-12-13, 11:08)Karellen Wrote: It can be installed from the Kodi repository. Go to...

Add-ons > Box Icon top left of the screen > Install from repository > VideoPlayer InputStream > InputStream Adaptive
 also get this error

I trying updating/reinstalling the addon but get an error messag

"the dependency on kodi.binary.global.main...."

how to fix this?

What is the purpose of this addon
and what addons or function needs this? 
Make sure you are using the up to date stable Kodi 18. If you try to install the latest inputstream.adaptive version on pre-release Kodi 18 rc or beta you will get that error.
hGO EU add-on (Forum / GitHub / Wiki), PLEASE IF YOU ARE REPORTING AN ISSUE PROVIDE Kodi Debug Logs
Reply
#6
(2019-02-14, 13:02)arvvoid Wrote:
(2019-02-14, 09:11)madmax2 Wrote:
(2018-12-13, 11:08)Karellen Wrote: It can be installed from the Kodi repository. Go to...

Add-ons > Box Icon top left of the screen > Install from repository > VideoPlayer InputStream > InputStream Adaptive
 also get this error

I trying updating/reinstalling the addon but get an error messag

"the dependency on kodi.binary.global.main...."

how to fix this?

What is the purpose of this addon
and what addons or function needs this?   
Make sure you are using the up to date stable Kodi 18. If you try to install the latest inputstream.adaptive version on pre-release Kodi 18 rc or beta you will get that error.  
 thanks

was on kodi v18 rc5..

it installed after I
-upgraded to kodi 18 
-upgraded to kodi 18.1 RC1

what is purpose of this addon?
which addon needs this?
Reply
#7
(2019-02-15, 01:18)madmax2 Wrote:
(2019-02-14, 13:02)arvvoid Wrote:
(2019-02-14, 09:11)madmax2 Wrote:  also get this error

I trying updating/reinstalling the addon but get an error messag

"the dependency on kodi.binary.global.main...."

how to fix this?

What is the purpose of this addon
and what addons or function needs this?  
Make sure you are using the up to date stable Kodi 18. If you try to install the latest inputstream.adaptive version on pre-release Kodi 18 rc or beta you will get that error.  

what is purpose of this addon?
which addon needs this? 
It's a client for adaptive streams and can play DRM content using an external library like Widevine.
A lot of different add-ons relly on inputstream.adaptive for playback. (example: Youtube, Netflix, Amazon, Hbo Go, ecc...ecc...ecc... )
hGO EU add-on (Forum / GitHub / Wiki), PLEASE IF YOU ARE REPORTING AN ISSUE PROVIDE Kodi Debug Logs
Reply
#8
Hi All

Running kodi 18.4 on osmc vero box 4K.

My inputstream addon is stuck at 2.3.22 and it will never update, even though there are newer versions. I tried to use https://github.com/peak3d/inputstream.ad...master.zip as the repository to install but that gave errors and wouldn't install the repository.

How do I install the latest version and get it to update itself when necessary?
I'm not very learned up on linux but will be able to follow commands from the ssh.
Reply
#9
First thing to try is updating the repo itself. Navigate to it in the addon browser (My Addons > Addon Repository , open the context menu for the Kodi menu and select information adn then update). If there's any update there then do it and try again with the update for inputstream.adaptive.
|Banned add-ons (wiki) Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

My Blog Posts
Reply
#10
@floatingkiwi Inputstream.adaptive 2.3.22 is the latest stable version available. So for stable everyday use, that's the version that should be used. Inputstream.adaptive is a binary add-on written in c++ witch means, it has to be built/compiled for the specific platform you are going to use it on.
By downloading the master.zip from GitHub you simply downloaded the current source code, to use it, you would need to build/compile it yourself for your specific platform.
Inputstream.adaptive is available through the Kodi official repository, and on various Linux distributions through the repositories of the os maintainers, so you don't have to worry about it, it will get auto-updated as soon a new version for your system is available.
hGO EU add-on (Forum / GitHub / Wiki), PLEASE IF YOU ARE REPORTING AN ISSUE PROVIDE Kodi Debug Logs
Reply
#11
(2019-11-01, 14:21)arvvoid Wrote: @floatingkiwi Inputstream.adaptive 2.3.22 is the latest stable version available. So for stable everyday use, that's the version that should be used. Inputstream.adaptive is a binary add-on written in c++ witch means, it has to be built/compiled for the specific platform you are going to use it on.
By downloading the master.zip from GitHub you simply downloaded the current source code, to use it, you would need to build/compile it yourself for your specific platform.
Inputstream.adaptive is available through the Kodi official repository, and on various Linux distributions through the repositories of the os maintainers, so you don't have to worry about it, it will get auto-updated as soon a new version for your system is available.

excellent thank you!!
Reply
#12
(2018-12-13, 11:08)Karellen Wrote: It can be installed from the Kodi repository. Go to...

Add-ons > Box Icon top left of the screen > Install from repository > VideoPlayer InputStream > InputStream Adaptive

Hi 
I am running Kodi 17.8 : can not find the Input Stream adaptive here.....what am I doing wrong?

Thanks
Reply
#13
(2019-11-07, 17:01)[email protected] Wrote: I am running Kodi 17.8 : can not find the Input Stream adaptive here.....what am I doing wrong?
You mean Kodi v17.6, there is no v17.8

Those instructions are for v18. Try updating to v18
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#14
(2018-12-13, 10:52)Unknow28 Wrote: Hi,
a message say "missing inputstream.adaptive in your KODI install".
Where can find an install tutorial for this videoplayer inputsream addon?

I'm new with KODI. 
WIN10 on PC ACER PREDATOR HELIOS 300

TY for help by advance
sudo apt-get install kodi-inputstream-adaptive 
Reply
#15
Installed inpoutstream, kodi19. The YouTube-Mpeg Dash section was activated . When playing video clips of good quality for some reason is offered in the standard-mpd, this file does not play the Kodi player for some reason ? It is not clear why the choice is not offered for MP4. 2080p-4k ? Problem with the mpd format.
Reply



Logout Mark Read Team Forum Stats Members Help
Where and how install inputstream.adaptive addon in KODI0
This forum uses Lukasz Tkacz MyBB addons.