Commercial Skip broken in Kodi 18?
#61
I reinstalled 18.0 official. When i went to the add-on browser i was able to install 2.4.4. When i loaded a recording with an edl with the first line as "4.00    12.10    3", Kodi played for 4 seconds, then skipped to 12.10. You can try enabling debug (settings -> system -> Logging -> Enable Debug Logging) in kodi, then starting the recording. The Kodi debug log should show Edl Loading information.

Here is an excerpt from my kodi debug log: https://pastebin.com/1rGQSTjL

Let us know what you find.
Reply
#62
So it seems to be an issue with the format of my edl files. I used yours and it works as expected. Mine are coming right from comskip so this is odd.

I seemingly can't get logging working. I turn on logging and go to the path shown on screen, but the log file isn't being updated. I deleted it, restarted kodi, and it hasn't recreated one. I'll have to try looking into that a bit more yet, but seems to be something on my side at least.
Reply
#63
The Kodi log should be in %appdata%\kodi in windows and .kodi/temp in Linux I think.
Reply
#64
I have been a long time WMC7 user and now am trying to get my new Shield setup and working well on Kodi.  I'm using Kodi 18.1 and server 10.0.0.63 build 1255 and addon 2.4.4.  All tv and playback functions work great.  Thanks! 
Comskip works great on my PC in WMC7, but I can't seem to get it to do anything in Kodi.  So I'm not sure if comskip should now be working or if there is still a bug out there, or if it is just something I'm doing wrong.  How do I activate (make it comskip) on a shield?  Or what are my next steps.
Reply
#65
I don't use comskip, but as far as I know it works.  You just have to have the .edl file with the same name as the .wtv file and stored in the same folder.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#66
Ok, found that the .edl files were in a different folder.  And it sort of works.  But it auto skips and then I cant even go back manually.  Any way to make it a manual skip with a button press? Thanks for the quick reply by the way!
Reply
#67
I don't know.  But if there is it would be a feature of kodi, and not something I can control in the pvr addon.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#68
(2019-02-23, 21:57)soccerdad Wrote: Ok, found that the .edl files were in a different folder.  And it sort of works.  But it auto skips and then I cant even go back manually.  Any way to make it a manual skip with a button press? Thanks for the quick reply by the way!
What do you mean that you can't go back manually? Mine auto skips commercials like it is supposed to, and if I want to go back manually, I just press left arrow as usual.
Reply
#69
Check out these kodi advanced settings for EDL:

https://kodi.wiki/view/Advancedsettings.xml#.3Cedl.3E
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#70
Make sure you have edl_skip_field=3 in your comskip.ini. This sets it properly as a commercial break according to kodi. If you already have .edl files, you may edit by hand and replace the last digit with 3 so it looks like the following:

607.17    740.21    3
1416.53    1514.40    3
1942.17    2160.12    3
etc.

Hope that helps!
Reply
#71
So I am now seeing the behavior kmarq mentioned earlier.  Anytime I open a recording, it immediately jumps to the second time listed within the first line of my EDL file.  For example:  "47.124   101.254      3"  in the first line of my EDL file skips straight to 101.254 seconds into the recording right away.  I had recently updated my MCEBuddy from 2.4.1 to 2.4.9 (which in turn updated Comskip from 81.092 to 82.003) and I noticed this began to occur just after this upgrade.  My "new" EDL files created with MCEBuddy 2.4.9/Comskip 82.003 are all showing up as UTF-8 BOM encoded when I open them in Notepad++.  All "old" EDL files from previous install still work as expected and show up as "UTF-8" in Notepad++.  I can also toggle the encoding in Notepad++ and the issue seems to follow the BOM encoded version of the EDL file.  I've posted in comskip forum to see if anyone has any ideas, and may post in MCEBuddy as well.  Can anyone else verify this?
Reply
#72
Confirmed. I can reproduce by just changing the encoding on the EDL file in notepad++. I'm still on MCE 4.7 and comskip 0.81.092. All edl files are utf-8.
Reply
#73
If there is no other way out, pvr.wmc could be changed to make it BOM friendly (at least I don't know why it couldn't...).  Although we'll be back to wondering if the change would get into kodi.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#74
(2019-03-12, 05:06)krustyreturns Wrote: If there is no other way out, pvr.wmc could be changed to make it BOM friendly (at least I don't know why it couldn't...).  Although we'll be back to wondering if the change would get into kodi.
The folks on the MCEbuddy forum just confirmed that they now add a BOM to the EDL file. They are going to disable this in their next beta, but mentioned that Kodi might want to fix this to be BOM-friendly. So for now just keep all this in mind in case other folks have any similar issues. I'll post an update here when I get a chance to test their next beta. Thanks for the reply.
Reply
#75
Sounds good. Please save some of these edl files with bom, so we'd have something to work with.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Commercial Skip broken in Kodi 18?00