v18 -  SFTP addon ( login issue
I'm having issues using the SFTP addon (, which I've never had a problem with on 17.6.
First up, using CoreElec latest nightly CoreELEC-S912.arm-9.0-nightly_20190102-S912.img.gz (and previously tried stable 8.95.6 with same SFTP issues) on Kodi 18b4 (and 18b2) respectively.
Secondly, the same SFTP connection still works via all my other boxes with the same login credentials.

I believe, from my NAS logs which show:
Invalid user abcd from x.x.x.x port yyyyy
....is using part of my password as the user.  I'll get back to this in a moment.

When I first add the network location using "Browse for a new share" I add the sftp source as I have with all previous versions, it allows me to initially see the directory. 
After I have selected the directory to "Add video source", the path that shows:
sftp://[email protected]:port/mnt/volume/storage
...has the last four characters from part of my password as "abcd".
I believe something is incorrectly parsing, as this part of my password is directly after a special character, namely exclamation "!"
I also use an at @ symbol earlier in the (long) password, but to me it looks like one of these are related.
Note that this same password works perfectly well on previous 17.6 versions (on the same hardware, using either OpenElec, LibreElec or native Android).

Hopefully this is enough info for a dev to take a look, or point this back at something else which may be causing the issue. 
Please let me know if I can provide more info.  Many thanks.
try if replacing the @ in your password with %40 helps.

found that info here: https://forums.vandyke.com/showthread.php?t=2457
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Thanks for the suggestion. 
I'd already tried inserting the ascii hex in that format for each special character, collectively and individually for both the ! and the @.
The login still fails in each case (incorrect password), however, the correct username is now attempting login, rather than part of the password, which is shown in the FreeNAS logging.
(For these examples)
[email protected]1234
Jan 7 13:14:42 freenas sshd[68416]: Failed password for CORRECTUSERNAME from x.x.x.x port 42240 ssh2
FWIW, I've also tested this scenario on a Windows10 box (Kodi 18B4, SFTP 1.01) with the same results, so it seems unrelated to platform.

So in summary:
Raw password used works initially, when Add network location... selected and SFTP credentials entered, hit ok, showing in "Browse for new share":
...allowing selection and successful traversal of subdirectories to browse for a new share.  FreeNAS log confirms:
Jan 7 13:15:37 freenas sshd[68499]: Accepted password for CORRECTUSERNAME from x.x.x.x port 42240 ssh2
Next step, hit OK after selecting subdirectory path, where the path now shows:
sftp://[email protected]/mnt/volumexx/storage/media/movies
Which is rejected due to the incorrect user, illustrated by FreeNAS logs again.
Jan 7 13:36:01 freenas sshd[70357]: Invalid user 1234 from x.x.x.x port 42243
Jan 7 13:36:01 freenas sshd[70357]: input_userauth_request: invalid user 1234 [preauth]
After accepting the location, I get an unable to connect message just before setting content (obviously due to the user being incorrect), however, if I go back to the browse for new share and select the original:
I can still select (and successfully traverse) with a successful login. 

Hopefully this helps find a resolution.  Cheers.
So I did find a way to get past the bad handling of '@' symbols in the SFTP password, using the %40.  Not perfect, but here's how to do it.
Using a previously defined network location like in my previous post:
which can access this location without issues using:
[email protected]1234
Then when adding for instance a movie file location, going into Add Video Source/Browse/selecting sftp location, then drill down to directory containing movies, click OK.
Back on the "Add video source" screen, you can clearly see the path is borked.  In this case it shows:
sftp://[email protected]:port/mnt/volumexx/storage...
If you clicked ok at this stage, it fails, however if you highlight the link and click into it, you will see:
sftp://CORRECTUSERNAME:[email protected]@dns.address.net:port/mnt/volumexx/storage/media/movies
If you then change this to:
sftp://CORRECTUSERNAME:Pass!word%[email protected]:port/mnt/volumexx/storage/media/movies
The source will, after hitting ok, change to appear as:
and if ok is hit the connection now works and starts scanning in the library.

So in summary, adding the %40 to the network location password does not help, but does help when adding the source in this way.
Kind of odd, but at least there is a way around it.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
SFTP addon ( login issue00