CloseLiveStream immediately follows OpenLiveStream - No Live TV in Leia on Xbox One
#16
In thinking about it, the behavior is not limited to the Xboxes.  If I do a clean install of Leia RC 5.2 from the Microsoft Store on my SurfaceBook (Win 10), the behavior is identical to the Xboxes, and I cannot watch live TV on my SurfaceBook with that install.

Alternatively, if I do a clean install of the desktop version of Leia RC 5.2 from Kodi's download page, bypassing the Microsoft Store, live TV plays on my SurfaceBook.  (My reference above to keeping the Profile from Krypton 17.6 does not actually seem to matter.)

I do not know the core differences between the two Leia's for Windows (maybe UPW vs. legacy Windows).  One observation between the two Leia's concerns SMB/Samba.  Desktop Leia comes fully ready to add SMB sources, whereas the Microsoft Store Leia must be enabled through Add-ons/Virtual filesystems/SMB support (libsmb2) as previously addressed.

Once SMB in Store Leia is enabled, differences remain for adding sources.  To add a source through the File Manager or Media settings, Desktop Leia identifies my host/server ('HP' with Win 7) under Windows Network SMB, and allows a click-through to the shared media folders (just like Krypton).  In contrast, Store Leia displays my server 'HP' but does not allow click-throughs to other contents (it will not open, same as the Xboxes).  In further contrast, Desktop Leia also displays my Netgear share folder, 'READYSHARE', and SURFACEBOOK, both of which can be opened to access other contents.  Store Leia displays READYSHARE, which is openable, but omits SURFACEBOOK.

I don't get it.  Maybe there is something to the SMB add-on referencing 'smb2' in the parenthesis; I wonder if it is strictly SMBv2 and not inclusive of SMBv3 (or something related) and if that is the reason the shares display and behave differently for the desktop and Store versions.  I can only speculate that there is a hidden connection between being able to access the server with a click-through for adding sources, and also being able to watch live TV, as weak as that association might be, but the one does not occur without the other thus far.  Perhaps, the inability to watch live TV with Store Leia has nothing to do with PVR-WMC or ServerWMC on Win 7 (if anybody is using this combo and can watch live TV on an Xbox One, it would be nice to know.)  At first, I thought these behavior differences were between Leia and Krypton, but, as of today, I see they're between Leia and Leia as well.
Reply
#17
I think you are right that the problem is related to smb for all versions of kodi that need the libsmb2 addon.  Still, its hard to see why recorded/active tv streams work but live-tv streams don't.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#18
So it seems, and PVR-WMC is not the only one with this mystery.  I scoured the other third-party PVR backend forum sections and found an uncanny parallel within MediaPortal.  Subtitled “Xbox UWP SMB” (333995 (thread)), the poster connects his media sources through SMB.  He can watch recorded but not live TV, just as described here.   There are similar speculations about cause of the limitation, and some exchanges with one of the Kodi team members who was involved with the SMB addon.  The last entry of that thread is October without the indication of a solution.  I did not find such a clear parallel for any other PVR.
Reply
#19
Maybe the other pvr's don't use smb to access data.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#20
Krustyreturns, do you have any suggestions for next steps, redirects?
Reply
#21
I'm afraid I don't know what to do from here with my code since it works on all other platforms and in addition, I can't debug on an xbox.  All I can think is to submit a bug report, or switch to the other pvr addon that you said worked fine on the xbox.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#22
Thank you, Krustyreturns, for all your reviews.  I have redirected the inquiry to General Support/Windows UWP (win10, phone, Xbox) as Redirect: No Live TV in Leia on Xbox One - Could Samba/SMB be related to the issue? (339914 (thread)).  Again thanks, DJJR.
Reply
#23
Just thought I'd add my findings, now I've found there is SMB in Kodi for Xbox One.

Xbox One can definitely see, and play wtv files from the Recorded TV Folder on the ServerWMC server. So SMB access isn't the problem.. I also noticed occasionally, very occasionally I would see a live image pop up on screen and then disappear (I had the shits and was mashing the play button).  So I started playing with <BufferDelayLiveMS>0.  When set to anything between 600 and 3000ms, I was actually able to get about 10 seconds worth of live playback. 5000ms+ seemed to just kill it straight away again.

All other devices work perfectly. Even other PC's with UWP version installed. All devices are (now) 18.0.

Happy to provide logs if I have to time to work our how to get them off the Xbox. Wink

Oh, and recorded tv shows also work on the Xbox One.

Drexyl
Reply
#24
I need some clarification:  When you say: 'All other devices work perfectly. Even other PC's with UWP version installed. All devices are (now) 18.0.'  does that mean live stream worked once you went to kodi 18.0 all UWP devices?
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#25
I appreciate that Dreyl's addition confirms the behaviors previously described including the outcomes of adjusting the <BufferDelayLiveMS> above zero.  I look forward to more.

For recent context, I note that the Kodi installations from the Microsoft Store have undergone some significant version changes in the last 10 days or so.  While the Store still only provides the UWP version for Xbox One, other Windows installations went from a modified Krypton 17.6 to UWP (same as Xbox) to a modified Leia 18 RC desktop version (modified in the sense that the desktop .exe version is able to be provided through the Store).  The Store changes partially explain my 2019-01-24 entry above, which was a couple of days prior to other posts on the matter.  The change resulted in numerous inquires under General Support/Windows UWP (win10, phone, Xbox); in particular see Important: Windows Store v18 update reset my settings (339891 (thread)).  I further note that the Store UWP installation on my SurfaceBook changed to the apparently modified desktop .exe version overnight two days ago (I can tell the difference because the replacement does not have, nor need the libsmb2 addon to use Samba/SMB protocols).  This version plays live and recorded/active TV on my SurfaceBook, but the playback for live TV is not really watchable because of buffering or stuttering issues (as noted in other recent post).  I have kept a separate desktop installation of Krypton 17.6 on my SurfaceBook because live TV plays perfectly on it.

It still is an unknown, in my opinion, if the Samba/SMB addon is up to the task of enabling live TV for the UWP version.  It could be something else but seems likely that even so, it would still be related to the addon, perhaps in regard to the use of credentials somehow bypassing live TV and, therefore, causing the almost immediate termination.  In digging into the settings, I saw that the libsmb2 addon.xml indicates that 'supportPort' is set to 'false'.  I wonder if ServerWMC port number setting of 9080 is somehow affected as a result.  I was unable to test a change to 'true' because the UWP version is locked up tighter than Fort Knox, and now that the UWP is no longer available to my SurfaceBook, it is out of reach to me.  Lastly, to date, there has been no traction on investigating this prospect on my redirected post to General Support/Windows UWP, but there have been plenty of views.  I would be happy to know if the live TV issue is caused by something else--that would mean we are closer to a solution.
Reply
#26
All up I have 13 devices running Kodi, which have all been updated to release version of 18.0.
3 x Android devices, Live TV streaming is fine.
6 x PC's running stock 64bit exe, Live TV streaming is fine.
3 x PC's running latest UWP, Live TV streaming is fine
1 x Xbox One running UWP, no Live TV Streaming.

UWP Live TV Streaming has never been an issue with any of the 64bit PC's. Only ever on the Xbox One. Although UWP isn't something I test thoroughly, Live TV is a necessity in this house, so it's always tested.

So I guess to answer your question Krusty, No. Live streaming was already working on previous UWP versions on Windows 10 devices. Just never had it working on Xbox One. Unfortunately I can't say if it's ever worked, because I installed Kodi on Xbox One before SMB support, and then put it on the try again later pile, and I only noticed they added SMB support a few days ago, which has got me back to trying to get it working on the Xbox One again.

I understand there is a lot of talk about SMB, but personally I don't think this one is related. I can do anything else related to SMB on the Xbox One, I can copy massive files across networks, delete, rename, etc... The stream starts, I can see that. it just closes very quickly, and what seems to be gracefully for some reason.

I haven't looked into any specific exe version numbers, but if I get some time, I'll take a look.

Drexyl
Reply
#27
Thanks for the info. I think what is happening on the xbox is that it is closing the stream because it thinks there is no more data to stream.  If that's true, then for some reason the waiting for buffer fills that is in happening in pvr.wmc does not work on the xbox - like maybe it is timing out very quickly.  I am assuming it's due to the different version of SMB, but yeah, that is just a guess.  If we can get some kodi guru to look at the debug kodi log, they'd be able to say why the stream is getting closed by kodi.

@DJJR if credentials were not working the stream file wouldn't be getting opened successfully which would trigger an error in the addon and it would be reported in swmc, but neither is happening according to the logs.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#28
Krustyreturns, thanks for the credentials info. That was just a guess based upon other threads where credentials were the culprit.  How does one get an expert to look at the debug log?  That's what I was hoping my redirect would do.

Drexyl, according to the ***Edit*** note in the link from in my last comment, the UWP version for PC's was replaced with what they are calling the 'Bridge Version' of the Leia desktop exe version.  If your Microsoft Store apps update automatically, then Kodi is now the Bridge version rather than UWP, leaving only the Xbox with the actual UWP app.  That's what happened to mine.  It looks like the Kodi Team is moving toward actual UWP for PC's but not at the moment since there were so many problems with the first attempt last month (which I am not sure was intentional).
Reply
#29
Hi guys,

I just found solution for not showing TV menu on main kodi menu... it was disabled in skin settings!

Hope this is the same issue with you guys.

Best regards,
Zver
Reply
#30
Thanks, Zver, for your input.  The issue, however, does not concern the presence of a TV menu item within Kodi but the actual playing of live TV on Xbox One.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
CloseLiveStream immediately follows OpenLiveStream - No Live TV in Leia on Xbox One00