How do I enable subtitles permanently?
#1
With every file, I have to "Enable subtitles". How do I make this a permanent thing?
Reply
#2
Bring up the video OSD. Then navigate to the subtitle settings setion and enable the subtitles. Then navigate one step back, scroll down and hit "Save for all files" (or similar). then that setting will apply to any video media in your library.
Reply
#3
(2019-01-12, 23:56)DaVu Wrote: Bring up the video OSD. Then navigate to the subtitle settings setion and enable the subtitles. Then navigate one step back, scroll down and hit "Save for all files" (or similar). then that setting will apply to any video media in your library.
Wont this only set the subtitle for films currently within your library with any new additions defaulting to the standard Kodi setting?
I'm a XBMC novice :)
Reply
#4
normally not
Reply
#5
(2019-01-12, 23:56)DaVu Wrote: Bring up the video OSD. Then navigate to the subtitle settings setion and enable the subtitles. (Did this).

Then navigate one step back, (huhHuh) scroll down and hit "Save for all files" (or similar). then that setting will apply to any video media in your library. (Don't use "Library")
 While the file was playing, I went into "Settings", made sure that "Enable subtitles" was switched on, and then did the "apply to all media" thing.

Went to another file that I knew had subs, and they didn't work!!! Had to manually enable them again.

Anything else I can try?
Reply
#6
(2019-01-13, 16:04)wiab4355 Wrote:
(2019-01-12, 23:56)DaVu Wrote: Bring up the video OSD. Then navigate to the subtitle settings setion and enable the subtitles. (Did this).

Then navigate one step back, (huhHuh) scroll down and hit "Save for all files" (or similar). then that setting will apply to any video media in your library. (Don't use "Library")
 While the file was playing, I went into "Settings", made sure that "Enable subtitles" was switched on, and then did the "apply to all media" thing.

Went to another file that I knew had subs, and they didn't work!!! Had to manually enable them again.

Anything else I can try?
"Bring up the video OSD" is the part you didn't do.

While a video is playing, press OK. The On Screen Display is now shown. Now navigate to the gear icon (Settings), then Subtitle Settings.
Reply
#7
Quote "Bring up the video OSD" is the part you didn't do.

I'm pretty sure I did! Read my last post again!
Reply
#8
(2019-01-13, 16:04)wiab4355 Wrote:  While the file was playing, I went into "Settings",

This might be confusing

With "Settings" we mostly understand the system settings.  But I guess we are talking about the same things.

Are the file you are trying to play all part of your library? As I just noticed that if I try to start a file using the filemanager that default setting won't apply, while it applies for any movie in my library.
Reply
#9
I don't use the "library". I go into Videos, then files, find the file I want to play and that's it. I guess to make subs permanent, I need to use the library! Ah well....
Reply
#10
(2019-01-13, 17:50)wiab4355 Wrote: I'm pretty sure I did! Read my last post again!
Sorry, jet lag impacting my reading comprehension.
Reply
#11
You might check Preferred subtitle language in the main Kodi settings, and if it is "None" or "Forced only" change it to another option. The default is "Original language", but it may have been modified.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
How do I enable subtitles permanently?00