Launching a rom from command line
#1
Not really sure where to ask this, but seeing as you guys probably know your way around the system, I'll try here. Smile

I'm trying to use AEL to play some NES/SNES roms (tried Retroplayer, not as smooth as the .emu apps yet unfortunately), and I have been using this command line before to get it to launch the rom directly:
Code:
/system/bin/am start -n com.explusalpha.Snes9xPlus/com.imagine.BaseActivity --user 0 -a android.intent.action.VIEW -eu Uri "file://%ROM_PATH%"
but, I think at some point it stopped working, and now it only launches to the main menu of the app.

Edit: I'm trying this from a shell, btw, it's not an issue with AEL.

Could this be an issue with Android 8 Oreo? Some security improvement perhaps?
I tried mailing the developer, but no response yet, so I thought you guys might now if something needs adapting - or perhaps if it's not possible anymore to launch an app with arguments?

I am rooted, if that helps.

This is on a Shield TV (2015 model) running Android Oreo 8.1.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Launching a rom from command line00