•   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 16
  •   
Release TheMovieDB - Movie scraper
Can someone please explain what is occurring when I initiate a library scan? Refer to the output of the log below. Is Kodi attempting to retrieve the video information (video length, bitrate, encode format etc)  of a video? This process really drags the length of the video scan and it appears in vein as the folder consists of STRM files which don't inhibit video information. Can this step be skipped if this is what Kodi is trying to do? Maybe an incorporation of a STRM toggle option to bypass this scan.

2020-10-27 13:22:19.848 T:15520   DEBUG: CCurlFile::GetMimeType - movie/Automata%20%282014%29%20%5Btt1971325%5D.strm -> application/octet-stream
2020-10-27 13:22:19.848 T:15520   DEBUG: CFileCache::Open - opening <movie/Automata%20%282014%29%20%5Btt1971325%5D.strm> using cache
2020-10-27 13:22:19.848 T:15520   DEBUG: CurlFile::Open(0x29c3d9ef4a0) movie/Automata%20%282014%29%20%5Btt1971325%5D.strm
2020-10-27 13:22:20.146 T:27748    INFO: CFileCache:Tonguerocess - Source read didn't return any data! Hit eof(?)
Reply
Hi folks!

Just found an interesting detail about tmdb api. It appears that api.tmdb.org and api.themoviedb.org doesn't seems to be the same! I found that in fact, api.tmdb.org has an issue with localization sometimes.

In example, request for movie info (Doctor Strange 2016):

https://api.tmdb.org/3/movie/284052?api_...anguage=ru
https://api.themoviedb.org/3/movie/28405...anguage=ru

The first link show data in English, ignoring language param (in this case). Which is odd, because the search request returns a correct translated data:

https://api.tmdb.org/3/search/movie?api_...&year=2016

So now it looks for me, that api.tmdb.org may have an outdated version of the api, without some fixes, etc. Even more, the api tmdb api documentation refers to api.themoviedb.org, not api.tmdb.org.

So, what do you think? Maybe it would be better to update the api endpoint? Or there is something that makes to stick with previous one?
Reply
@endid

You might find it hard to believe, but I see both those links in Russian.

But the issue you raise has been covered before and you can read more here... https://www.themoviedb.org/talk/5f423cce...0036b64034

Basically you can no longer use 2 character codes. Instead you need to use 4 character codes - ru-RU
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
@Karellen 

Interesting, thanks! I was wrong about endpoint differences, it's more like cache related behavior. Because now I also see both in Russian Smile

Anyway, there is no ru-RU option in the addon settings. I will try to manually edit the addon's xml next time to see either it would be helpful.

Thank you for pointing on it!
Reply
Hi all.

Thank you for the hard work on the add-on!

Just passing by to say that the "it_IT" language is still not working: it's downloading the English summary/tags/posters etc. instead of the Italian variant. I'm using version 5.2.2 of this add-on.
Reply
(2020-10-29, 14:45)OniTheMovie Wrote: Just passing by to say that the "it_IT" language is still not working: it's downloading the English summary/tags/posters etc. instead of the Italian variant.
Can you provide the link to the movie or tv show which is causing the problem
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-29, 18:27)Karellen Wrote:
(2020-10-29, 14:45)OniTheMovie Wrote: Just passing by to say that the "it_IT" language is still not working: it's downloading the English summary/tags/posters etc. instead of the Italian variant.
Can you provide the link to the movie or tv show which is causing the problem

All new scanned movies are affected by this problem.

Here is an example:
Movie (imdb): https://www.imdb.com/title/tt0327084/
Movie (themoviedb): https://www.themoviedb.org/movie/7518-over-the-hedge
API link that works (localized): https://api.tmdb.org/3/movie/7518?api_ke...anguage=it

I can provide more feedback/debug information if you point me to the right direction.
Reply
Hello everybody,

First of, I want to thank a lot all to all people who help and develop Kodi, especially Karellen who is very efficient to find solutions. Smile

Since 2 weeks, I have same problem than several other users: The Movie Database add-on provides only English translations even if the add-on language setting is "fr-FR", whereas, for several years, everything was OK.

Kodi release at 18.9 didn't solved the situation that I got with 18.6 and 18.8 before. The Movie Database xml add-on release is 5.2.2 (and updated it several times at 5.2.2). I added Movie Database Python add-on (release 1.3.0 and language settings at fr-FR); it didn't improved the situation but I didn't succeeded to require this Python scrapper to work "over" XML scrapper.

I changed "C:\Program Files (x86)\Kodi\addons\metadata.themoviedb.org\resources\settings.xml":
from:
<setting label="30002" type="select" values="ar-AE|ar-SA|bg|bn-BD|ca-ES|ch-GU|cs|da|de|el|en|eo-EO|es|es-MX|eu-ES|fa|fa-ir|fi|fr|fr-CA|gl|he|hi-IN|hr|hu|id-ID|it|ja|ka-GE|ko|lt-LT|lv-LV|ml-IN|nb|nl|no|pl|pt|pt-br|ro|ru|sk|sl|sr|sv|ta-IN|th|tr|uk|vi-VN|zh|zh-tw|zh-hk" id="language" default="en"/>
to:
<setting label="30002" type="select" values="ar-AE|ar-SA|bg|bn-BD|ca-ES|ch-GU|cs|da|de|el|en|eo-EO|es|es-MX|eu-ES|fa|fa-ir|fi|fr-FR|fr-CA|gl|he|hi-IN|hr|hu|id-ID|it|ja|ka-GE|ko|lt-LT|lv-LV|ml-IN|nb|nl|no|pl|pt|pt-br|ro|ru|sk|sl|sr|sv|ta-IN|th|tr|uk|vi-VN|zh|zh-tw|zh-hk" id="language" default="en"/>
with no success.

I'm copied my log file at: yemucihuwi.kodi (paste).

All 3 movies that I scrapped are:
@ 2020-10-31 08:19:25.441  https://www.themoviedb.org/movie/382591-...t-commence
@ 2020-10-31 08:19:28.408  https://www.themoviedb.org/movie/110420-...me-to-yuki
@ 2020-10-31 08:19:29.323  https://www.themoviedb.org/movie/185-a-clockwork-orange

I have noted that even for French film "Demain tout commence" that "langage" is required at "en":
2020-10-31 08:19:25.459 T:8920 DEBUG: scraper: CreateSearchUrl returned <url>https://api.tmdb.org/3/search/movie?api_key=f090bb54758cabf231fb605d3e3e0468&amp;query=Demain%20tout%20commence&amp;year=2016&amp;language=en</url>
I don't know if it is a problem. But if it can help someone to find the root cause...

I strongly wish to not borrying anyone with this problem which seems to not be only mine. i just wish it may help the kind coders, helpers and users of marvellous Kodi. I'm not coder at all, but if I can help...
Reply
@KindFraxinus

I think the wrong setting is stuck in your addon and\or database. Please do the following

1. Exit Kodi
2. Go to C:\Users\Boquette\AppData\Roaming\Kodi\userdata\addon_data and delete the metadata.themoviedb.org folder if one is there.
3. Start Kodi and go to your source and change scrapers. Any scraper is fine and save the selection and answer No when asked to update the library
4. Go back and change the scraper again back to TheMovieDB then on that same page select Settings and adjust your settings as required. Make sure you select fr-FR for the language.

Make sure you are changing your settings at the Source, not in Settings>Addons. Changing settings in Settings>Addons does not change existing sources.

Does that fix it?
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-10-31, 12:16)Karellen Wrote: @KindFraxinus

I think the wrong setting is stuck in your addon and\or database. Please do the following

1. Exit Kodi
2. Go to C:\Users\Boquette\AppData\Roaming\Kodi\userdata\addon_data and delete the metadata.themoviedb.org folder if one is there.
3. Start Kodi and go to your source and change scrapers. Any scraper is fine and save the selection and answer No when asked to update the library
4. Go back and change the scraper again back to TheMovieDB then on that same page select Settings and adjust your settings as required. Make sure you select fr-FR for the language.

Make sure you are changing your settings at the Source, not in Settings>Addons. Changing settings in Settings>Addons does not change existing sources.

Does that fix it?
PERFECT! Yes, it fix it. Impressive! Thanks a lot for your help.
Reply
(2020-10-31, 12:16)Karellen Wrote: @KindFraxinus

I think the wrong setting is stuck in your addon and\or database. Please do the following

1. Exit Kodi
2. Go to C:\Users\Boquette\AppData\Roaming\Kodi\userdata\addon_data and delete the metadata.themoviedb.org folder if one is there.
3. Start Kodi and go to your source and change scrapers. Any scraper is fine and save the selection and answer No when asked to update the library
4. Go back and change the scraper again back to TheMovieDB then on that same page select Settings and adjust your settings as required. Make sure you select fr-FR for the language.

Make sure you are changing your settings at the Source, not in Settings>Addons. Changing settings in Settings>Addons does not change existing sources.

Does that fix it?
Quite an odd fix, but it worked!

I hope that other people having the same issue will stumble in your comment.

Thank you.
Reply
hi,

working in my old kodi v17.6 in my pc connected to main TV, at least with new added movies. However, with a fresh installation of kodi (android kodi 18.9, windows 17.6 and 18.9) in another PC and in an android device, movies are detected correctly by the themoviedb scrapper but just a few load fan-art and posters

TV shows scrapping working ok with thetvdb scrapper

EDIT: I use to export fan-art and nfo files to the remote files, it seems that if I delete the .nfo files, the new searches seems to work again. I hope it helps other users


Greetings
Reply
Hi,
is there any way to configure the addon to scrape based on groups (TV Episode groups)? I'm asking because there are TV shows, specially anime, where the default one is a single season. Using groups you can change this to a specific group like DVD, TV, Story arc, etc. Not all TV shows have this and for each group you can have different implementations (for instance, Saint Seiya has Original Air Date and Story Arc groups implemented but inside Story Arc you have Main Arcs with 3 groups and Arcs with 8 as implementations) so not an easy one to implement I guess.
Reply
(2020-11-12, 16:52)Sepharat Wrote: is there any way to configure the addon to scrape based on groups (TV Episode groups)?
Yes, see here... https://kodi.wiki/view/Naming_video_file...ode_Groups
My Signature
Links to : Official:Forum rules (wiki) | Official:Forum rules/Banned add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create Music Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
(2020-11-12, 19:50)Karellen Wrote:
(2020-11-12, 16:52)Sepharat Wrote: is there any way to configure the addon to scrape based on groups (TV Episode groups)?
Yes, see here... https://kodi.wiki/view/Naming_video_file...ode_Groups

Ah cool! I missed that wiki page. Thanks!
Reply
  •   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 16
  •   



Logout Mark Read Team Forum Stats Members Help
TheMovieDB - Movie scraper0
This forum uses Lukasz Tkacz MyBB addons.