v18 Multiple lines of ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
#1
I'm seeing multiple lines that read: ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true in my log but am unsure why.  They seem to be triggered when a video exits.  This debug log is very short, I just loaded kodi, navigated to a video and played it (fast forwarded till about 2 min left and let it end).  It doesn't matter which video file I use/seems to happen with any. 

Even though the file in the debug log is getting played over an NFS share, I get the same error if I play the same file from the local file system.

Is there any clue in the debug log as to cause?
Need help programming a Streamzap remote?
Reply
#2
The error message comes from here:

https://github.com/xbmc/xbmc/blob/0978b1...o.cpp#L259

This can be ignored at the end of a video. An error message which is kind of confusing

Video is playing -> all is fine.... you stop that video -> audio asks for some packets which it doesn't get anymore (the error) but there's still something in the buffer and that need to be flushed.

In short: Ignore it Wink
Reply
#3
(2019-01-26, 09:21)DaVu Wrote: The error message comes from here:

https://github.com/xbmc/xbmc/blob/0978b1...o.cpp#L259

This can be ignored at the end of a video. An error message which is kind of confusing

Video is playing -> all is fine.... you stop that video -> audio asks for some packets which it doesn't get anymore (the error) but there's still something in the buffer and that need to be flushed.

In short: Ignore it Wink
 Thanks very much the link and the explanation.
Need help programming a Streamzap remote?
Reply
#4
I confirmed seeing this on several different boxes now (x86_64 and ARM).  Harmless error to be ignored or not, should it get reported on the github page (assuming it would be a low priority)?
Need help programming a Streamzap remote?
Reply
#5
If you are concerning PR a change to make it debug
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#6
(2019-01-26, 21:27)fritsch Wrote: If you are concerning PR a change to make it debug
 @fritsch - sorry, I don't understand :/  Are you saying you guys (developers) are considering a PR to make this a debug option?  Please let me know if any action on my part is needed, limited as it may be.
Need help programming a Streamzap remote?
Reply
#7
No - we don't consider it. It's good as is.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#8
(2019-01-26, 21:22)graysky Wrote: Harmless error to be ignored or not

As said...harmless and can be ignored at the end of a video or if you stop that video manually. I wouldn't bother about a single line in the log if a video ends Wink
Reply
#9
OK, thanks again, guys.
Need help programming a Streamzap remote?
Reply
#10
(2019-01-26, 09:21)DaVu Wrote: This can be ignored at the end of a video. An error message which is kind of confusing

Video is playing -> all is fine.... you stop that video -> audio asks for some packets which it doesn't get anymore (the error) but there's still something in the buffer and that need to be flushed.
 Can this be triggered by something else?  I ask because I get the error when a video stops that doesn't contain an audio track at all.  Try this video for example.  Debug log playing it and allowing it to just stop on its own.
Need help programming a Streamzap remote?
Reply
#11
Yes, it can. What is your issue with that message? What does not work?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#12
@fritsch - There does not seem to be any functional consequence of the error message.  If it's expected that any video ending should trigger the message/log entry, that's fine with me.  I just wanted to explore it a bit and share the results.
Need help programming a Streamzap remote?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Multiple lines of ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true00
This forum uses Lukasz Tkacz MyBB addons.