Kodi GUI disapppear on my HDMI, service needs restart
#1
My logs:
kodi.log: http://paste.ubuntu.com/p/Zn2hVfX2yh/

My system:
[email protected]:~$ uname -a
Linux kodi 4.15.0-45-generic #48-Ubuntu SMP Tue Jan 29 16:28:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Ubuntu is running on a Intel NUC DN2820FYKH with a Celeron N2830 and Intel HD Graphics connected via HDMI to my Samsung TV.
The NUC is used as a media player and as a server for some services.

Kodi version: 18.0 installed via PPA
[email protected]:~$ apt policy kodi
kodi:
  Installed: 2:18.0+git20190128.1934-final-0bionic


I run kodi as a service:
[email protected]:~$ cat /etc/systemd/system/kodi.service
[Unit]
Description=Kodi standalone
After=systemd-user-sessions.service network-online.target sound.target mysqld.service
Requires=network-online.target
[email protected]

[Service]
User=kodi
Group=kodi
PAMName=login
TTYPath=/dev/tty1
ExecStart = /usr/bin/xinit /usr/bin/dbus-launch --exit-with-session /usr/bin/kodi-standalone -- :0 -nolisten tcp vt1
Restart=always
RestartSec = 5
StandardInput=tty

[Install]
WantedBy=multi-user.target

At boot kodi starts and I can see the GUI and use the media player.
But if I switch off the TV and leave kodi idle for a while, I can't figure out how much, when I switch the TV on again I get a message that there is no signal on the HDMI.
I can ssh to the server and it is running, to see the kodi GUI again I have to restart the kodi.service with systemctl command.
Is there some change I can do to my system to avoid the GUI to disappear?
Reply
#2
10:20:27.032 T:139772532970432 NOTICE: ADDON: repository.universalscrapers v1.0.0 installed

As per forum rules (wiki), please first remove the banned repository and its related add-ons & modules from your Kodi setup before requesting support here.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#3
Please try to follow the instruction on this thread 231955 (thread) and retest your issue.
Reply
#4
Make sure not to use system screensaver but a Kodi provided one like dim.
Reply
#5
I removed the illegal plugin, but the problem is still there.
I read the post in the other thread and my setup is very similar, the only difference are that my kodi user has a different home and a nologin shell and I use xfce and not openbox as a window manager.
I also checked and my screensaver is dim, I don't even know how to check if I'm using the system screensaver, suggestion?
Reply
#6
try this when screen goes blank

Code:
export DISPLAY=:0
xset s off -dpms
Reply
#7
(2019-02-05, 21:59)sauliusz Wrote: try this when screen goes blank

Code:
export DISPLAY=:0
xset s off -dpms

Will do.
Can you please explain what does this mean and why should I try it?
Reply
#8
First line sets which display to use for next command, you can try to skip this, but i was getting error that display is not set.

Second line disables ubuntu from blanking screen.
Seems that with new version of kodi, they now let ubuntu to turn off screen if you are not using kodi.
Default for ubuntu is 10 minutes i think
Reply
#9
I noticed that in the openbox configuration from the linked post the system screensaver is disabled, so I decided to switch to openbox and now I don't have the problem anymore, so I guess the system screensaver could have been the problem.
Thanks.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi GUI disapppear on my HDMI, service needs restart00
This forum uses Lukasz Tkacz MyBB addons.