Broken -  ListItemAbsolute(offset) broken in Leia
#1
I don't use it often and I just noticed it right after the Leia stable release (grml):

What works
  • ListItemAbsolute(1).Label = Is returning the second absolute position of a container

What does not work:
  • ListItemAbsolute(0).Label = Is returning the focused item instead of the absolute position

@Hitcher @jurialmunkey 
Can you please test it on your end and confirm?
Reply
#2
Have you tested ListItemAbsolute.Label?
Reply
#3
Yep. Same issue.

But I've noticed that it only breaks in media windows with viewtypes. Widgets on home etc are okay.

This works:
Container.ListItemAbsolute(0).Label / Container(50).ListItemAbsolute(0).Label (of the visible viewtype) / Container.ListItemAbsolute.Label

It only breaks without the container. prefix.
Reply
#4
Can you start posting skinning engine bugs on GitHub with steps to reproduce in Estuary so we can keep a better track of them. Thanks.
Reply
#5
FYI - Here's the link to the github page to report issues:
https://github.com/xbmc/xbmc/issues
Reply
#6
BTW can confirm.
$INFO[Container.ListItemAbsolute(0).Label] - Returns first absolute position
$INFO[ListItemAbsolute(0).Label] AND $INFO[ListItemAbsolute.Label] - Both incorrectly return current focused item instead.

Reproduce in Estuary in MyVideoNav by adding label control:
Code:
<control type="label">
<label>$INFO[ListItemAbsolute(0).Label]</label>
</control>
Reply
#7
I'm aware of the GitHub issues, I just wanted to be sure it's not just me Smile
Thanks for confirming. I'll open the ticket later this day.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
ListItemAbsolute(offset) broken in Leia00