v18 Video streaming is broken in Leia
#1
I jumped the gun and lived to regret it.

A video streaming add-on (public content) I am working on has trouble installing from own repo in Krypton, so I was more than happy to find that same repo Works flawlessly on Leia.

The joy was short winded though when I slowly realized that the stuttering, resyncing, artefacting and crashing of the video feed was not to blame on the source but on Leia. With the log containing many many, maaaaaany entries like this:
00:25:10.504 T:33796   DEBUG: ffmpeg[8404]: [mpegts] PES packet size mismatch
00:25:10.504 T:33796   DEBUG: CVideoPlayer::CheckContinuity - resync forward :2, prev:43426044.444444, curr:55626044.444444, diff:12160000.000000
00:25:10.504 T:33796   DEBUG: CVideoPlayer::CheckContinuity - resync forward :1, prev:43415633.333333, curr:55639188.888889, diff:12173144.444444
00:25:10.504 T:33796   DEBUG: CVideoPlayer::CheckContinuity - update correction: 12173144.444444
00:25:12.557 T:18264   DEBUG: CPtsTracker: detected pattern of length 1: 40000.00, frameduration: 40000.000000
00:25:18.432 T:18264   ERROR: ffmpeg[4758]: [h264] Invalid NAL unit 8, skipping.
00:25:18.508 T:18264   DEBUG: CPtsTracker: pattern lost on diff 160000.000000, number of losses 2
00:25:18.697 T:21244   DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:10132.956524, adjusted:10132.956524
00:25:19.706 T:21244   DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:18964.560064, adjusted:18964.560064

Full log here: emoletimud.kodi (paste)

After reinstalling Krypton (and the add-ons from zip) same video service resumes flawless work.

If someone wants to try: https://github.com/dam-pav/plugin.rtvslo.../1.0.0.zip The menus are Slovenian only, sorry. You know, as in FLOTUS. ;-) Since the streaming content is almost exclusively Slovenian there is little reason to expect foreign audience. The menu structure is extremely simple though and podcast items are found one level into the structure mostly.

If there is a tweak in Leia that I can use to tame the hiccup, please enlighten me and I shall forever be grateful.
Reply
#2
I suppose I should add that I tried this with HW acceleration on, off, auto... It made no difference. "This is not the tweak you're looking for." (waving hand)
Reply
#3
Please do NOT splatter log files or big parts thereof directly onto the forum.

This text line "Do not post logs in the forum. Use https: //paste.kodi.tv/ instead." above the Post Reply button is there for a reason.

Always provide the FULL debug log (wiki) file via a pastebin website.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#4
(2019-02-06, 13:05)Klojum Wrote: https: //paste.kodi.tv/

Right, so like this? 
emoletimud.kodi (paste)

I'm not sure what would constitute a FULL log, so I just dumped all of it.

Fun starts at around 18:59.
Reply
#5
(2019-02-06, 20:16)daimono Wrote: so I just dumped all of it.
That's the big idea Smile

Some people only provide small portions of a section that they think is sufficient or the most interesting.
But errors can have their origin at any point, plus the hardware, settings, add-ons involved can also be a lead.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#6
Well, I don't think hardware makes a difference either. I confirmed same behaviour on Windows 10 and on two separate rPi3+ boxes (libreelec). Also confirmed that reversing the upgrade fixes the problem on both hw platforms.
Reply
#7
I have seen the same issues going from 17.6 to 18.0.

For the slight jitter that is seen on ticker banners during news broadcasts I changed the video settings to DXVA for both deinterlacing and scaling. I also found spline32 optimized helped. If DXVA doesn’t do it play around with selecting others. I found that just changing these would clear it up but then later reappear. I mention this as not a fix but a direction to look.

Oddly, I see scaling contains a different list depending on the program on. I seen it limited to just DXVA and Auto. But on other programs it had about 6 different choices: DXVA, Spline32, Spline32 optimized, Bicubic, Lansxxx something.

If what you’re seeing is more of a stutter of the video where it pauses and fast forwards I found turning off the updates to the guide helped.
Settings -> PVR & Live TV -> Guide. Set Prevent update during playback to ON. Otherwise the curls to get channel listings will consume the backend bandwidth and result in CRenderManager WaitForBuffer timing out.

Jeff
Reply
#8
(2019-02-10, 17:58)jeffj9930 Wrote: I have seen the same issues going from 17.6 to 18.0.

For the slight jitter that is seen on ticker banners during news broadcasts I changed the video settings to DXVA for both deinterlacing and scaling. I also found spline32 optimized helped. If DXVA doesn’t do it play around with selecting others. I found that just changing these would clear it up but then later reappear. I mention this as not a fix but a direction to look.

Oddly, I see scaling contains a different list depending on the program on. I seen it limited to just DXVA and Auto. But on other programs it had about 6 different choices: DXVA, Spline32, Spline32 optimized, Bicubic, Lansxxx something.

If what you’re seeing is more of a stutter of the video where it pauses and fast forwards I found turning off the updates to the guide helped.
Settings -> PVR & Live TV -> Guide. Set Prevent update during playback to ON. Otherwise the curls to get channel listings will consume the backend bandwidth and result in CRenderManager WaitForBuffer timing out.

Jeff
To be honest I do not use tickers so I wouldn't know about any jitter going on.

Your "stutter" description is closer to my symptoms. Unfortunately, I also confirmed that "Prevent update during playback" is on, as by default. I'd expect all PVR and Live TV functionality to be off anyway, in the absence of proper hw. Is it not so?
Reply
#9
So, v18.2 is out and no improvement still.

Seems bouncing this to bug reporting area is in order.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Video streaming is broken in Leia00