v18 -  Kodi doesn't display external subtitle
#1
Question 
Hi everyone. I've been having this issue since 17.6 and with the recent update to 18, it's still there.

Kodi isn't displaying subtitles with shows that have external subtitle files (same name as video file, in the same directory).

But when I go to the Subtitles menu, the popup indicates an external subtitle file is present (and it's there when I look in the directory). The subtitles show when I play the video on a Mac app.

However, when I use Kodi to download a subtitle, it proceeds to show them when playing the video. (Which is what I've been doing all this time but I figured it's time I try to fix this!)

How can I troubleshoot this? Should I upload a log? Is it a debug log from Kodi that's required?
Reply
#2
Bump
Reply
#3
Here's a debug log: https://paste.ubuntu.com/p/ps76zWhSzW/
Reply
#4
The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#5
Here's a new clean log: https://paste.ubuntu.com/p/MVCKMtHw7V/

Oddly, previously before rebooting Kodi, I tried to play Insecure.S01E04.720p.BluRay.x264-DEMAND-postbot.mkv and there was no subtitles. After the reboot, subtitles show.

But the issue happens again when I play the file Insecure.S01E05.720p.BluRay.x264-DEMAND.mkv.
Reply
#6
Bump
Reply
#7
According to the Emby addon developer here, the issue could be with Kodi.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Kodi doesn't display external subtitle00