Mythv very bad jitter on one machine in home only.
#1
Recently upgraded my living room htpc to Ubuntu 18.04. Live tv is unwatchable. Stutters, audio out of sync, screen looks washed out occasionally.

I'm fairly certain this isn't a mythtv problem or storage issue as my htpc in the bedroom is working just fine. Wife watched tv in there before bed last night for over an hour, not a single problem.

Ubuntu 18.04 LTS 64bit. Kodi 18 Leia from the ppa.

This paste just pulled from the htpc while live tv playing.

https://paste.ee/p/TN3po

*EDIT* I have eliminated non upgaded packages as being a potential problem. Found a few packages, including a few kodi as Xenial still. All upgraded and running now. Still no dice.
Reply
#2
Is the framerate correct? sounds like what would happen if it was set to 30fps instead of 60.
Reply
#3
Where do I set that?
Reply
#4
Yop, very bad thing. What is the video card ? And what is the installed video driver ? Do you use Xorg or wayland ?

For my case I didn't migrated my htpc to 18.04 for many good reasons and it stills with 16.04.
Reply
#5
It's an AMD Kabini 5350 quad core APU. Xorg, no wayland. The funny thing is my LTSP pxe boot machine in the bedroom is the same line of APU, just a Sempron rather than an Athlon and it runs fine on 18.04. I still have my LVM snapshot worst case I guess but I don't want to roll back over something like this, especially if it's working fine on another machine with almost identical hardware.

*EDIT* maybe this is what I get for upgrading instead of a clean install Sad I don't know. Could be something botched there to I guess. Ubuntu isn't known for clean upgrades.

*EDIT 2* Just tried a newly created ~/.kodi folder. Same results. It's not a corrupted settings file either.
Reply
#6
settings>system>display>refreshrate  Also settings>player settings>videos>sync playback to display
Reply
#7
No good. It's the strangest thing. My bedroom which is PXE booted using LTSP based on 18.04 is working flawlessly. I know it's something in this machine that is causing the problem. It is using the Mythtv backend on this machine and working great.

I just tried purging and reinstalling xorg, openbox, lightdm, kodi, kodi-pvr-mythtv, kodi-eventclients-kodi-send. It did have to download some stuff, which theoretically should have been in the apt cache but wasn't. Had high hopes, but it's still no good. I found an error in my dns servers config file, fixed it thinking maybe it was having a hard time with network due to that.

The audio is ahead of the video by a couple seconds at all times. I tried playing with the sound settings on the channels, the different english / spanish options. Still screwed up. The bedroom is fine and it's driving me crazy!

A fresh install is an option but I won't have time till Monday... I suppose the wife can watch her shows in the bedroom. It should be noted that all local media plays back just fine. Movies / Tv shows all play perfectly well.
Reply
#8
Ok I have an update. Although I'm not sure what to do about it. My laptop and the bedroom htpc work just fine off of this mythtv backend. As such it is only the living room. The living room media center is the server, combined with the others being over wire and or wireless and doing fine. That rules out network. Also rules out storage problems, dying drive or something. 

The only difference between both my laptop and bedroom media center verses the living room htpc, is the tv in the living room is 4k. Others are 1080p. My problem isn't the server itself, as much as maybe some kind of upscaling or god knows what is going on that the tv isn't keeping up with. As such, are there any suggested kodi settings, or advancedsettings.xml flags help with this? Stuff that would improve results to a 4k display?
Reply
#9
I think you can change the display resolution to 2k. But if 4k is enabled means you hardware supports it. IMO some libs have been broken during the upgrade. Uninstalling with purge the Xorg and all stuff around video drivers, then reinstalling could help.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Mythv very bad jitter on one machine in home only.00