v18 -  problem to calling addon
#1
I have my own addon which works like next airred but for German TV chanals.
With Kodi 17 everything works fine.
Cause of KODI 18 is final I installed it on my laptop for testing but I can't get it work under Kodi 18.

for the Widget part I call the addon
Code:
plugin://plugin.program.serienplaner/?action=get_item_serienplaner&reload=$INFO[Window(Home).Property(SerienPlaner.Countdown)]

but under KODI 18 I allways get an Error

Code:
12:44:37.318 T:10712 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.program.serienplaner/?action=get_item_serienplaner&reload=

I tries to find if there were some changes in the widget logic but I cold not find...

Any Idea?
Board: B85M-ITX
CPU: i3 4330
GPU: Geforce GTX 750ti
Reply
#2
I‘ ve tried the whole last week but I could not find any solution?

The call of the addon always run into this error.
The pfad is D:/Kodi-Leia/portable/addon/plugin.program.serienplaner/
I‘ve compared with some other plugin but could not find a difference.

So on which point I could start to find the problem?
Board: B85M-ITX
CPU: i3 4330
GPU: Geforce GTX 750ti
Reply
#3
Debug Log
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#4
Hi Karellen,

thanks for your anwer.

here we go with the log...
Board: B85M-ITX
CPU: i3 4330
GPU: Geforce GTX 750ti
Reply
#5
not sure if this helps, but a good starting point is the kodi 18 code. the kodi debug logs are not much of a help when i comes to internal system code

https://codedocs.xyz/AlwinEsch/kodi/clas...5524d9921f

A few questions:
- what skin are you using?
- does it happen with other skins as well?
- can you use a different entry point of your addon for the widget?
Reply
#6
Yes, that happend with every skin I tried Titan and AEON NOX Silvo.

I have crate a Submenu point to start the script as follow:

Code:
RunScript(plugin.program.serienplaner,"?action=get_item_serienplaner&reload=$INFO[Window(Home).Property(SerienPlaner.Countdown)]")

and it works so far cause I got the right output from the addon debug

find log here
Board: B85M-ITX
CPU: i3 4330
GPU: Geforce GTX 750ti
Reply
#7
Please use pastebin or something similar rather than plastering the board with large blocks of text.
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#8
(Yesterday, 19:31)DarrenHill Wrote: Please use pastebin or something similar rather than plastering the board with large blocks of text.
 done... edit my post...
Board: B85M-ITX
CPU: i3 4330
GPU: Geforce GTX 750ti
Reply
#9
oh, I been browsing to search for this issue.
Code that worked in 17.x now stopped to work in some plugins that are launch with

xbmc.executebuiltin('RunScript(script.module.nakamori,?info=calendar)', True)
If you lunch it from other plugin it don't work (some does), if you lunch same code from inside script you referring to it's always work !
Looks like issue with Kodi18 Huh

There is also this: 340954 (thread) which is a bit related to, but this didn't help with my issue;
Reply
#10
I really don't know...

it seems to be a problem to solve the addon-path but ist the same as such other plugins.
I've tested some other addon that use the same kind of calling the addon and it works...

So I've no further ideas...
Board: B85M-ITX
CPU: i3 4330
GPU: Geforce GTX 750ti
Reply
#11
I tested it more and it looks like I'm unable to execute any script outside of my initial script (cross script launching).
While same code works on kodi 17.6.
Reply
#12
RunScript is no problem, that works. But i tried to call as a widget to get back the listitems...
I could not understand the problem with the path of the addon...
Board: B85M-ITX
CPU: i3 4330
GPU: Geforce GTX 750ti
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
problem to calling addon00