[Guide] Getting Started with Kodi Retroplayer
Not sure the problem, but it appeared to be with the Millhouse build.

Installed a fresh copy of the latest LibreElec & everything worked flawlessly.
In Krypton, I was able to run some games from external emulator by editing a "videoextensions" in "advancedsettings.xml", and by adding an "ExternalPlayer" in "playercorefactory.xml".
In Leia, it works. But since there is a "Game" menu entry for games library/add-ons/RetroPlayer features, is there a way to say to Kodi to use an ExternalPlayer of my choice from this menu entry replacing the add-on/retroplayer default player?
Without installing any game addon?
For example with a gameextensions section and a game="true" attribute, simply like for audio and video?
Something like :

<advancedsettings version="1">


<?xml version="1.0" encoding="UTF-8"?>
        <player name="Mupen64plus" type="ExternalPlayer" game="true">

    <rules name="my_rules" action="prepend">
        <rule game="true" filetypes="n64|z64|avi|mp4" player="Mupen64plus"></rule>
Here are the up to date steps that (almost) worked for me with Ubuntu 18.4 and Kodi 18.4:

1. Install emulators from stable ppa:

sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get install kodi-game*

2. Go to "Settings -> Add-ons -> My Add-ons -> Game Add-ons -> Emulators" and enable the emulator you want to play use.

3. In the main Kodi menu, go to "Games -> Add Games..." and add a path to your gaming library

4. In the main Kodi menu, go to "Games -> Your Path to Game" and start it.

5. If it fails with error that says that something is missing, you need to install this something manually from a zip. For SNES, I was missing 4 addons related to controllers, these can be downloaded from here:

    - https://mirrors.kodi.tv/addons/leia/game...r.player2/
    - https://mirrors.kodi.tv/addons/leia/game...fier.snes/
    - https://mirrors.kodi.tv/addons/leia/game....multitap/
    - https://mirrors.kodi.tv/addons/leia/game...per.scope/

6. The game is running now but the screen is black. It should display a hardcoded graphic that explains how to start the emulator, but there is a bug on my system. To see it, press "\" to go into Kodi windowed mode. Press Enter to start the emulator.

7. At this point I was stuck as I do not know how to control the games with a keyboard. Will update post when I find solution.
Can't edit the post, so I continue from step 7.

7. I have XBOX controller connected via USB to the machine. I tested that it is being recognized and working using jstest-gtk utility (requires installing with apt)

8. Got to Settings -> System -> Input -> Configure Attached Controllers. Choose "Super Nintendo" controller and configure the buttons according to the image. Don't map X on the XBOX to the "X button" as they are at different locations on the controller. Use the image for reference. I also advice to map left thumb-stick to the up/down/left/right keys, it is more pleasant to play this way.

9. That's it, the controller is working now and it is possible to even control the Kodi UI with it.
Missing a - in the apt-get line for kodi-game
I just noticed when i copy pasted it.
(2019-10-31, 05:39)t0aster Wrote: Missing a - in the apt-get line for kodi-game
I just noticed when i copy pasted it.

Fixed. Thanks for reporting. @zachmorris hope I didn't screw anything up (our forum can be picky about WYSIWYG editing)
@alkhimey Wait, does that mean that it is possible to run mupen64 via Kodi on an raspberry pi 4 as well?
Is there a way to add sample files yet? for mame/arcade games? Where should they be placed?
(2019-12-23, 03:52)ewookie Wrote: Is there a way to add sample files yet? for mame/arcade games? Where should they be placed?

I haven't tried this, but it should work the same as bios files/hash files and the like. I would put the same folders you put in your Retroarch system folder in the Addon folder:
In Retroarch the path would be:


In Kodi it would be (I think):

..path to kodi userdata folder/game.libretro.mame2003_plus/resources/system/mame2003-plus/samples/
..path to kodi userdata folder/game.libretro.mame2003_plus/resources/system/mame2003-plus/hi/ (for high scores)
Hi, is the Kodi Retroplayer still available for downloading? I have download MAME ROMs and I want to play them with the Retroplayer if it's still possible.

I get no sound in any games/emulators.

I have audio through spdif setup in kodi.

is there a setting somewhere i can get it to put sound through spdif? (my tv is connected through hdmi, so i guess its defaulting to this output?)

many thanks for any help!

Best Regards

i follow this guide and i was trying to launch .bin files, especially with pcsx rearmed (psx games) and genesis emulator (genesis games), i still cant launch roms because kodi only propose to me : vectrex, atari, gba, vitrual boy.

- i created an advancedsettings.xml like mentionned in the first post
- psx bios file are in the right folder

How can i add more emulator choices when i launch a specific file ?
The emulator choices are determined by the file extension. Try changing the extension or using a game file with a different extension.

If you can identify an emulator that should support a file and doesn't, let us know and we'll file a bug report.
looks like your video got age restricted.
A bunch of my kodi tutorial videos also had the same.
Even after "fighting it", Youtube just says nope.

Logout Mark Read Team Forum Stats Members Help
[Guide] Getting Started with Kodi Retroplayer1
This forum uses Lukasz Tkacz MyBB addons.