Can't record NCS: Los Angeles or NCIS: New Orleans
#1
I can't record "NCIS: Los Angeles" or "NCIS: New Orleans" if it is a scheduled recording (screening for bad taste?).  However, I can manually record them.  Scheduled recordings of "NCIS" record fine.  
I'm running Tvheadend 4.3 and Kodi on a Nvidia Shield TV and am recording to an attached FAT32 hard drive.  
I get a recording started message immediately followed by a recording completed message.  The Tvheadend web interface shows "file not created" status in the "Removed Recordings" tab. 
I posted a message on the Tvheadend.org board but the server appears to be down.  
I suspect that because of the ":" in the title Tvheadend is unable to create a sub-folder with that name. When I manually record the file is put in the top level folder without creating a sub-folder.  
I have tried enabling both "Remove all unsafe characters from filename" and "Use Windows-compatible filenames" but these options only seem to effect the filename, not the sub-folder name.  
What I don't understand is why Tvheadend is creating sub-folders since I don't have "Make subdirectories per title" enabled.  

Any suggestions?
Reply
#2
In your default recording profile make sure that "Recording system path:" is set to a specific directory, also make sure that the pathname "Format string:" is set (for example, try $t%F%R$n.$x in that field).  And under "Subdirectory options" make sure that none of the boxes are checked.  See if any of those help fix the problem.
Reply
#3
My recording path is /storage/4867-D829/NVIDIA_SHIELD/Recordings.  
No boxes are checked in subdirectory options.  
I'll try replacing $t%F$-e$n.$x with $t%F%R$n.$x in the pathname/filename field.  

Thanks
Reply
#4
If that doesn't work then the only other thing I can suggest is that you go to your Autorecs tab and for those shows, in both the Name and Title (regexp) fields, insert a backslash character (\) just prior to the colon.  I have never had to do that, but maybe on some systems the colon is considered a special character, and in that case the backslash should cause it to be considered as part of the filename.  Other than that I can't think of anything else to try, but maybe someone else can.
Reply
#5
My understanding is ":" is a forbidden character in Windows (FAT32) directories and filenames so I need to make sure Tvheadend is not trying to crate a subdirectory with that in the name.  

Thanks
Reply
#6
I've also noticed something else strange.  "." is an allowable character in Windows filenames but a filename can not end with a ".".  So Tvheadend can create a subdirectory called "Magnum P.I." but a filename "Magnum P.I." is not allowed.  However, the file does get created.  Kodi can see it and play it.  However I can not see the file in Windows - the subdirectory looks empty.  

Does anyone else schedule recordings for "NCIS: New Orleans", "NCIS: Los Angeles", or "Magnum P.I."?  If so, can you post the filename and subdirectory name?  

Thanks
Reply
#7
(2019-02-22, 19:29)xbmclinuxuser Wrote: If that doesn't work then the only other thing I can suggest is that you go to your Autorecs tab and for those shows, in both the Name and Title (regexp) fields, insert a backslash character (\) just prior to the colon.  I have never had to do that, but maybe on some systems the colon is considered a special character, and in that case the backslash should cause it to be considered as part of the filename.  Other than that I can't think of anything else to try, but maybe someone else can.
The backslash didn't work but I did find a workaround.  There is an option in the show settings (under the Autorecs tab) to specify the directory.  I removed the ":" from "NCIS: Los Angeles".  Tvheadend then created the directory "NCIS Los Angeles" and successfully recorded the show in the directory.  I'll just have to remember this when setting timers for shows with prohibited characters in the name.  

Either the "Use Windows-compatible filenames" option doesn't apply when it creates sub-directories, there is an option somewhere that I haven't found that forces windows compatible directory names, or something is screwy with my machine.  

Thanks for the suggestions
Reply
#8
Following up
I submitted a bug report for this.  Tvheadend is planning to address this in version 4.4.  
The zap2epg author created a temporary version of the addon to use until the fix is incorporated into Tvheadend 4.4:
https://www.dropbox.com/s/z689mmjn28lg0u...e.zip?dl=0
Reply



Logout Mark Read Team Forum Stats Members Help
Can't record NCS: Los Angeles or NCIS: New Orleans0
This forum uses Lukasz Tkacz MyBB addons.