Recorded shows won't play without Kodi restart
#1
Hi, I've been using SWMC for years now and love it so first off want to say thank you!!  I recently upgraded from kodi 17.6 to 18.0 and started having an issue where Kodi works fine for watching recorded shows and then after watching one I will go and select another to play, and it will spin for a few seconds and then just do nothing.  I can still use Kodi at this point but no matter what recorded show I select nothing will play.  After closing and reopening Kodi it works again for a while then will have the same issue later on that day.  I'm running SWMC on a windows 7 PC and streaming to a separate windows 10 PC running Kodi - both are on the same network and hardwired.  An example can be seen at 22:19:04 trying to open a recorded episode of The Goldbergs.

Kodi Log - kowazuxobe.kodi (paste)
SWMC Log - aweqofetel (paste)

Thank you in advance for your help and please let me know if you need any other information!
Reply
#2
The swmc log says the file could not be opened, its like the samba path to the file is no longer valid, but the same path worked previously, so weird - not sure what is going on.  I can't reproduce it.  If you figure out some steps to make it happen every time let me know.
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#3
There has been some weirdness lately with Windows shares. Not sure if it is Kodi 18, Windows updates, or atomic particles...

I've had the best luck going into kodi and adding the Recorded TV folder as a source under settings -> file manager. Once the username and password is set properly there, I've been able to access reliably.

Your mileage may vary :-)
Reply
#4
@sbthomas are you saying that you add it is a video source and then play the wtv files through this added source, OR that once you add it you can play the wtv files through pvr.wmc as normal?
Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/serverwmc
Reply
#5
No, I play them back through the normal PVR interface but Kodi uses the credentials set when the path is added to file manager. I think file manager is different than adding a source through video -> files.
Reply
#6
I had this happen to me also.

After i upgraded to 18.4 on my win7 HTPC's was running 17.6. & ServerWMC
At first everything was working normal, then after a  few weeks i started to get an error one day, trying to play any recordings,
it claimed duplicate credentials or something like that.

After searching here i found others had this happen and if they removed the user:password entry's in the kodi password.xml file for the recorded TV folders it went away.
I did that and it started working again.

now a few weeks later i start to have this problem of any new recordings are listed but will not play without restart of kodi.

So i have to track down that real problem. Of course that is not easy as you make a change one at a time to see if it helped but you don't know if that reloaded the list (Like restarting kodi) or fixed it.

anyways first i tried to add the entry's back into password.xml for recorded TV folder. that Did not help still would not play but i had not restarted kodi so maybe they were not being used. I restarted kodi and new recording worked but that had always fixed it. seen notice that a recording started and after watching a show that new recording would not play.
Went to Recorded TV folder and noticed that the shares security info listed a unknown account in the list, so i deleted the unknown account and added the user i had setup in serverWMC to use to access the folders. I am sure i had added the user before, must have been the one that turned to unknown account.

Still would not play the new recording, but of course i had not restarted everything as most like would be required but would also make it work until the next new recording. So without restarting.
I went into ServerWMC and unchecked the Use Credentials box and then it started working, i could play that new recording without having to restart kodi.
Will have to wait and see what the future holds as that unchecked box could of caused ServerWMC to re read the list of recordings and send to the clients.
So either i am back to using the user:password entry's in the password.xml file or serverWMC just refreshed the recording list and i will see the issue again next time.

I will try and update if it make any sense in a few days.
Reply
#7
Update
I have not solved this yet.

Tried many more things still not working. Everything looks correct but it just no longer works for any new recordings since kodi loaded the list from ServerWMC.

If you check or uncheck the ServerWMC, folder tab the Use Credentials box, the kodi 18.4 clients still can't play the new recording not sure why it did that one time above.

It seems that to really test this you would need to reboot both PCs (Server and Client) after each change and test after a new recording was made. PIA

I find the recording are made and are listed in the Recorded TV list at the kodi clients Just fine. But the new recording will not play all older recording play just fine.
The currently recording show will play just fine (Recording Now group in the list), You are not asked if you want to start at the beginning when you play a currently recording show in just starts at the beginning, so that is something different.

Even the show you just watched while it was in the Recording Now list after it gets moved to the recorded TV list still will not play.
I checked the logs on the kodi client and ServerWMC and  there is an error about opening the file stream "reports error opening stream" but it don't give any info as to why.

If you got to system>>addons>>prv clients and disable and then enable the WMC.PVR  addon that will also reload the list of recorded TV and the new recording will now play.

anyways i am going on vacation for 3 weeks, so will fix this when i get back.

This just started with Kodi 18.4, I was running 17.6 just fine for over a year and playing with 18.2 and did not see this problem. I have only be using 18.4 less then a month now and have had some weird windows SMB file issues.
Reply
#8
This sounds exactly like what I have been seeing. Do you use a separate remux target? I do but don't remux finished recordings so wonder if there is a stale uri for the media file?

(2019-09-19, 22:16)Rainey222 Wrote: Update
I have not solved this yet.

Tried many more things still not working. Everything looks correct but it just no longer works for any new recordings since kodi loaded the list from ServerWMC.

If you check or uncheck the ServerWMC, folder tab the Use Credentials box, the kodi 18.4 clients still can't play the new recording not sure why it did that one time above.

It seems that to really test this you would need to reboot both PCs (Server and Client) after each change and test after a new recording was made. PIA

I find the recording are made and are listed in the Recorded TV list at the kodi clients Just fine. But the new recording will not play all older recording play just fine.
The currently recording show will play just fine (Recording Now group in the list), You are not asked if you want to start at the beginning when you play a currently recording show in just starts at the beginning, so that is something different.

Even the show you just watched while it was in the Recording Now list after it gets moved to the recorded TV list still will not play.
I checked the logs on the kodi client and ServerWMC and  there is an error about opening the file stream "reports error opening stream" but it don't give any info as to why.

If you got to system>>addons>>prv clients and disable and then enable the WMC.PVR  addon that will also reload the list of recorded TV and the new recording will now play.

anyways i am going on vacation for 3 weeks, so will fix this when i get back.

This just started with Kodi 18.4, I was running 17.6 just fine for over a year and playing with 18.2 and did not see this problem. I have only be using 18.4 less then a month now and have had some weird windows SMB file issues.
Reply
#9
Just wanted to add #metoo  having the same issue.   Anyone know if there's a python command to refresh the addon instead of restarting?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Recorded shows won't play without Kodi restart00