Solved -  Language strings stop working correctly
#1
Hey,

After upgrading to kodi18.1 some string translation stopped working.
all my translation are in `/resources/language/resource.language.en_gb`

Most of translation work fine but some strings with id like:
30080, 30139, 30110 are overwriten with id: 30082

It looks like 30082 is FIRST ACTION LABEL, and all affected are ACTION LABELS too


<setting label="30082" type="action" id="action" action="RunPlugin(plugin://plugin.video.nakamori/?cmd=wizard)" option="close"/>
<setting label="30080" type="action" id="action" action="RunPlugin(plugin://plugin.video.nakamori/?mode=32)" option="close"/>
<setting label="30139" type="action" id="action" action="RunPlugin(plugin://plugin.video.nakamori/?mode=33)" option="close"/>
<setting label="30110" type="action" id="action" action="RunPlugin(plugin://plugin.video.nakamori/?mode=31)" enable="System.HasAddon(script.module.nakamori)" option="close"/>

I filled issue: 15578 (GH issue)

edit: looks like it works in k17 but k18 is more restrictive about id's - or it was label based and now its id (cached?) based
changing id's from 'action' to 'action-number' solved the issue. thanks
Reply
#2
each setting needs to have a unique id.

only under specific circumstances, you will want re-use a setting id. and that's indeed broken currently.
15252 (GH issue)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#3
Thanks, replacing id so each label have unique id solved problem on k18.
Looks like this is one of many things that is 'fixed' while working fine in k17.
Thanks for helping out.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Language strings stop working correctly00