Sega Genesis and CD not working...
#1
I try to load both Sega Genesis and Sega CD roms and neither work. In the case of the Genesis roms, when I click to load it briefly pops up the "playing" popup in the upper right hand corner then it just goes away as if nothing was pressed, almost as if the file doesn't exist. It doesn't ever leave the Kodi environment. It does not popup the emulator choice screen or anything.

As an interesting side note, it does not seem to have a addon folder for the pico or gen emulators in .kodi/.../addon_data/ but it does have folders for the NES and SNES.

I have the BIOS files needed and they are named correctly (case also).
Reply
#2
I had the exact same issue with Atari and PSX. I fixed it by trying different file extensions that the core supports.

So for example with PSX. It lists bin, cue, img, mdf, pbp, toc, cbn, and m3u. I tried them one by one until I hit mdf which worked. Then renamed all my img psx games to mdf.
Reply
#3
I can get Sega CD to work with game.libretro.picodrive using bin/cue files. SegaCD requires BIOS files in:

..path_to_userdata/addon_data/game.libretro.picodrive/resources/system/

bios_CD_E.bin
bios_CD_U.bin
bios_CD_J.bin

See the getting started post on adding bin/cue to the ignore list for video/image files. You need to disassociate those filetypes from valid video or image filetypes.

Genesis should work with genplus or picodrive, and doesn't require any bios files. I use md files.

Image
Reply
#4
(2019-03-13, 23:27)zachmorris Wrote: I can get Sega CD to work with game.libretro.picodrive using bin/cue files. SegaCD requires BIOS files in:

..path_to_userdata/addon_data/game.libretro.picodrive/resources/system/

bios_CD_E.bin
bios_CD_U.bin
bios_CD_J.bin

See the getting started post on adding bin/cue to the ignore list for video/image files. You need to disassociate those filetypes from valid video or image filetypes.

Image

Both of these fixed my issue. I reinstalled Pico then had to manually create the/ resources/system/ folder to upload my bios files to. I then disassociated with the advancedsettings.xml file and all is well.

.bins worked perfect.

Thanks so much for the thoughtful response.!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Sega Genesis and CD not working...00