Subtitles downloading in temp folder
#1
After the upgrade to version 18.0 subtitles are no longer being downloaded in the same folder as video file (although settings say that they should) but are being downloaded in the temp folder under some "code" name (for example 89045.srt).

I have seen that this is happening on android but i'm using kodi on windows 10 1803 on which Kodi 17 worked flawlessly.

Any suggestions?

Thank you in advanced.
Reply
#2
using Libreelec same thing , all subs are downloaded and saved in temp folder but not moved next to the folder
Reply
#3
Settings, add-ons, my addons, virtual file system, active support rar files.
MediaBrazil forum Website - Youtube Channel
Windows 10 - Kodi 18 Leia 64 bits - Aeon MQ8-2.8.0 & Ace2-0.4.0 Team
MarcosQui Website - visit for Donate and support us.
Reply
#4
Subtitles being stored in the temp folder would only happen if there is no user write access to the video file folder.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#5
(2019-03-13, 16:29)Klojum Wrote: Subtitles being stored in the temp folder would only happen if there is no user write access to the video file folder.
 That would indeed be the case but the user is local admin and has access to the folder - same user on the same PC was downloading subs normally on kodi 16, 17....
Reply
#6
(2019-03-13, 13:13)Wanilton Wrote: Settings, add-ons, my addons, virtual file system, active support rar files.
 Unfortunately I don't have that add on and I never needed it before
Reply
#7
(2019-03-14, 23:14)bothari Wrote:
(2019-03-13, 16:29)Klojum Wrote: Subtitles being stored in the temp folder would only happen if there is no user write access to the video file folder.
 That would indeed be the case but the user is local admin and has access to the folder - same user on the same PC was downloading subs normally on kodi 16, 17.... 
I forgot to mention that if i define the same folder as central subtitle download location then subs are downloaded in that folder - I think that this proves that it is not an access issue.
Reply
#8
There is no logical reason for Kodi to store subtitles in a different location from the default video file location.
Other than that, there is still debug enabled kodi log file available, so we'll probably end up making assumptions till eternity on what is actually happening.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#9
Hi

here is the debug log portion regarding subtitle download

22:08:06.469 T:3620   DEBUG: New Service [service.subtitles.opensubtitles]
22:08:06.470 T:3620   DEBUG: ------ Window Init (DialogSeekBar.xml) ------
22:08:06.470 T:868   DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin OpenSubtitles.org('plugin://service.subtitles.opensubtitles/','1','?action=search&languages=Croatian%2cEnglish&preferredlanguage=English','resume:false')
22:08:06.472 T:2964   DEBUG: Thread LanguageInvoker start, auto delete: false
22:08:06.472 T:2964    INFO: initializing python engine.
22:08:06.472 T:2964   DEBUG: CPythonInvoker(11, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): start processing
22:08:06.480 T:7540   DEBUG: CDVDAudio:Tongueause - pausing audio stream
22:08:06.934 T:2964   DEBUG: -->Python Interpreter Initialized<--
22:08:06.934 T:2964   DEBUG: CPythonInvoker(11, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): the source file to load is "C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py"
22:08:06.934 T:2964   DEBUG: CPythonInvoker(11, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): setting the Python path to C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles;C:\Program Files (x86)\Kodi\system\python\DLLs;C:\Program Files (x86)\Kodi\system\python\Lib;C:\Program Files (x86)\Kodi\python27.zip;C:\Program Files (x86)\Kodi\system\python\lib\plat-win;C:\Program Files (x86)\Kodi\system\python\lib\lib-tk;C:\Program Files (x86)\Kodi;C:\Program Files (x86)\Kodi\system\python;C:\Program Files (x86)\Kodi\system\python\lib\site-packages
22:08:06.934 T:2964   DEBUG: CPythonInvoker(11, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): entering source directory C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles
22:08:06.935 T:2964   DEBUG: CPythonInvoker(11, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): instantiating addon using automatically obtained id of "service.subtitles.opensubtitles" dependent on version 2.1.0 of the xbmc.python api
22:08:07.077 T:800 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
22:08:08.672 T:2964 WARNING: Previous line repeats 3 times.
22:08:08.672 T:2964   DEBUG: ### [__main__] - action 'search' called
22:08:08.678 T:2964   DEBUG: ### [__main__] - VideoPlayer.OriginalTitle not found
22:08:08.685 T:2964   DEBUG: CAddonSettings[service.subtitles.opensubtitles]: loading setting definitions
22:08:08.685 T:2964   DEBUG: CAddonSettings[service.subtitles.opensubtitles]: trying to load setting definitions from old format...
22:08:08.686 T:2964   DEBUG: CAddonSettings[service.subtitles.opensubtitles]: loading setting values
22:08:09.140 T:2964   DEBUG: ### [OSUtilities] - Search String [ Brooklyn+Nine-Nine+S06E10 ]
22:08:09.140 T:2964   DEBUG: ### [OSUtilities] - Hash Standard file
22:08:09.160 T:800 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
22:08:09.186 T:2964   DEBUG: ### [OSUtilities] - OpenSubtitles module hash [5e92bf70624bff13] and size [158911607]
22:08:09.283 T:2964    INFO: CPythonInvoker(11, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): script successfully run
22:08:09.283 T:2964   DEBUG: CPythonInvoker::onExecutionDone(11, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py)
22:08:09.384 T:2964    INFO: Python interpreter stopped
22:08:09.384 T:2964   DEBUG: Thread LanguageInvoker 2964 terminating
22:08:09.662 T:800 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
22:08:12.033 T:3620 WARNING: Previous line repeats 4 times.
22:08:12.033 T:3620   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x000d, modifier: 0x0
22:08:12.158 T:3620   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x0000, modifier: 0x0
22:08:12.158 T:3620   DEBUG: CInputManager::HandleKey: return (0xf00d) pressed, action is Select
22:08:12.160 T:868   DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin OpenSubtitles.org('plugin://service.subtitles.opensubtitles/','2','?action=download&link=http://dl.opensubtitles.org/en/download/src-api/vrf-f5780bc2/sid-QUrnhbOKhiHU0ujJaYb0t4QHyAd/sub/7687175&ID=1956262002&filename=Brooklyn.Nine-Nine.S06E10.HDTV.x264-SVA.srt&format=srt','resume:false')
22:08:12.161 T:1684   DEBUG: Thread LanguageInvoker start, auto delete: false
22:08:12.161 T:1684    INFO: initializing python engine.
22:08:12.161 T:1684   DEBUG: CPythonInvoker(12, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): start processing
22:08:12.327 T:800 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
22:08:12.573 T:1684   DEBUG: -->Python Interpreter Initialized<--
22:08:12.573 T:1684   DEBUG: CPythonInvoker(12, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): the source file to load is "C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py"
22:08:12.573 T:1684   DEBUG: CPythonInvoker(12, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): setting the Python path to C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles;C:\Program Files (x86)\Kodi\system\python\DLLs;C:\Program Files (x86)\Kodi\system\python\Lib;C:\Program Files (x86)\Kodi\python27.zip;C:\Program Files (x86)\Kodi\system\python\lib\plat-win;C:\Program Files (x86)\Kodi\system\python\lib\lib-tk;C:\Program Files (x86)\Kodi;C:\Program Files (x86)\Kodi\system\python;C:\Program Files (x86)\Kodi\system\python\lib\site-packages
22:08:12.573 T:1684   DEBUG: CPythonInvoker(12, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): entering source directory C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles
22:08:12.574 T:1684   DEBUG: CPythonInvoker(12, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): instantiating addon using automatically obtained id of "service.subtitles.opensubtitles" dependent on version 2.1.0 of the xbmc.python api
22:08:12.878 T:800 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
22:08:13.365 T:1684   DEBUG: CAddonSettings[service.subtitles.opensubtitles]: loading setting definitions
22:08:13.365 T:1684   DEBUG: CAddonSettings[service.subtitles.opensubtitles]: trying to load setting definitions from old format...
22:08:13.367 T:1684   DEBUG: CAddonSettings[service.subtitles.opensubtitles]: loading setting values
22:08:13.385 T:800 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
22:08:13.649 T:1684   DEBUG: ### [OSUtilities] - Download Using XMLRPC
22:08:13.650 T:1684    INFO: CPythonInvoker(12, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py): script successfully run
22:08:13.650 T:1684   DEBUG: CPythonInvoker::onExecutionDone(12, C:\Users\Bruno\AppData\Roaming\Kodi\addons\service.subtitles.opensubtitles\service.py)
22:08:13.773 T:1684    INFO: Python interpreter stopped
22:08:13.773 T:1684   DEBUG: Thread LanguageInvoker 1684 terminating
22:08:13.910 T:800 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
22:08:13.978 T:868   DEBUG: CGUIDialogSubtitles::OnDownloadComplete - Saved subtitle C:\Users\Bruno\AppData\Roaming\Kodi\userdata\addon_data\service.subtitles.opensubtitles\temp\9fd5b22e-3320-40c2-8534-1dbbe5638d97.srt to special://temp/9159.en.srt
22:08:13.981 T:5884   DEBUG: CUtil::GetExternalStreamDetailsFromFilename - Language = 'eng' / Name = '9159 (External)' / Flag = '0' from special://temp/9159.en.srt


I can see no errors in this log only that it is saved to temp folder although settings say to download it next to file..
Reply
#10
Ehm... Which portion of the bold red text "Do not post logs in the forum. Use https: //paste.kodi.tv/ instead." is unclear? We prefer to keep our forum server clean.

Also don't submit only the portion that you think is interesting. Errors can start at any moment, so we always want the full log file.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
#11
(2019-03-15, 23:46)Klojum Wrote: Ehm... Which portion of the bold red text "Do not post logs in the forum. Use https: //paste.kodi.tv/ instead." is unclear? We prefer to keep our forum server clean.

Also don't submit only the portion that you think is interesting. Errors can start at any moment, so we always want the full log file.
 Sorry my bad. I pasted the whole log to https://paste.kodi.tv/hebusomata.kodi 
Reply
#12
@bothari - your "bad" is not reading the forum rules (wiki) that you accepted when you signed up here, and providing a log full of banned addon (wiki) crap meaning that your device is not eligible for support here.

The forum moderators have determined that banned addons (wiki) are present on your system. To receive assistance here, these banned items must be removed. If a clean log is not submitted within 3 days, then the relevant post(s) will be removed after this time.
| Banned add-ons (wiki) | Forum rules (wiki) | VPN policy (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
#13
Its me again - I have cleaned up my Kodi and pasted the new log here  imadoxutig.kodi (paste)

What I also found out:

1) Clean installation of Kodi on the same computer doesn't download subs either
2) UWP version of KODI downloads the subs, even with the database and settings migrated from old installation
3) Running Kodi.exe (classic app, not UWP) as system account still doesn't download the subs.

Any hint would be appreciated, thank you.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Subtitles downloading in temp folder00