•   
  • 1
  • 278
  • 279
  • 280(current)
  • 281
  • 282
  • 294
  •   
Release Amber for Leia/Matrix/Nexus
(2022-01-19, 14:56)robertlaing Wrote: When in a movie info page, if I go to choose to click on the director or writer where more than one person exists in that category, nothing happens.

@robertlaing , that is by design if you do not have the use of Embuary Helper enabled, as I use script.embuary.helper to provide the dialog to choose which person to search for (director, writer), or which genre or country to search for if there is more than one.

Estuary uses script.embuary.info to provide the information and to provide a dialog that allows you to choose the person.

So, in summary, enable the use of embuary helper in the general section of the Amber settings, and you will also get a dialog allowing you to choose the director/writer/genre/country when there is more than one.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
@robertlaing , I think I have now added/changed the items you have mentioned with regards to music.  The changes are already on GitHub (Matrix).

So, now, when a song is playing, there are new player controls in the sideblade (the left overlay as you called it).  The rightmost of those controls will take you back to the player.  It looks like this:

Image


Also, in the music OSD, there is a new Playlist button, which will take you to the current playlist.  It looks like this:

Image

As you can see from the screenshot, I have fixed the width of the bitrate label.

Third, in the playlist window, I have also added player controls, and, as in the sideblade, the rightmost of those controls will take you back to the player.  It looks like this:

Image

As you can see from the screenshot, I have added the media flags as you requested.

Finally, I have added the bitrate to the audio flags that are shown in Icons and Fanart views.  It looks like this (with Icons view):

Image


I think this covers all of the changes that you had requested.  Please test and let me know what you think and any additional issues that you find.  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
(2022-01-19, 16:01)bsoriano Wrote:
(2022-01-19, 14:56)robertlaing Wrote: When in a movie info page, if I go to choose to click on the director or writer where more than one person exists in that category, nothing happens.

@robertlaing , that is by design if you do not have the use of Embuary Helper enabled, as I use script.embuary.helper to provide the dialog to choose which person to search for (director, writer), or which genre or country to search for if there is more than one.

Estuary uses script.embuary.info to provide the information and to provide a dialog that allows you to choose the person.

So, in summary, enable the use of embuary helper in the general section of the Amber settings, and you will also get a dialog allowing you to choose the director/writer/genre/country when there is more than one.

Regards,

Bart
Hi Bart,

Thanks for you hard work.

Have just upgraded, and am in the middle of testing, and have found that the search has reverted back to bombing out, and does not return to the search results from the movie info, which you had fixed previously.

This is for all searches/categories.

Otherwise, so far I have installed the TMDB helper and Embuary helper, and have the two choices come up as you said they would.

Will keep testing and let you know if I find anything else.

looking forward to seeing the changes in the music!

Thanks so much.

Kind regards,
Robert.
Reply
Hi Bart,

Just to add:

Have just turned off TMDB helper, and I have tested the searches again.

Now when I use the search, I return to the search results from the movie info.

It looks like enabling TMDb helper is the cause of not allowing the return to the search results.

Hope this helps.

Kind regards,
Robert.
Reply
Hi Bart,

I have continued switching the two helpers off and on, and after a lot of testing, this is what I have found:

I keep getting random results!

See what you think!

Kind regards,
Robert.
Reply
Hi Bart,

I have had a look at the changes you have made to the music, and it's wonderful!

It looks great, and works great.

It has really improved the music experience.

I am really impressed with what you have done Bart, so thank you so much.

I will continue testing and let you know how it goes.

Thanks once again.

Kind regards,
Robert.
Reply
Hi Bart

Noticed that when 'enable choosing default menu item' option is enabled while some menu items have been disabled or moved, default menu item isn't what have been chosen
Reply
Hi Bart,

One thing I have noticed, is that I think the playlist button in the music player that you added needs to become a "main menu choice".

By this I mean that I have found that if I do the following, for example:

1. Choose "party mode" from the main menu in music (a "main menu choice").
2. The party mode playlist shows.
3. I go to the music player by using your new button on the right.
4. I press return and I return to the party mode playlist.

However,

1. Choose "party mode" from the main menu in music (a "main menu choice").
2. The party mode playlist shows.
3. I go to the music player by using your new button on the right.
4. I go to the main menu to browse the movies whilst listening to the song (the song is shown in the now playing).
5. I return back to the main menu.
6. I hit return and return to the music player.
7. Then I go to the playlist by using your new playlist button.
8. Playlist pops up.
9. Then I go back into the player.
10. When I hit return it does not go back to the playlist.
11. It returns to the main menu, and when I use return, it goes to the player and this circle continues.

I have also found that I can "force" the focus back onto the playlist as follows:

1. Following on from number 11 above: (whilst the song is still playing), I go into an album.
2. I then bring up the left blade.
3. Choose playlist from this.
4. Then I go into player.
5. Then when I press return it goes back to the playlist.

It seems that the playlist option on the left blade also acts as a "main menu choice", and gives "focus" back to the playlist.

In other words, any "main menu choice" I make whilst in the player becomes the new focus for when I press return from the player.

So, to my mind, I thought that if you made the new icon in the player become a "main menu choice" it would always allow me to return to the playlist from th eplayer by pressing return.

Please excuse any lack of technical language!

Thank you so very much for everything.

Kind regards,
Robert.
Reply
(2022-01-19, 20:21)robertlaing Wrote: It seems that the playlist option on the left blade also acts as a "main menu choice", and gives "focus" back to the playlist.

In other words, any "main menu choice" I make whilst in the player becomes the new focus for when I press return from the player.

So, to my mind, I thought that if you made the new icon in the player become a "main menu choice" it would always allow me to return to the playlist from th eplayer by pressing return.

@robertlaing , unfortunately, this is not something I can change.  This is core Kodi behavior.  

What I did, to make it easier for you, is to add a "Current Playlist" submenu item in the Music main menu.  So, in your scenario, instead of just pressing Back (what you call return), Back from the main menu to go back to the player, just go to the music main menu, and click on the "Current Playlist" submenu item.  This should take you to the playlist, and then, when you go to the player from there, when you press Back you will return to the playlist.  

In essence, it's just less clicks than going into an album and then going to the sideblade and choosing "Playlist".

It's possible that when you update from GitHub, you will not see the new submenu item.  If that is the case, please quit Kodi, and delete the "script-skinshortcuts-includes.xml" file from the skin's 1080i folder.  You can then restart Kodi, and the menu/submenu will be rebuilt.

If you do not feel comfortable deleting skin files, I also changed the code so that you can add yourself the current music playlist as a menu or submenu item.  Just go to the menu configuration dialog, and add a new item.  In the following example, I am adding the Current Playlist to the submenu for the Music main menu item:

Image

Then go to Choose item for Menu, and select "Common":

Image

In there, you will find the option Current Playlist, select it:

Image

After that, just return to the main menu, and amber will rebuild the menu/submenu.  In my example, I get a new submenu item under the Music main menu item:

Image

You could also add this as a main menu item, for even less clicks when you want to return from the music player to the playlist.


Please let me know if this helps.  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
(2022-01-19, 20:14)G0mez Wrote: Hi Bart

Noticed that when 'enable choosing default menu item' option is enabled while some menu items have been disabled or moved, default menu item isn't what have been chosen

@G0mez , yes, that is a unwanted side effect of how that is coded.  You have to choose again the default menu item if you move, add,disable or delete any menu items.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
(2022-01-19, 19:36)robertlaing Wrote: Hi Bart,

I have continued switching the two helpers off and on, and after a lot of testing, this is what I have found:

I keep getting random results!

See what you think!

@robertlaing , could you please try the latest from GitHub? You can leave tmdb helper disabled and embuary helper enabled, so that you can get the dialog to choose from multiple items.  I have tested under that scenario, and things seem to be working as expected.  Please test and let me know what you find.  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
(2022-01-20, 00:03)bsoriano Wrote: @robertlaing , could you please try the latest from GitHub? You can leave tmdb helper disabled and embuary helper enabled, so that you can get the dialog to choose from multiple items.  I have tested under that scenario, and things seem to be working as expected.  Please test and let me know what you find.  Thanks.

Regards,

Bart
Hi Bart,

Firstly can I say thank you very much for all your hard work. I am very appreciative.

The music changes you have made are brilliant. I added the current music playlist as a submenu item, and it works perfectly.
For me, all these music changes have really elevated the experience.

As for the search issues in movies, I have done as you advised and have disabled tmdb helper and enabled embuary helper.

By doing this, the searches are back to working as they were after you fixed the issue of bombing out. So that's great.

However, when I click on any category containing more than one search item (ie: writer, director, genre) nothing happens at all.
No box pops up at all to give a choice.

On another small issue, I noticed that when I was testing using the Estuary skin when using online tmdb info, the movies I have in my collection have an icon, and any that I have watched out of those have an extra watched mark. Is this possible for you to add to the movies in the list in your online tmdb info page?

Thanks again Bart.

Kind regards,
Robert.
Reply
@robertlaing , I am not sure what is going that the searches are not working as expected for you. 

First, let's make sure we have the same settings.  When I wrote "enable embuary helper", I did not mean to just enable the addon, but to enable its use in Amber settings, as it is shown here:

Image

Second, my understanding is that you are only doing local searches, as shown here:

Image

With those settings, I get the following results:

Image

When I click on the writer for that movie, I get the following:

Image

Please confirm that you have those two settings as shown in the screenshots, and, of course, that you have the script.embuary.helper addon installed and enabled in your system.  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
(2022-01-20, 15:06)bsoriano Wrote: Second, my understanding is that you are only doing local searches
Hi Bart,

This was the problem!!!

I did originally have this set to local search only, but due to issues with Android 11, I have had to re-install the skin a number of times, and have obviously missed this setting out when checking things over after the last re-install!

So thank you for all your patience in this matter, you have solved my problem!

Everything works just as it should - what a pleasure!

However, I have noticed that if I do a search and find a movie I want to watch in that search, the following happens:

1. Click into movie's info page.
2. Press play.
3. Nothing appears to happen.
4. As soon as I back out of the search results the movie begins to play.

Is there any way this can play straight away after pressing the play button?

Kind regards,
Robert.
Reply
(2022-01-20, 17:40)robertlaing Wrote: 1. Click into movie's info page.
2. Press play.
3. Nothing appears to happen.
4. As soon as I back out of the search results the movie begins to play.

Is there any way this can play straight away after pressing the play button?

@robertlaing , thank you for your continued testing.  We are getting closer.  Could you please try the latest from GitHub? I think I fixed the issue of the media not playing.  Also, I am working on adding the overlays to the embuary info windows, as you also requested.  I am not done yet with that part.

Please let me know how it goes now.  Thanks.

Regards,

Bart
Amber Maintainer
Main HTPC: Intel Core i7, 32GB, nVidia GTX1080, Windows 11 Soundbar: Samsung HW-Q950A TV: LG CX Kodi: 19.3 Skin: Amber
Reply
  •   
  • 1
  • 278
  • 279
  • 280(current)
  • 281
  • 282
  • 294
  •   



Logout Mark Read Team Forum Stats Members Help
Amber for Leia/Matrix/Nexus5
This forum uses Lukasz Tkacz MyBB addons.